Announcement

Collapse
No announcement yet.

Struggling with UltraECM3

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Struggling with UltraECM3

    So UltraECM3 was the first Plug in I installed during my migration to HS3. I was excited about the new features and the ability to run without running the ECM engine. But...I never got it to work so I decided to wait until later to get it working.

    I have HS3 up and running now, with most things working as they should, so I tried to tackle UltraECM3 again...and I still can't get it working.

    I have 3 ECM-1240 devices, each connected to its own Serial Port through a QSE-100 serial to ethernet converter.

    I believe I've set up the three devices per the directions, but cannot seem to connect in Homeseer. I tried each device separately as well as all three together - same result no matter what.

    Upon start up, there aren't any error messages in the log:
    Jan-11 8:41:59 PM Informational Brultech ECM Device connection established to COM:5.
    Jan-11 8:41:59 PM Informational Brultech ECM Device connection established to COM:4.
    Jan-11 8:41:59 PM Informational Brultech ECM Device connection established to COM:3.
    Jan-11 8:41:59 PM Plug-In Finished initializing plug-in UltraECM3
    Jan-11 8:41:58 PM Info Plug-in UltraECM3 has connected successfully
    Jan-11 8:41:39 PM Plug-In Found plug-in: UltraECM3, version: 3.0.5036.31992
    However, I don't see any database inserts on the Status tab. I do see what appears to be successful connections on the HomeSeer device screen (these are the only UltraECM devices I see here):





    For the first UltraECM, I manually typed in the serial number. For the other two, I just typed in a random number to see if it would detect the serial number (per the instructions.) The serial numbers were not detected.





    I do see some errors in the log, but they are just connection errors:




    If I shutdown Homeseer and connect with the ECM Engine, I don't have any issues.




    Here is the setup screen for one of the ECMs:



    I made sure all relevant serial ports were closed after running the ECM engine.

    Any thoughts? Am I missing a set up step?

    Thanks,
    Scott
    Attached Files

  • #2
    Hello Scott. There is another Brultech program that you use to upgrade the firmware and set the packet format. Can you use that to confirm the units are set to send in binary format?

    Regards,
    Ultrajones
    Plug-ins: UltraMon, UltraM1G, UltraCID, Ultra1Wire, UltraLog, UltraWeatherBug, UltraPioneerAVR, UltraGCIR

    Comment


    • #3
      Originally posted by Ultrajones View Post
      Hello Scott. There is another Brultech program that you use to upgrade the firmware and set the packet format. Can you use that to confirm the units are set to send in binary format?

      Regards,
      Ultrajones
      Just downloaded ECM-1240 Application Interface program. Verified that all three are set to send in Binary format. I also updated the firmware to the latest (1.031). Unfortunately, I still have the same issue.

      Any other thoughts?

      Thanks,
      Scott

      Comment


      • #4
        For Troubleshooting purposes, try bypassing the QSE-100 serial to Ethernet converter with a direct serial connection from HomeSeer to the ECM1240.
        Plug-ins: UltraMon, UltraM1G, UltraCID, Ultra1Wire, UltraLog, UltraWeatherBug, UltraPioneerAVR, UltraGCIR

        Comment


        • #5
          The UltraECM3 HSPI uses a 15200 serial connection. Change the Serial connection from 9600 to 115200.
          Plug-ins: UltraMon, UltraM1G, UltraCID, Ultra1Wire, UltraLog, UltraWeatherBug, UltraPioneerAVR, UltraGCIR

          Comment


          • #6
            Originally posted by Ultrajones View Post
            The UltraECM3 HSPI uses a 15200 serial connection. Change the Serial connection from 9600 to 115200.
            Interesting. I can't seem to connect to them at 115,200, even through the Brultech software. I don't see a way to set the ECMs to a certain baud, I think it is set from whatever client you are using to connect to them.

            I'll play around and see what I can figure out. I don't have an easy way to connect an ECM direct to my Homeseer PC (no serial ports, and very far away) but there are a couple of settings I can play with (115,200 is supported by the QSE100.)

            Comment


            • #7
              Here's what I've tested:

              My old HS2 machine has a Moxa 8 Port Serial Card. I connected to one of my ECM-1240s with this card and ran the Brultech Software - I can connect to the ECM at 19,200 but cannot connect to the ECM at 115,200.

              I then installed UltraECM2 on my HS2 machine and it worked right away. Not sure if it is communicating at 19,200 or 115,200, but I'm assuming 19,200 since that's what worked using the ECM software.

              Finally, I connected the QSE100 to my HS2 machine and tried connecting to the same ECM as above. Just like with the onboard serial card, it connected at 19,200 but did not connect at 115,200 using the ECM software.

              Using UltraECM2, it again connected right away, but when looking at the diagnostics of the QSE100, it showed the connection was at 19,200.

              So...it appears to me that my ECM-1240s do NOT support connections at 115,200. I think I have some earlier models, so maybe they updated them at some point to support 115,200???

              I think you correctly identified that the issue is with the connection speed, but based on my testing, I don't think this is a result of the serial to ethernet device but is because my ECM units can't handle a 115,200 connection.

              Would it be possible to have this as a configurable option in the plugin? Otherwise, I don't think I'll be able to get it to work.

              Thanks so much.
              Scott

              Comment


              • #8
                Try the version I just uploaded to the HS3 updater. You'll need to set the default baud rate for the ECM-1240 in the options web page, then restart HomeSeer.
                Plug-ins: UltraMon, UltraM1G, UltraCID, Ultra1Wire, UltraLog, UltraWeatherBug, UltraPioneerAVR, UltraGCIR

                Comment


                • #9
                  Originally posted by Ultrajones View Post
                  Try the version I just uploaded to the HS3 updater. You'll need to set the default baud rate for the ECM-1240 in the options web page, then restart HomeSeer.
                  Works perfect now. Thanks so much!!!

                  Comment


                  • #10
                    I have to say...after playing with this plugin for just a little bit of time, it is by far the coolest plugin I have on my HS system. Very, very well thought out and mostly intuitive.

                    I think I'll have some questions and suggestions as I move forward, but this is really cool plugin. Love the graphs.

                    Comment

                    Unconfigured PHP Module

                    Collapse

                    Working...
                    X