Announcement

Collapse
No announcement yet.

UltraECM3 Questions

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • UltraECM3 Questions

    Attached Files
    Last edited by rprade; February 14th, 2014, 07:20 PM.
    Randy Prade
    Aurora, CO
    Prades.net

    PHLocation - Pushover - EasyTrigger - UltraECM3 - Ultra1Wire3 - Arduino

  • #2
    Just confirmed with separate instruments that the temperatures shown in the GEM Live Data interface are correct. The numbers in the ECM devices are incorrect. It seems at low temperatures they track correctly, but above 100F they seem to begin to track low.

    I'll do some more checking and see if I can come up with more information.
    Randy Prade
    Aurora, CO
    Prades.net

    PHLocation - Pushover - EasyTrigger - UltraECM3 - Ultra1Wire3 - Arduino

    Comment


    • #3
      An additional datapoint. If the GEM is reconfigured to Celsius the GEM and ECM temperature values track. If both are set to Fahrenheit the ECM temperature values are consistent with the GEM at lower values, but above 90F the ECM begins tracking low. At the highest temperature monitored the GEM reports an accurate 185 degrees while the ECM reported 123 degrees. This is consistent across the first three channels I added.
      Randy Prade
      Aurora, CO
      Prades.net

      PHLocation - Pushover - EasyTrigger - UltraECM3 - Ultra1Wire3 - Arduino

      Comment


      • #4
        Hello. I will reply to your first post once I get a chance to review it. As far as the temperature, the plug-in isn't doing any temperature conversion. It is just using the value provided by the GEM, then appending either an F or a C. I'll contact Brultech and ask them if there are any known issues with the binary output when setting the temperature to Fahrenheit in the GEM.

        Regards,
        Ultrajones
        Plug-ins: UltraMon, UltraM1G, UltraCID, Ultra1Wire, UltraLog, UltraWeatherBug, UltraPioneerAVR, UltraGCIR

        Comment


        • #5
          Originally posted by Ultrajones View Post
          Hello. I will reply to your first post once I get a chance to review it. As far as the temperature, the plug-in isn't doing any temperature conversion. It is just using the value provided by the GEM, then appending either an F or a C. I'll contact Brultech and ask them if there are any known issues with the binary output when setting the temperature to Fahrenheit in the GEM.

          Regards,
          Ultrajones
          I determined that there was no conversion as I was testing it, merely a change in the symbol after the temperature. It may very well be a problem in the data Brultech is sending in the packets as the temperatures on their Live Data page are always correct. Also with Celsius temperatures all being in a range below 90 the values fall into the range where the Values between the GEM and ECM track accurately. I'll also send Ben an email.
          Randy Prade
          Aurora, CO
          Prades.net

          PHLocation - Pushover - EasyTrigger - UltraECM3 - Ultra1Wire3 - Arduino

          Comment


          • #6
            I sent an email to Ben at Brultech and copied your Hotmail account.
            Randy Prade
            Aurora, CO
            Prades.net

            PHLocation - Pushover - EasyTrigger - UltraECM3 - Ultra1Wire3 - Arduino

            Comment


            • #7
              Re: UltraECM3 Questions

              Originally posted by rprade View Post
              In UltraECM3 Channel configuration I am a little unclear of the meaning of some of the columns specifically “Post” and “Main”. I can make assumptions, but would prefer to understand your concepts.

              In UnltraECM3 Dashboard view I do not understand the Main x true x false and enabled x true with dropdowns. Neither of the dropdowns do anything nor do the true and false buttons. What is their purpose?
              Here's a web link for details about post and main.
              http://forums.homeseer.com/showpost....10&postcount=9

              When on your channel setup page if you tick "main" for your main CTs, then the function of adding or removing them within dashboard will work.

              Main - True = will display all Main CTs on dashboard when chosen and will remove when unchosen.
              Main - False= will display all your Circuit CTs on dashboard when chosen and will remove when unchosen.

              Post = Reporting data to 3rd party website. I never looked into this so I'm unsure any benefit in doing so if your running the GEM and ECM 2 or 3.

              I also feel your pain about the character limit on the gauges. I had to rethink and use knick names to get the text to fix. Not a major deal but it might have been nice if the text would "wrap" like such when using excel.

              This is one of my more favorite plugins. There's lots on my list to request for mods but just lack time and energy.

              On another note, its not listed in any manual but it would be wise to add the sum of all your circuits to compare against the draw of the Main CTs. Even with all the OCD efforts we made, there were still a couple CTs that were facing the wrong direction. Most issues we found were on the 240v loads that contains a 120v load and also circuit channels that had 2 or more micro CTs. In one case wiring a circuit up we had 2 CTs producing positive and 1 ct producing a negative,

              Sent from my Nexus 7 using Tapatalk
              HSPro: 3.0.0.194
              PL: Insteon PLM 3.0.5.20,Insteon Thermostat 3.0.1.1 , UltraM1G, RainRelay8, UltraECM3, UltraPioneerAVR3, BLBackup, weatherXML, Jon00 Network & PC Monitor
              HW : Win 7 64bit, Intel i7-2600, 16 GB DDR3 Ram, 60 Plus Insteon Dual Band Devices, Rain8 Pro2, Elk M1 Gold, Brueltech GreenEye.

              Comment


              • #8
                Originally posted by CharlieWayne View Post
                Here's a web link for details about post and main.
                http://forums.homeseer.com/showpost....10&postcount=9
                ....
                Thanks for the help. The x True and x False buttons weren't working intuitively for me. When I clicked on x False beside Main, all the other channels went away, when I clicked on x True beside Enabled, nothing happened. I should have gone further because clicking on x True beside Main then shows all the other channels and then choices are on the dropdowns and the True and False buttons go away. Chosing False on the Main dropdown then gives me all of the channels except Main. Now that I understand the logic it works fine.
                Randy Prade
                Aurora, CO
                Prades.net

                PHLocation - Pushover - EasyTrigger - UltraECM3 - Ultra1Wire3 - Arduino

                Comment


                • #9
                  Originally posted by rprade View Post
                  I sent an email to Ben at Brultech and copied your Hotmail account.
                  << 8 | lo & 0xFF)
                  else:
                  return -1*((hi & 0x7F) << 8 | lo & 0xFF)

                  Bolded the difference, I was previously shifting the hi-byte left 7 times, it should be shifted 8 times."
                  Randy Prade
                  Aurora, CO
                  Prades.net

                  PHLocation - Pushover - EasyTrigger - UltraECM3 - Ultra1Wire3 - Arduino

                  Comment


                  • #10
                    Yes, I did use their temperature code sample. This bug is fixed as of UltraECM3 HSPI version 3.0.5162.23080. It should be in the updater in about 15 minutes.

                    Regards,
                    Ultrajones
                    Plug-ins: UltraMon, UltraM1G, UltraCID, Ultra1Wire, UltraLog, UltraWeatherBug, UltraPioneerAVR, UltraGCIR

                    Comment


                    • #11
                      Originally posted by Ultrajones View Post
                      Yes, I did use their temperature code sample. This bug is fixed as of UltraECM3 HSPI version 3.0.5162.23080. It should be in the updater in about 15 minutes.

                      Regards,
                      Ultrajones
                      Thanks for the help.
                      Randy Prade
                      Aurora, CO
                      Prades.net

                      PHLocation - Pushover - EasyTrigger - UltraECM3 - Ultra1Wire3 - Arduino

                      Comment

                      Working...
                      X