Announcement

Collapse
No announcement yet.

EltraECM3 errors began last night

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • EltraECM3 errors began last night

    These errors began appearing in the HS3 log at 10:27 lats night. They continued continuously, once every 5 seconds, until I noticed them at 1:07 this afternoon. I disabled the plug-in and enabled it again and those errors have not returned.

    Aug-21 10:22:47 PM 1 Error System.OverflowException
    Aug-21 10:22:42 PM 1 Error System.OverflowException: Arithmetic operation resulted in an overflow. at HSPI_ULTRAECM3.Device.processPacket(UInt32 seconds, UInt64[] wattSeconds, UInt16 volt, UInt64[] pulseCounters, Double[] tempSensors)
    Aug-21 10:22:42 PM 1 Error System.OverflowException
    Aug-21 10:22:37 PM 1 Error System.OverflowException: Arithmetic operation resulted in an overflow. at HSPI_ULTRAECM3.Device.processPacket(UInt32 seconds, UInt64[] wattSeconds, UInt16 volt, UInt64[] pulseCounters, Double[] tempSensors)
    Aug-21 10:22:37 PM 1 Error System.OverflowException

    After I enabled it again, I got a series of new errors.


    Aug-22 1:08:01 PM Error SQL Exception updating device record in the database: SQL logic error or missing database no such column: NaN, Code=1, Link=
    Aug-22 1:08:01 PM Database ERROR, device Energy GEM Watts Realtime [US Bath, Chest Freezer] failed to be updated or added to the database.
    Aug-22 1:08:01 PM Error SQL Exception updating device record in the database: SQL logic error or missing database no such column: NaN, Code=1, Link=
    Aug-22 1:07:47 PM Informational Brultech ECM Device connection established to 192.168.2.7:80.
    Aug-22 1:07:47 PM Plug-In Finished initializing plug-in UltraECM3

    They continued for about a minute and these two errors:

    Aug-22 1:08:07 PM Database Error - Save of the devices to the database did not succeed - see the log for more details.

    Aug-22 1:08:45 PM Database There were errors generated during the save of the database item. Please consult this log for more details and report any data loss to HomeSeer Technologies.

    I am going to restart HomeSeer.

    I don't know what other information I can provide or what to do to correct the problem. I had debug logging level enabled.
    Randy Prade
    Aurora, CO
    Prades.net

    PHLocation - Pushover - EasyTrigger - UltraECM3 - Ultra1Wire3 - Arduino

  • #2
    It looks like you were experiencing a problem with HomeSeer too. Did a reboot resolve the issue?
    Plug-ins: UltraMon, UltraM1G, UltraCID, Ultra1Wire, UltraLog, UltraWeatherBug, UltraPioneerAVR, UltraGCIR

    Comment


    • #3
      Seems like it did.
      Randy Prade
      Aurora, CO
      Prades.net

      PHLocation - Pushover - EasyTrigger - UltraECM3 - Ultra1Wire3 - Arduino

      Comment


      • #4
        It hasn't come back. I am assuming HS3 does some sort of repair or roll-back if there are database errors.
        Randy Prade
        Aurora, CO
        Prades.net

        PHLocation - Pushover - EasyTrigger - UltraECM3 - Ultra1Wire3 - Arduino

        Comment

        Working...
        X