Announcement

Collapse
No announcement yet.

UltraECM2 Watchdog Timer Setting

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • UltraECM2 Watchdog Timer Setting

    I routinely get:
    m/d/yyyy h:mm:ss PM UltraECM2 Warning Watchdog Timer indicates No response response from the Brultech device '192.168.x.xxx:xxxx' for 304 seconds.. Attempting to reconnect ...
    m/d/yyyy h:mm:ss PM UltraECM2 Info Brultech ECM Device connection to 192.168.x.xxxx (192.168.x.xxx:xxxx)
    m/d/yyyy h:mm:ss PMUltraECM2 Info Watchdog Timer reconnect attempt succeeded.

    My questions:
    1. Can I change the Watchdog Timer from 300 seconds to something else? If so, how?
    2. Is anyone else seeing this? Or did I configure something wrong?
    3.

  • #2
    Ken,

    This sounds similar to a problem I just worked though with my GEM on HS3. There are differences, I have slightly newer COM firmware and you are on HS2 but I have attached the settings that finally resolved this for me. You might try and see if this helps. Be sure to keep track of the settings you have now in case you need to revert back to what you had. Good luck.

    Jerry
    Attached Files

    Comment


    • #3
      Jerry,
      Thanks. The changes from my setup were the Packet Chunk Interval (from 200 to 22), Keep-Alive Pulse (from Enabled to Disabled), and COM1 Flow (from Enabled to Disabled).

      At first it seemed to be clicking along smoothly but it is back to every ~300 seconds getting the UltraECM2 Warning of the Watchdog Timer.

      I am unable to get to the Wifi-Uart Setting (first page of your .pdf). If I go to http://xxx.xxx.xxx.xxx/home.html I’m required to input a user name/password…”The Site Says “A11”” and I do not know what that is…can’t find it in any of the manuals.

      By chance did you upgrade your COM firmware? I'm curious on how long it took for the upgrade because I aborted mine after about an hour and the progress bar was not above 1%.

      Also where did you get COM V3.21? I’ve searched and the best I can get is V3.18.

      Again, appreciate it.
      Ken J.

      Comment


      • #4
        At the password prompt use "admin" for both the user name and password - I see it identify itself as A11 too. By the way my document showed a TCP Timeout of 0 and I think this should probably be left at the default of 300 instead.

        I have not updated my GEM firmware as I just bought it and it already had the latest.

        I also do not believe I changed the packet chunk interval and it's possible that it might be best to leave the COM1 flow enabled. The keep-alive setting may not matter at all in the server mode. The settings in the document were what mine are that are working but I went though quite a few settings and work with Ultrajones and Brultech before I got things working. I already set my TCP timeout back to 300 and will probably re-enable the COM1 flow.

        The critical settings to get the timeouts to stop were settimg server mode in application setup, the packet and network tabs and the UltraECM3 tab.

        Also please note ultrajones is the expert here and he may have better information.

        Comment


        • #5
          It looks like the TCP Timeout must be set to 0 or the timeouts will occur. Ignore my previous comment.

          Comment


          • #6
            Jerry,
            Thanks on letting me know your successful setup and the password...that was really bugging me.

            I set TCP Time out to 0 - rebooted it and didn't seem to help. Then I changed the CTSRTS (UART Setting) from Disable to Enable like you have it, rebooted and have been running solid now with no Watchdog warning for over 30 minute. Not saying it was the CTSRTS setting or a combination of the two or just not letting it 'settle' after rebooting but whatever it was it seems to have done the trick.

            What I find interesting on the Firmware is I'm actually running at COM V3.17 and you are at COM V3.21...neither is available for download from Brultech. Brultech has V3.16, and V3.18. Needless to say I'm not going to muck with my firmware now.

            Right now my settings are mirroring yours across the board (except server address and COM firmware) and life seems to be good!

            Ken J.

            Comment


            • #7
              Attached Files
              Plug-ins: UltraMon, UltraM1G, UltraCID, Ultra1Wire, UltraLog, UltraWeatherBug, UltraPioneerAVR, UltraGCIR

              Comment


              • #8
                Thanks Ultra. I tweaked my setup a little based on your post (Packet Chunk size). Based on input from Jerry and you everything is humming along great now!

                Ken J.

                Comment


                • #9
                  Ken,
                  I'm having the same issue with the watchdog timer reporting no response for over 300 seconds.

                  I looked through the threads but am a little confused as to what exact settings you ended up with in the end. It looks like a combination of Jerry and Ultras settings.

                  I have COM Ver 4.0 ENG Ver 1.49 and use the wifi of the combined wifi/ethernet module.

                  What did you set for:
                  Packet Chunk Size
                  Packet Chunk Interval Time
                  Idle Time etc?

                  Do you need to reboot every time you make a change?

                  Help appreciated. Marty
                  iCore5 Win 10 Pro x64 SSD

                  HS3 Pro Edition 3.0.0.435 Windows

                  BLOccupied:,Device History:,Yamaha:,UltraMon3:,mcsXap:,Restart:,UltraNetatmo3:, UltraM1G3:,Ultra1Wire3:,BLBackup:,Harmony Hub:,DoorBird:,UltraECM3:,Nanoleaf 3P:,UltraRachio3:,Z-Wave:,SDJ-Health:,BLGarbage:,Blue-Iris:,Chromecast:,Pushover 3P:,EasyTrigger:

                  Comment


                  • #10
                    Marty,
                    Sorry for not getting back sooner...life events getting in the way of my home automation.

                    The key for me was in the GEM hardware setup. Go into the ip of the GEM with no ':8000' (the ':8000' puts you into the Monitor).

                    Click on the 'Application Setting' (left side) and it will bring up the 'Wifi-Uart Setting Window'. Change the CTSRTS to 'Enable', hit apply, and then restart the GEM unit.

                    Also I matched what Ultra posted above in the GEM Monitor sections ('Packet Send' and 'Adv').

                    Ken J.

                    Comment


                    • #11
                      Thanks Ken. I eventually got it sorted. And the net values are working too thanks to Ultra's efforts.
                      iCore5 Win 10 Pro x64 SSD

                      HS3 Pro Edition 3.0.0.435 Windows

                      BLOccupied:,Device History:,Yamaha:,UltraMon3:,mcsXap:,Restart:,UltraNetatmo3:, UltraM1G3:,Ultra1Wire3:,BLBackup:,Harmony Hub:,DoorBird:,UltraECM3:,Nanoleaf 3P:,UltraRachio3:,Z-Wave:,SDJ-Health:,BLGarbage:,Blue-Iris:,Chromecast:,Pushover 3P:,EasyTrigger:

                      Comment

                      Working...
                      X