Announcement

Collapse
No announcement yet.

GEM failure, now problems with the plug-in

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • GEM failure, now problems with the plug-in

    The 5-volt power supply for my GEM failed in the middle of the night Sunday night. This caused the GEM to fail to boot. I replaced the power supply getting the GEM to work again, but the plug-in was no longer getting data with the watchdog timer showing no connection and attempting a reconnect every few seconds. After exhausting every possibility to do with the GEM hardware and Ethernet connection, I rolled back HomeSeer to a backup taken at midnight Saturday night. This restored connection of the plug-in and the devices now update. Unfortunately the log is filled with errors:

    Oct-06 12:55:48 PM 1 Error System.OverflowException: Arithmetic operation resulted in an overflow. at HSPI_ULTRAECM3.Device.processPacket(UInt32 seconds, UInt64[] wattSeconds, UInt16 volt, UInt64[] pulseCounters, Double[] tempSensors)
    Oct-06 12:55:48 PM 1 Error System.OverflowException
    Oct-06 12:55:43 PM 1 Error System.OverflowException: Arithmetic operation resulted in an overflow. at HSPI_ULTRAECM3.Device.processPacket(UInt32 seconds, UInt64[] wattSeconds, UInt16 volt, UInt64[] pulseCounters, Double[] tempSensors)
    Oct-06 12:55:43 PM 1 Error System.OverflowException
    Oct-06 12:55:38 PM 1 Error System.OverflowException: Arithmetic operation resulted in an overflow. at HSPI_ULTRAECM3.Device.processPacket(UInt32 seconds, UInt64[] wattSeconds, UInt16 volt, UInt64[] pulseCounters, Double[] tempSensors)
    Oct-06 12:55:38 PM 1 Error System.OverflowException


    I restored the HomeSeer database to today's version so that I didn't lose events I had edited, but the errors continue.

    I sent a couple of emails.

    Is there any way I can get the errors to stop, or are there any ideas what could be corrupted causing the GEM to be unable to communicate?
    Randy Prade
    Aurora, CO
    Prades.net

    PHLocation - Pushover - EasyTrigger - UltraECM3 - Ultra1Wire3 - Arduino

  • #2
    There's a bad batch of power supplies that came with the GEMs. You need at least 2 amps if I recall to have Both the COMMS and ENG running. If its less than the COMMS wont work and you wont be able to connect.
    HSPro: 3.0.0.194
    PL: Insteon PLM 3.0.5.20,Insteon Thermostat 3.0.1.1 , UltraM1G, RainRelay8, UltraECM3, UltraPioneerAVR3, BLBackup, weatherXML, Jon00 Network & PC Monitor
    HW : Win 7 64bit, Intel i7-2600, 16 GB DDR3 Ram, 60 Plus Insteon Dual Band Devices, Rain8 Pro2, Elk M1 Gold, Brueltech GreenEye.

    Comment

    Working...
    X