Announcement

Collapse
No announcement yet.

Errors after update

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Errors after update

    I updated to the latest version last night and see this in the log since:
    Nov-02 9:44:33 AMErrorObject reference not set to an instance of an object.Nov-02 9:44:33 AM1ErrorSystem.IndexOutOfRangeException: Index was outside the bounds of the array. at HSPI_ULTRAECM3.Device.processPacket(UInt32 seconds, UInt64[] wattSeconds, UInt64[] polWattSeconds, UInt16 volt, UInt64[] pulseCounters, Double[] tempSensors)Nov-02 9:44:33 AM1ErrorSystem.IndexOutOfRangeExceptionNov-02 9:44:14 AMErrorObject reference not set to an instance of an object.Nov-02 9:44:14 AM1ErrorSystem.IndexOutOfRangeException: Index was outside the bounds of the array. at HSPI_ULTRAECM3.Device.processPacket(UInt32 seconds, UInt64[] wattSeconds, UInt64[] polWattSeconds, UInt16 volt, UInt64[] pulseCounters, Double[] tempSensors)Nov-02 9:44:14 AM1ErrorSystem.IndexOutOfRangeException
    Replaced the exe and aspx files with those from the previous version, and things seem to have quieted down again.
    (Disabled plug-in. Copied old files over new ones. Restarted plug-in.)
    Mike____________________________________________________________ __________________
    HS3 Pro Edition 3.0.0.548

    HW: Stargate | NX8e | CAV6.6 | Squeezebox | PCS | WGL 800RF, Rain8Net+ | RFXCOM | QSE100D | Vantage Pro | Green-Eye | X10: XTB-232, -IIR | Edgeport/8 | Way2Call | Ecobee3

  • #2
    I am sorry about that. Thank you for reporting the issue. The issue was related to adding Net channel support and would only affect those that have a Brultech ECM 1240. Please download and install UltraECM3 version 3.0.5784.37408 to see if it fixes the issue you reported.

    Regards,
    Ultrajones
    Plug-ins: UltraMon, UltraM1G, UltraCID, Ultra1Wire, UltraLog, UltraWeatherBug, UltraPioneerAVR, UltraGCIR

    Comment


    • #3
      Thank you for the quick response. Just installed 37408. No errors and it appears to be running without issue. I'll post back if and problems show up later.
      Mike____________________________________________________________ __________________
      HS3 Pro Edition 3.0.0.548

      HW: Stargate | NX8e | CAV6.6 | Squeezebox | PCS | WGL 800RF, Rain8Net+ | RFXCOM | QSE100D | Vantage Pro | Green-Eye | X10: XTB-232, -IIR | Edgeport/8 | Way2Call | Ecobee3

      Comment


      • #4
        Ultra,

        I haven't had any luck with any of the releases after 3.0.5579.19855. I have a GEM. With 3.0.5773.39268 I lose connection with the GEM right after update. I then replace the exe and aspx files with those from 3.0.5579.19855, and it works again. With 3.0.5784.37408 it first shows a status of "WARNING: Failed getting InterfaceStatus from UltraECM3 - the interface was not found in the list of active interfaces, the list may need to be refreshed." and then UltraECM disappears completely. I go to my HS3 folder and the exe is gone. Copying the exe back (3.0.5579.19855) and replacing the aspx file again restores operation. Any ideas?

        Comment


        • #5
          I've installed 3.0.5784.37408 and have no errors and the net usage still works. But I checked my logs and never have had any errors with the previous version, if that is of any help working with jmjones to sort his problem.
          Marty
          iCore5 Win 10 Pro x64 SSD

          HS3 Pro Edition 3.0.0.435 Windows

          BLOccupied:,Device History:,Yamaha:,UltraMon3:,mcsXap:,Restart:,UltraNetatmo3:, UltraM1G3:,Ultra1Wire3:,BLBackup:,Harmony Hub:,DoorBird:,UltraECM3:,Nanoleaf 3P:,UltraRachio3:,Z-Wave:,SDJ-Health:,BLGarbage:,Blue-Iris:,Chromecast:,Pushover 3P:,EasyTrigger:

          Comment


          • #6
            Never mind. Bit by my anti-virus software again. You'd think I would learn.

            Comment

            Working...
            X