Announcement

Collapse
No announcement yet.

Setting up Kinect

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Setting up Kinect

    I have a 360 Kinect. That is not a standard USB cable I don't think. Am I supposed to have a power supply? And what's up with that notta-usb connector?

  • #2
    Here purchased combo power supplies for the Kinects on Ebay for around $10.00.
    - Pete

    Auto mator
    Homeseer 3 Pro - 3.0.0.500 (Linux) - Ubuntu 18.04 64 bit Intel CPU - Mono 5.18
    Homeseer Zee2 (Lite) - 3.0.0.531 (Linux) - ARMBian Ubuntu 18.04 64 bit Arm CPU - Mono 5.20

    X10, UPB, Zigbee, ZWave and Wifi MQTT automation.

    Comment


    • #3
      if your kinect 369 does not come with a standard USB cable, here is what you need: https://www.amazon.com/360-Kinect-Se...+adapter&psc=1

      Comment


      • #4
        Alright, so, I was playing around with this last week. It was somewhat working. I had to put the threshold down to .2 or something not sure if that's normal. I set up 'cortana' as my activation word (forget what you call this). I had it trigger my living room AV on and off events (not a good idea-1). I added a grammar just to play around with not using an activation word (lol not a good idea-2). I named this Grammar "Living Room". I think it worked a few times, and then everything started powering on and off in a loop. I deleted the event right away, and the madness stopped. So now i'm back to troubleshooting. I cant get the Grammar to delete, I hit the red x and it doesn't delete. I re-installed the plugin, but to my surprise the grammar was still there, and still won't delete. I then created another grammar, and was able to delete that one, so I thought maybe it's bound to 'events', so I deleted all the voice events, and then started looking for the few devices I had went in and put phrases in the voice command box. I'm not sure I found them all and am unsure how you would go about finding them all as opening up every device would be insane, so surely whatever you put there shouldn't matter, and gave up.
        I built a more civilized event to test out the VR a I created an event that if a phrase was recognized "can you hear me" 'Speak: "Yes I can hear you". If I manually trigger this event, it speaks 'Yes I can hear you", but I can never get the VR to work in triggering this. It's broke or something. And it has something to do with me not able to delete that grammar. So I looked in the logs, and when I say "living room on", or "living room off" I consistently get this dev13, and dev14 entries in the log. *Note I don's say 'cortana', these are triggered with just "turn livingroom off/on. Thoughts?

        Dec-04 8:39:31 PM Kinect DEBUG Looking for triggers with evRef=14
        Dec-04 8:39:31 PM Kinect DEBUG Saving global variables: END
        Dec-04 8:39:31 PM Kinect DEBUG Saving global variables: BEGIN
        Dec-04 8:39:31 PM Kinect DEBUG Cortana Living Room On
        Dec-04 8:39:31 PM Kinect DEBUG Phrase recognized with confidence=0.5464388
        Dec-04 8:39:24 PM Kinect DEBUG Looking for triggers with evRef=14
        Dec-04 8:39:24 PM Kinect DEBUG Saving global variables: END
        Dec-04 8:39:24 PM Kinect DEBUG Saving global variables: BEGIN
        Dec-04 8:39:24 PM Kinect DEBUG Cortana Living Room On
        Dec-04 8:39:24 PM Kinect DEBUG Phrase recognized with confidence=0.5872403
        Dec-04 8:39:10 PM Kinect DEBUG Looking for triggers with evRef=13
        Dec-04 8:39:10 PM Kinect DEBUG Saving global variables: END
        Dec-04 8:39:10 PM Kinect DEBUG Saving global variables: BEGIN
        Dec-04 8:39:10 PM Kinect DEBUG Cortana Living Room Off
        Dec-04 8:39:10 PM Kinect DEBUG Phrase recognized with confidence=0.5336087
        Dec-04 8:39:01 PM Kinect DEBUG Looking for triggers with evRef=13
        Dec-04 8:39:01 PM Kinect DEBUG Saving global variables: END
        Dec-04 8:39:01 PM Kinect DEBUG Saving global variables: BEGIN
        Dec-04 8:39:01 PM Kinect DEBUG Cortana Living Room Off
        Dec-04 8:39:01 PM Kinect DEBUG Phrase recognized with confidence=0.5381784

        Comment


        • #5
          Originally posted by tome10 View Post
          Alright, so, I was playing around with this last week. It was somewhat working. I had to put the threshold down to .2 or something not sure if that's normal. I set up 'cortana' as my activation word (forget what you call this).
          No it's not normal, this is really low.
          Have you try with another activation word?

          Originally posted by tome10 View Post
          I had it trigger my living room AV on and off events (not a good idea-1). I added a grammar just to play around with not using an activation word (lol not a good idea-2). I named this Grammar "Living Room". I think it worked a few times, and then everything started powering on and off in a loop. I deleted the event right away, and the madness stopped. So now i'm back to troubleshooting. I cant get the Grammar to delete, I hit the red x and it doesn't delete. I re-installed the plugin, but to my surprise the grammar was still there, and still won't delete. I then created another grammar, and was able to delete that one, so I thought maybe it's bound to 'events', so I deleted all the voice events, and then started looking for the few devices I had went in and put phrases in the voice command box. I'm not sure I found them all and am unsure how you would go about finding them all as opening up every device would be insane, so surely whatever you put there shouldn't matter, and gave up.
          I built a more civilized event to test out the VR a I created an event that if a phrase was recognized "can you hear me" 'Speak: "Yes I can hear you". If I manually trigger this event, it speaks 'Yes I can hear you", but I can never get the VR to work in triggering this. It's broke or something. And it has something to do with me not able to delete that grammar. So I looked in the logs, and when I say "living room on", or "living room off" I consistently get this dev13, and dev14 entries in the log. *Note I don's say 'cortana', these are triggered with just "turn livingroom off/on. Thoughts?
          I'm not 100% sure why you can't delete the grammar, but it may be the fact that it's name has a space in it. Anyway to delete it manually: disable the plugin, edit Config/Kinect.ini and delete the grammar in the [ VOICE_RECOGNITION] section.

          Your confidence threshold is so low that the VR engine may understand Cortana even if you don't say it.

          Comment


          • #6
            I got the Grammar deleted. The system isn't responding. I see this in the speaker client when I try to get a response there. What does this mean? On a side note, any way to get Blue Iris to handle the Kinect's video? When I try to access the snapshot pic, it says "error connection refused". Ideas?
            12/6/2017 8:36:46 PM:Error loading grammar file C:\Program Files\HomeSeer HS3\Grammar\Grammar_hometroller#Default_Final.xml : Exception from HRESULT: 0x80045003
            Last edited by tome10; December 6th, 2017, 10:23 PM.

            Comment


            • #7
              Originally posted by tome10 View Post
              I got the Grammar deleted. The system isn't responding. I see this in the speaker client when I try to get a response there. What does this mean? On a side note, any way to get Blue Iris to handle the Kinect's video? When I try to access the snapshot pic, it says "error connection refused". Ideas?
              I don't know what this error means, but it's not related to kinect. The kinect plugin VR is totally independent from the HS speaker client.
              If you set the log level to Trace from the config page, and then restart the Kinect plugin, you will see in the logs what commands are loaded in the main grammar, and you will see what the VR engine understand when you try to say something.

              Don't know anything about Blue Iris. The kinectsnapshot url is serving standard jpeg file, so not sure what could be wrong.

              Comment


              • #8
                I set the debug to trace, power cycled everything. Tried the "can you hear me" event, but no response. The only thing I get in the logs is this.
                Dec-07 8:41:39 AM Kinect DEBUG Frame skipped

                Comment


                • #9
                  please post the logs you get when you start the plugin instance

                  Comment


                  • #10
                    I grabbed another Kinect today to make sure it wasn't a bad mic in play. I tried a few different attention words, and I also built two more 'if phrase is recognized' events to turn the living room lamp on/off (two separate events). if recognized; "Turn the living room lamp off". I still get no response. As a novice, I'd say it is booting up fine, but I don't know what I'm looking at. Here's the log.

                    Dec-07 10:42:42 PM Kinect DEBUG Frame skipped
                    Dec-07 10:42:41 PM Kinect DEBUG Building Grammars
                    Dec-07 10:42:41 PM Plug-In Finished initializing plug-in Kinect
                    Dec-07 10:42:41 PM Kinect DEBUG End Init Dec-07 10:42:41 PM Kinect INFO Kinect initialized
                    Dec-07 10:42:41 PM Kinect DEBUG Snapshot server started: http://*:8078/kinectsnapshot/
                    Dec-07 10:42:41 PM Kinect DEBUG Starting Speech Recognition
                    Dec-07 10:42:41 PM Kinect DEBUG Web Pages Registered
                    Dec-07 10:42:41 PM Kinect DEBUG Visual Recognition Initialized
                    Dec-07 10:42:40 PM Kinect DEBUG Writing image file Kinect/zones/zones1.jpg
                    Dec-07 10:42:40 PM Kinect DEBUG Deleting image file Kinect/zones/zones0.jpg
                    Dec-07 10:42:40 PM Kinect DEBUG Drawing Zones File
                    Dec-07 10:42:40 PM Kinect DEBUG CreateZoneDevice: End Enumerating Devices Dec-07 10:42:40 PM Kinect DEBUG CreateZoneDevice: Start Enumerating Devices
                    Dec-07 10:42:40 PM Kinect DEBUG Voice Recognition Initialized
                    Dec-07 10:42:40 PM Kinect DEBUG USB\VID_0409&PID_005A\5&1DDF47FD&0&7 status=Connected
                    Dec-07 10:42:40 PM Kinect INFO Kinect version 3.0.0.45
                    Dec-07 10:42:40 PM Kinect DEBUG Logger Initialized
                    Dec-07 10:42:39 PM Info Plugin Kinect has connected. IP:127.0.0.1:53675 Dec-07 10:42:32 PM Info Plugin Kinect with instance: has disconnected Dec-07 10:42:32 PM Kinect DEBUG System.Net.HttpListenerException (0x80004005): The I/O operation has been aborted because of either a thread exit or an application request at System.Net.HttpListener.GetContext() at HSPI_KINECT.SnapshotServer.b__0()
                    Dec-07 10:42:32 PM Kinect DEBUG Snapshot server stopped
                    Dec-07 10:42:32 PM Kinect DEBUG Stopping Speech Recognition
                    Dec-07 10:42:32 PM Plug-In Shutting down Plug-In: Kinect

                    Comment


                    • #11
                      Originally posted by tome10 View Post
                      I grabbed another Kinect today to make sure it wasn't a bad mic in play. I tried a few different attention words, and I also built two more 'if phrase is recognized' events to turn the living room lamp on/off (two separate events). if recognized; "Turn the living room lamp off". I still get no response. As a novice, I'd say it is booting up fine, but I don't know what I'm looking at. Here's the log.
                      What trigger do you use for your events?
                      The regular "A phrase was recognized" trigger does not work with kinect, you need to use a specific Kinect trigger, read the user guide: https://forums.homeseer.com/showthre...58#post1082258

                      Comment


                      • #12

                        Comment


                        • #13

                          Comment


                          • #14
                            The zone setup is only for visual recognition.

                            Comment


                            • #15
                              I think I have a bad Kinect. the first one always has a low 2-3 confidence, but the other has 6-8 confidence. determined from the same location using the trace log tool.

                              Comment

                              Working...
                              X