Announcement

Collapse
No announcement yet.

Ambient Noise

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Ambient Noise

    Anyone having luck triggering events while TV or radio is on near by. I have it set up in my living room and when the TV is on it won't trigger any of my commands. As soon as I mute the TV it works fine. I had beside the TV and speakers so I moved it 20 feet away and it's the same. Is it just me or is everyone the same.

  • #2
    This is a very common issue with VR, one of which people doesn't like to speak off since it will degrade their 'success story'

    The proper way to solve this is by using an audio mixer like the AP800 or XAP800. There are other mixers on the market but i know and use these ones.

    Comment


    • #3
      Originally posted by freeon View Post
      Anyone having luck triggering events while TV or radio is on near by. I have it set up in my living room and when the TV is on it won't trigger any of my commands. As soon as I mute the TV it works fine. I had beside the TV and speakers so I moved it 20 feet away and it's the same. Is it just me or is everyone the same.
      if you can feed the audio of the TV into the computer which is running the kinect plugin, you could try the "Echo cancellation" feature.

      Comment


      • #4
        Originally posted by spud View Post
        if you can feed the audio of the TV into the computer which is running the kinect plugin, you could try the "Echo cancellation" feature.

        Is it as simple and running an audio cable into the computer (remote instance?), or does it have to have some program running to understand the audio as well?

        One of my other remote instances is on my HTPC which is the source of the audio. I haven't tried echo cancellation on that one yet, but is that all I need to do, turn it on?

        Thanks!

        Comment


        • #5
          Originally posted by ckellyusa View Post
          Is it as simple and running an audio cable into the computer (remote instance?), or does it have to have some program running to understand the audio as well?

          One of my other remote instances is on my HTPC which is the source of the audio. I haven't tried echo cancellation on that one yet, but is that all I need to do, turn it on?

          Thanks!
          Actually the Echo cancellation feature filters out the sound that goes out of the speakers configured as your default playback device in windows.

          It's easy to see if it works or not, set the log level to Trace, start a movie, then with the Echo cancellation turned off you will see in the logs (or in the console) that the kinect plugin tries to interpret the movie's dialogues as commands; with echo cancellation turned on, nothing should be written to the log unless there is some other sound/voices in the room that the plugin tries to understand.

          That being said some users have reported some problems with this feature, like it can make the VR got stuck, it doesn't work if the default audio output is a digital audio output, ...
          Personnally I didn't test it extensively, and I have not much control over it in the plugin's code (it's just a flag from the kinect SDK I turn on or off)

          I would love some more feedback about this feature, if anyone tested it.

          Comment


          • #6
            Originally posted by spud View Post
            Actually the Echo cancellation feature filters out the sound that goes out of the speakers configured as your default playback device in windows.

            It's easy to see if it works or not, set the log level to Trace, start a movie, then with the Echo cancellation turned off you will see in the logs (or in the console) that the kinect plugin tries to interpret the movie's dialogues as commands; with echo cancellation turned on, nothing should be written to the log unless there is some other sound/voices in the room that the plugin tries to understand.

            That being said some users have reported some problems with this feature, like it can make the VR got stuck, it doesn't work if the default audio output is a digital audio output, ...
            Personnally I didn't test it extensively, and I have not much control over it in the plugin's code (it's just a flag from the kinect SDK I turn on or off)

            I would love some more feedback about this feature, if anyone tested it.
            Wonder if that's the problem with my MasterBedroom remote instance. I'll leave it on for now and see when it crashes and report back in my other thread.

            Comment


            • #7
              Originally posted by spud View Post
              if you can feed the audio of the TV into the computer which is running the kinect plugin, you could try the "Echo cancellation" feature.
              Hey Spud, I've been having trouble with this too. My receiver is feeding the audio from anything flowing through it to the my little NUC I have as the remote Kinect station. I have Echo Cancellation turned on. But it seems like if there is any sound coming from the receiver, VR doesn't work. Additionally, I can't seem to see any difference in Trace mode when EC is turned off or on.

              Any suggestions from Spud or from the field? Any configuration requirements on the Kinect OS side to ensure that .. I dunno, the SDK is "hearing" what is being piped in through the audio port?

              I should probably check to make sure I can actually see volume on the mic... hm.

              hjk
              ---

              Comment


              • #8
                Originally posted by hjk View Post
                Hey Spud, I've been having trouble with this too. My receiver is feeding the audio from anything flowing through it to the my little NUC I have as the remote Kinect station. I have Echo Cancellation turned on. But it seems like if there is any sound coming from the receiver, VR doesn't work. Additionally, I can't seem to see any difference in Trace mode when EC is turned off or on.

                Any suggestions from Spud or from the field? Any configuration requirements on the Kinect OS side to ensure that .. I dunno, the SDK is "hearing" what is being piped in through the audio port?

                I should probably check to make sure I can actually see volume on the mic... hm.

                hjk
                ---
                The Echo Cancellation filters out the audio from your default output (and not input), so you have to make sure the audio input is redirected to your default audio output like in the screenshot below.
                Click image for larger version

Name:	redirectinputtooutput.jpg
Views:	1
Size:	57.0 KB
ID:	1176676

                then I would test first with some speakers plug into your NUC and with the speakers of the receiver turned off.

                let me know if it works

                Comment


                • #9
                  I never got around to try this but I want to try it now. Since I run the Kinect remotely do I feed the tv' studio in the computer that has the kinect connected to it or the one that homeseer is on?

                  Comment


                  • #10
                    Originally posted by spud View Post
                    The Echo Cancellation filters out the audio from your default output (and not input), so you have to make sure the audio input is redirected to your default audio output like in the screenshot below.
                    [ATTACH]44784[/ATTACH]

                    then I would test first with some speakers plug into your NUC and with the speakers of the receiver turned off.

                    let me know if it works
                    So in Other words spud, you feed the output of you TV to the mic input and then click "listen to this device"? Correct?
                    Hector
                    ____________________________________
                    Win.2003 OS, HS3
                    BLDSC,BLstat,BLRadar,BLRamdom,BLOccupied
                    BLups,BLrain8,HSTouch,Ultrajones Weatherbug,
                    MyTrigger,ACRF2,W800,Zwave
                    AP800,Honeywell Stat

                    Comment


                    • #11
                      Originally posted by Rotech View Post
                      So in Other words spud, you feed the output of you TV to the mic input and then click "listen to this device"? Correct?
                      correct, and you have to tick the "Echo Cancellation" checkbox in the plugin config page.

                      Comment


                      • #12
                        I have my source of audio coming from my PC (HTPC) and have clicked "echo cancellation" however when I play a song the kinect plug in still shows (in the log trace) that it's trying to decipher the singer's words.
                        and idea?

                        Comment

                        Working...
                        X