Announcement

Collapse
No announcement yet.

kinect stop working suddenly

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • spud
    replied
    Originally posted by Rotech View Post
    Spud, have you got the chance to chk this out by any chance?
    sorry for the delay, I have been very busy...
    did you try to remove the location part of the VR string and/or using only one of the string, as Jeff suggested here:

    http://board.homeseer.com/showthread...17#post1193617

    Leave a comment:


  • Rotech
    replied
    Originally posted by spud View Post
    I guess so, I will try to reproduce the problem this weekend.
    Spud, have you got the chance to chk this out by any chance?

    Leave a comment:


  • Rotech
    replied
    Bump

    Leave a comment:


  • Rotech
    replied
    Any luck with this issue spud?


    Sent from my iPad using Tapatalk HD

    Leave a comment:


  • spud
    replied
    Originally posted by Rotech View Post
    I deleted the weather XML event and now it started working. Is it the way its written the problem?


    Sent from my iPad using Tapatalk HD
    I guess so, I will try to reproduce the problem this weekend.

    Leave a comment:


  • Rotech
    replied
    I deleted the weather XML event and now it started working. Is it the way its written the problem?


    Sent from my iPad using Tapatalk HD

    Leave a comment:


  • spud
    replied
    the empty optional words are probably a formatting problem in the HS logs, could you turn on the "log to file" option at debug level from the kinect config page, then restart the plugin and send me the Logs/Kinect.txt file

    I still suspect the WeatherXML VR commands to be the problem, so you can try to completely delete the "WeatherXML VR Kinect 1" event and then restart the kinect plugin to see if that change anything

    Leave a comment:


  • Rotech
    replied
    Any idea Spud?


    Sent from my iPad using Tapatalk HD

    Leave a comment:


  • Rotech
    replied
    Can it be this?
    Attached Files

    Leave a comment:


  • spud
    replied
    Originally posted by Rotech View Post
    Spud, I have no idea why there are empty optional choices. I haven't done any changes on my part.
    Can you find the events that contains the words in these rules (i.e. "the days") and post them here.

    Leave a comment:


  • Rotech
    replied
    Originally posted by spud View Post
    where do the following rules come from? Why is there some empty optional choices?

    Code:
    Jul-20 6:49:28 PM         Kinect    DEBUG Rule (Show Time) [] [] [the] [ days] [] []
    Jul-20 6:49:28 PM         Kinect    DEBUG Rule: [] [] [the] [ days] [] []
    also you should avoid entering commands where all words are optional, because that makes the attention phrase with nothing after a valid command
    Spud, I have no idea why there are empty optional choices. I haven't done any changes on my part.

    Leave a comment:


  • spud
    replied
    Originally posted by Rotech View Post
    Here you go spud
    where do the following rules come from? Why is there some empty optional choices?

    Code:
    Jul-20 6:49:28 PM         Kinect    DEBUG Rule (Show Time) [] [] [the] [ days] [] []
    Jul-20 6:49:28 PM         Kinect    DEBUG Rule: [] [] [the] [ days] [] []
    also you should avoid entering commands where all words are optional, because that makes the attention phrase with nothing after a valid command

    Leave a comment:


  • Rotech
    replied
    Originally posted by spud View Post
    sorry for the delay, this error means you have one or more voice commands causing a problem when the plugin tries to build the grammar. Could you post your entire debug logs when the plugin starts. Thanks.
    Here you go spud
    Attached Files

    Leave a comment:


  • Furious
    replied
    Originally posted by Furious View Post
    Spud, may need to add some extra trapping - you can trip this error if HS is rebooted, and it basically kills the whole plugin remotely without a reconnect.
    Code:
    Jul-20 02:35:55 DEBUG Speech Recognition Stopped
    Jul-20 02:35:55 DEBUG Snapshot server stopped
    Jul-20 02:35:56 DEBUG System.Net.HttpListenerException (0x80004005): The I/O ope
    ration has been aborted because of either a thread exit or an application reques
    t
       at System.Net.HttpListener.GetContext()
       at HSPI_KINECT.SnapshotServer.<Start>b__0()
    Appears this can also be triggered if you restart a plugin from the mange plugins page - for example, restarting zwave will also cause the remote plugin to give the error, and then no longer be active.

    Leave a comment:


  • spud
    replied
    Originally posted by Rotech View Post
    anybody knows what this error means?

    Jul-18 9:49:09 PM Kinect ERROR '' rule reference not defined in this grammar.

    this pops out in start up.
    sorry for the delay, this error means you have one or more voice commands causing a problem when the plugin tries to build the grammar. Could you post your entire debug logs when the plugin starts. Thanks.

    Leave a comment:

Working...
X