Announcement

Collapse

Contacting HomeSeer This Week

HomeSeer is open and operational this week. All orders are being processed and shipped as usual. However, some staff are working from home. If you need to contact HomeSeer for support or customer service, please use our Email or Chat options. https://homeseer.com/contact-us/
See more
See less

Remote Kinect - Windows 10

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Remote Kinect - Windows 10

    I recently upgraded my desktop system to Windows 10 and I cannot get the Kinect remote working again (it had been working perfectly for months with my previous Win 8.1 installation).

    I installed the Kinect Runtime 1.7 package (which installed without issue) and my Kinect seems physically fine (in the sense that I get the usual blinky green light when it's plugged into USB). When I start HSPI_Kinect, though, I see the following (using a DEBUG trace):

    C:\Kinect>HSPI_KINECT.exe server=192.168.101.72 instance=hank autoreconnect=20
    Plugin: Kinect Instance: hank starting...
    Connecting to server at 192.168.101.72...
    Connection attempt #1
    Connected (HomeSeer API 3). Waiting to be initialized...
    Aug-15 10:54:52 DEBUG Logger Initialized
    Aug-15 10:54:52 INFO Kinect version 3.0.0.34
    Aug-15 10:54:52 DEBUG USB\VID_0409&PID_005A\5&2301DF1D&0&4 status=DeviceNotSupported
    Aug-15 10:54:52 DEBUG Voice Recognition Initialized
    Aug-15 10:54:52 DEBUG CreateZoneDevice: Start Enumerating Devices
    Aug-15 10:54:53 DEBUG CreateZoneDevice: End Enumerating Devices
    Aug-15 10:54:53 DEBUG CreateZoneDevice: Start Enumerating Devices
    Aug-15 10:54:53 DEBUG CreateZoneDevice: End Enumerating Devices
    Aug-15 10:54:53 DEBUG Drawing Zones File
    Aug-15 10:54:53 DEBUG Deleting image file Kinect/zones_hank/zones0.jpg
    Aug-15 10:54:53 DEBUG Writing image file Kinect/zones_hank/zones1.jpg
    Aug-15 10:54:53 DEBUG Visual Recognition Initialized
    Aug-15 10:54:53 DEBUG Web Pages Registered
    Aug-15 10:54:53 DEBUG End Init

    ...with the relevant line, of course, being the 'DeviceNotSupported' bit just after the INFO line.

    Am I just out of luck? --or does anybody have any suggestions?

    -M.

  • #2
    I think you need to install the kinect SDK (not runtime). There is a link in the user guide

    Comment


    • #3
      Ah, sure enough! That was the issue.

      I had visited the documentation, btw, but I got confused by the title of that link. I read 'Kinect for XBox 360' and my brain just edited it out or something :-)

      Thanks for the quick response!

      -M.

      Comment

      Working...
      X