Announcement

Collapse
No announcement yet.

Kinect needs to be restarted

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Kinect needs to be restarted

    Current Date/Time: 10/9/2015 7:50:49 AM
    HomeSeer Version: HS3 Standard Edition 3.0.0.208
    Operating System: Microsoft Windows 7 Home Premium - Work Station
    System Uptime: 0 Days 13 Hours 3 Minutes 9 Seconds
    Number of Devices: 211
    Number of Events: 171

    Enabled Plug-Ins
    2.0.22.0: BLDSC
    2.0.14.0: BLOccupied
    2.0.110.0: BLRadar
    1.0.11.0: BLRain8Net
    2.0.5.0: BLRandom
    3.0.12.0: BLReminders
    2.0.63.0: BLStat
    1.0.16.0: BLTED
    2.0.17.0: BLUPS
    3.0.0.75: HSTouch Server
    3.0.0.35: Kinect
    3.0.0.141: PHLocation
    1.0.0.2: Restart
    30.0.0.29: RFXCOM
    3.0.0.38: weatherXML
    3.0.1.25: Z-Wave

    I have been encountering problem with kinect not responding to voice commands lately, To resolve issue I need to restart plugin and that makes it work. Anyone experimenting this?
    Hector
    ____________________________________
    Win.2003 OS, HS3
    BLDSC,BLstat,BLRadar,BLRamdom,BLOccupied
    BLups,BLrain8,HSTouch,Ultrajones Weatherbug,
    MyTrigger,ACRF2,W800,Zwave
    AP800,Honeywell Stat

  • #2
    Anyone?
    Hector
    ____________________________________
    Win.2003 OS, HS3
    BLDSC,BLstat,BLRadar,BLRamdom,BLOccupied
    BLups,BLrain8,HSTouch,Ultrajones Weatherbug,
    MyTrigger,ACRF2,W800,Zwave
    AP800,Honeywell Stat

    Comment


    • #3
      This happens to my remote Kinect when there are wifi glitches and the remote computer loses its network connection for a bit.

      Comment


      • #4
        Hector,
        Is it a local or remote instance?
        could you provide some logs with log level=trace?
        thanks

        Comment


        • #5
          Originally posted by spud View Post
          Hector,
          Is it a local or remote instance?
          could you provide some logs with log level=trace?
          thanks
          It a local instance.
          When placing log level to "trace" what do you want me to test? Or what do you want me to do afterwards?
          Hector
          ____________________________________
          Win.2003 OS, HS3
          BLDSC,BLstat,BLRadar,BLRamdom,BLOccupied
          BLups,BLrain8,HSTouch,Ultrajones Weatherbug,
          MyTrigger,ACRF2,W800,Zwave
          AP800,Honeywell Stat

          Comment


          • #6
            Originally posted by Rotech View Post
            It a local instance.
            When placing log level to "trace" what do you want me to test? Or what do you want me to do afterwards?
            keep the log level to trace until the problem happens again then post the latest log lines from the Kinect plugin.

            Comment


            • #7
              Originally posted by spud View Post
              keep the log level to trace until the problem happens again then post the latest log lines from the Kinect plugin.
              Spud

              today I notice that my TTS event where lagging. I opened task manager and CPU usage was at 100%. I then started turn off processes to see if the CPU usage will scale itself down. the kiect was at around 53k, when I turn kinect process off cpu usage came down to less the 10%. I captured info from log, didnt see any specific error. But maybe you can see things that I dont.
              Hector
              ____________________________________
              Win.2003 OS, HS3
              BLDSC,BLstat,BLRadar,BLRamdom,BLOccupied
              BLups,BLrain8,HSTouch,Ultrajones Weatherbug,
              MyTrigger,ACRF2,W800,Zwave
              AP800,Honeywell Stat

              Comment


              • #8
                Originally posted by Rotech View Post
                Spud

                today I notice that my TTS event where lagging. I opened task manager and CPU usage was at 100%. I then started turn off processes to see if the CPU usage will scale itself down. the kiect was at around 53k, when I turn kinect process off cpu usage came down to less the 10%. I captured info from log, didnt see any specific error. But maybe you can see things that I dont.
                when you restart the kinect plugin does it immediatly takes 100% CPU?

                the kinect plugin can be pretty CPU intensive especially if you use all the features, try to disable some of them: "Gesture, Posture and Person Recognition", camera, voice recognition...

                Comment


                • #9
                  Originally posted by spud View Post
                  when you restart the kinect plugin does it immediatly takes 100% CPU?

                  the kinect plugin can be pretty CPU intensive especially if you use all the features, try to disable some of them: "Gesture, Posture and Person Recognition", camera, voice recognition...
                  Disabling all except voice recognition is hovers around 32k. If I disable voice reconnition it drops to 25k.
                  Hector
                  ____________________________________
                  Win.2003 OS, HS3
                  BLDSC,BLstat,BLRadar,BLRamdom,BLOccupied
                  BLups,BLrain8,HSTouch,Ultrajones Weatherbug,
                  MyTrigger,ACRF2,W800,Zwave
                  AP800,Honeywell Stat

                  Comment


                  • #10
                    Spud, for some reason the log file that I wanted to attach did not work work. but here it is. this was I think not sure before or after I ended the proceeds in task manager.
                    Attached Files
                    Hector
                    ____________________________________
                    Win.2003 OS, HS3
                    BLDSC,BLstat,BLRadar,BLRamdom,BLOccupied
                    BLups,BLrain8,HSTouch,Ultrajones Weatherbug,
                    MyTrigger,ACRF2,W800,Zwave
                    AP800,Honeywell Stat

                    Comment


                    • #11
                      Bump
                      Hector
                      ____________________________________
                      Win.2003 OS, HS3
                      BLDSC,BLstat,BLRadar,BLRamdom,BLOccupied
                      BLups,BLrain8,HSTouch,Ultrajones Weatherbug,
                      MyTrigger,ACRF2,W800,Zwave
                      AP800,Honeywell Stat

                      Comment


                      • #12
                        Originally posted by Rotech View Post
                        Disabling all except voice recognition is hovers around 32k. If I disable voice reconnition it drops to 25k.
                        not sure I understand what you mean by 25k or 32k?
                        what you have to look at in task manager is the CPU column, it's a % of the total CPU available (so it doesn't have a "k" at the end)

                        the log you attached only contains the initialization of the plugin so there is not much to see there.

                        Comment


                        • #13
                          Originally posted by spud View Post
                          not sure I understand what you mean by 25k or 32k?
                          what you have to look at in task manager is the CPU column, it's a % of the total CPU available (so it doesn't have a "k" at the end)

                          the log you attached only contains the initialization of the plugin so there is not much to see there.
                          The 25k and 32k is the CPU usage, I currently have the plugin disable to see if I get the lagging again. So far it has been stable. Any other test I can do?
                          Last edited by Rotech; October 21st, 2015, 06:21 AM. Reason: Correcting question
                          Hector
                          ____________________________________
                          Win.2003 OS, HS3
                          BLDSC,BLstat,BLRadar,BLRamdom,BLOccupied
                          BLups,BLrain8,HSTouch,Ultrajones Weatherbug,
                          MyTrigger,ACRF2,W800,Zwave
                          AP800,Honeywell Stat

                          Comment


                          • #14
                            I am going to try another Kinect device to see if this is a hardware issue. If this doesn't work I may need to uninstall plugin, Any one having issues with this problem?
                            Hector
                            ____________________________________
                            Win.2003 OS, HS3
                            BLDSC,BLstat,BLRadar,BLRamdom,BLOccupied
                            BLups,BLrain8,HSTouch,Ultrajones Weatherbug,
                            MyTrigger,ACRF2,W800,Zwave
                            AP800,Honeywell Stat

                            Comment


                            • #15
                              Originally posted by Rotech View Post
                              I am going to try another Kinect device to see if this is a hardware issue. If this doesn't work I may need to uninstall plugin, Any one having issues with this problem?
                              did anyone find a resolution to a local kinect non-response? besides restarting the plug-in? I have this problem and it seems to be getting worse....

                              Comment

                              Working...
                              X