No announcement yet.

Remote Kinect Error

  • Filter
  • Time
  • Show
Clear All
new posts

  • Remote Kinect Error

    Attached Files

  • #2
    Looks like you're getting a few things similar to what I've experienced.
    Not all errors are trapped successfully, so until they've all been ironed out by Spud, best to set up some log monitoring (Jon00 is the one I use) to trigger a kill and restart of the exe's on the other tablets remotely.

    When a remote plugin is disconnected, it'll be lost from the kinect config screen. If you then reload the remote plugin, the local instance may also not show up to configure.
    I've also noticed that restarting *any* plugin (BLLan, mediacontroller, etc) on my HS3 instance causes any remote kinect plugins to die with your error and need to be fired up again.


    • #3
      Thanks, Furious. I like to learn how to do the log monitoring. Are you using the Jon00 Remote Computer Control & Network Monitor for that? Thanks.


      • #4
        After some more learning on the web, I think that you used Jon00's HS3 Log Monitor Utility and based on the findings of a problem in the log use a script to kill and restart the remote Kinect exe files. I just can't figure out how it all works together. Can you give some more info, and share the script if you use one. Thank you for your help.


        • #5
          Need to have a few things to monitor for, here's a sample trigger to go in the config:
          SearchMessage="Shutting down Plug-In: Kinect"
          EventTrigger=restart kinect plugin
          HSLogTriggerText=Restarting kinect plugin, disconnect may cause issues with confidence
          Put some other triggers as above, but for
          "Cannot access remote plugin Kinect"
          "DEBUG Speech Recognition Stopped"
          "Shutting down Plug-In: Kinect"

          My event is basically to run a batch file, which in turn calls powershell. It basically runs cmdlets remotely to kill and restart the kinect process. Tried psexec and pskill, but psexec acts really weird with trying to launch an executable with arguments.

          $username = "adminaccount"
          $password = "password"
          $secstr = New-Object -TypeName System.Security.SecureString
          $password.ToCharArray() | ForEach-Object {$secstr.AppendChar($_)}
          $cred = new-object -typename System.Management.Automation.PSCredential -argumentlist $username, $secstr
          invoke-command -computer *remote* -credential $cred { get-process hspi_kinect | stop-process -force}
          start-sleep 3
          invoke-command -computer *remote* -credential $cred {c:\users\adminaccount\documents\kinect\HSPI_KINECT.exe server= autoreconnect=10 console=true instance=LivingRoom}
          You can save the credentials as an encrypted xml if you're really paranoid, just google how to save and then import them, it's dead easy.


          • #6
            Thanks for the extra detail. I think that I know how to do that now. Had to learn PowerShell first. Also, for this to work, I needed to deal with some settings related to the firewall and allowing remoting for my remote Windows 8 tablets which are on workgroup (not a domain). Thus far I have it done manually alone, meaning that I run the batch file manually that runs the PowerShell script, that stops and restarts the remote Kinect. With 2 remote Kinects, I found out that when one disconnects that I need to shut down both and then restart both for the dropdown menu in the plugin management of HS3 to show up properly for the Kinects.
            Attached Files