Announcement

Collapse
No announcement yet.

Remote install Windows 10 - no go

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Remote install Windows 10 - no go

    Just started playing with this, and though I got it to work fine on the HS3 server, I've now tried two different PCs with Windows 10 and remote install without success. It seems to start fine, but I can't get speech to work at all. I've tried adjusting confidence as well. Startup looks good:

    Code:
    C:\WINDOWS\system32>c:\kinecths3\HSPI_KINECT.exe server=(IP-address removed) instance=Livingroom autoreconnect=55 console=true 
    Plugin: Kinect Instance: Livingroom starting...
    Connecting to server at (IP-address removed)...
    Connection attempt #1
    Connected (HomeSeer API 3). Waiting to be initialized...
    nov-17 08.27.33 DEBUG Logger Initialized
    nov-17 08.27.33 INFO Kinect version 3.0.0.36
    nov-17 08.27.33 DEBUG USB\VID_0409&PID_005A\5&280A4CBE&0&1 status=Connected
    nov-17 08.27.33 DEBUG Voice Recognition Initialized
    nov-17 08.27.33 DEBUG Drawing Zones File
    nov-17 08.27.33 DEBUG Deleting image file Kinect/zones_Livingroom/zones0.jpg
    nov-17 08.27.33 DEBUG Writing image file Kinect/zones_Livingroom/zones1.jpg
    nov-17 08.27.33 DEBUG Visual Recognition Initialized
    nov-17 08.27.34 DEBUG Web Pages Registered
    nov-17 08.27.34 DEBUG Starting Speech Recognition
    nov-17 08.27.34 DEBUG Building Grammars
    nov-17 08.27.34 DEBUG   Rule:turn tv on
    nov-17 08.27.34 DEBUG   Rule:turn tv off
    nov-17 08.27.34 DEBUG Speech Recognition Started
    nov-17 08.27.41 DEBUG Snapshot server started: http://*:8078/kinectsnapshot/
    nov-17 08.27.41 INFO Kinect initialized
    nov-17 08.27.41 DEBUG End Init
    With trace on, I can't get any indication of speech being recognized at all. Snapshot works, and it seems to detect people in the room from time to time.

    Is there some sort of test application I can download (from Microsoft?) to verify everything is OK? Haven't found anything so far.

  • #2
    so, you are saying that you set the log level to trace for this remote instance but you don't see any "Phrase hypothesized" or "Phrase recognized" log lines in the console?

    if so go to windows control panel > Sound > Recording > Microphone Array > Properties, check the levels and try to increase it.

    Click image for larger version

Name:	kinectmicconfig.jpg
Views:	1
Size:	83.5 KB
ID:	1182008


    with the Kinect SDK comes some samples apps you can test, for example you can try the "Speech Basics - WPF" one, which let you move a turtle using voice commands. Make sure to shut down the kinect plugin before running these sample apps.

    Click image for larger version

Name:	kinecttoolkit.jpg
Views:	1
Size:	74.3 KB
ID:	1182009

    Comment


    • #3
      Thanks for the input!

      I guess this explains a lot:



      Tried reinstalling, but can't get it to show up for some reason. All devices seem to be there, but still...
      Attached Files

      Comment


      • #4
        what version of Kinect SDK have you installed? You can try version 1.8: https://www.microsoft.com/en-us/down....aspx?id=40278

        also, don't use a USB3 port to plug the kinect sensor, use USB2

        you said it works on the HS3 machine, is it Windows 10 as well?

        Comment


        • #5
          I think there might be something wrong with the NUC PC I test this on, just tried it on my Surface 3 and Kinect works as expected there (didn't test with the plugin though).

          I'll be back with my findings!

          (Tried SDK 1.7 and 1.8, the HS3 server is win7).

          Comment


          • #6
            Okay, finally cracked it. Thing is, I've been using RDP (Remote desktop) to the computers I've tested with as they weren't connected to neither keyboard, mouse nor display.

            And if you intend to do that, you'd better remember to turn on 'playing sound on remote computer' in Remote Desktop, or your Kinect will not be available as a mic...

            Oh well, live and learn.

            Comment

            Working...
            X