Announcement

Collapse
No announcement yet.

Using Internet to set Time on XP

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Using Internet to set Time on XP

    I have always had my HomeSeer computer pull the time from the internet. For the last week or so I have been unable to set the time. I have tried four different time servers, all unsuccessful. I decided to ping them, no luck. I can browse the 'net with no problems. Tried to ping Google, again, no luck.

    I don't know if these problems are related, but I think they are. A google search didn't help.

    This problem appears to be on all the computers on my LAN. Very frustrating.

    I'm still on XP, although I have a couple of boxes using WIN7. All have the same problem.

    The ping thing I can live with, not having the correct time, not. Can anyone give me some advice?

    Thank You.
    Don

  • #2
    Any chance you have a new router or ISP? Port 123 is open?

    Z

    Comment


    • #3
      Port 123 is open as far as windows firewall. Is there some way to check if my ISP has it blocked?
      Don

      Comment


      • #4
        Since you said it was a LAN wide issue, it's most likely not a computer issue (unless you run a domain server and have some Group policy issues), but rather something common to them all (ie router, etc). You haven't made any router changes lately? You're running on DSL, cable, ??

        BTW, it's not uncommon for NTP servers to not respond to ICMP packets (ping).

        On your Windows 7 machine open a cmd window and type:
        w32tm /query /status (XP is? Net time /querystatus)

        See what it says. w32tm can show you a lot, but I suspect UDP port 123 is being blocked somewhere upstream by either your router or ISP?

        Here's a good page to find NTP info for windows:
        http://technet.microsoft.com/en-us/l...mes_tools_suxb

        Z

        Comment


        • #5
          Darrell:

          Thanks for the link and advice. Looking at the Windows Event Log there is an error at
          W32Time...

          Time Provider NtpClient: An error occurred during DNS lookup of the manually
          configured peer


          I'll see if I can get anything out of the link.

          Appreciate the help.
          Don

          Comment


          • #6
            Sounds like a DNS issue. What is the time server you're looking at?
            Does your DNS resolve it correctly ?
            From the cmd line see of your DNS server resolves the NTP server correctly:
            nslookup name of NTP server

            Comment


            • #7
              Tried using nslookup on the following and not quite sure what to look for in a response.

              Brought up pinging only to add another issue that might be part of this....

              Servers

              time.windows.com
              time-a.nist.gov
              time.nist.gov

              all three come back from nslookup with IP addresses.

              Talked to my ISP (Hughes.net) and was told that they don't block any ports.

              Not sure where to go from here.

              Totally open to suggestions.
              Don

              Comment


              • #8
                Ahh.. Hughes... That might complicate matters
                DNS is fine, your IP addresses are resolving it looks like.

                Any chance you just upgraded to Gen4 ?
                I'd guess Hughes has their own NTP server for you to use, I'd ask them if there's any special config that you need to setup to do NTP over their network. They do a lot of "magic" to compensate for the 2+ sec delay you get..

                Z

                Comment


                • #9
                  Yeah, I did about 2 months ago. Since then I get certification errors on facebook. Spent too many hours trying to get that resolved. Didn't ever.

                  Will try and see if there is any info on that.

                  Thanks.
                  Don

                  Comment


                  • #10
                    Does your firewall / router have the option of entering an NTP server for time sync?

                    Try the IP resolved instead of the DNS name for the NTP servers; just to see if it works?

                    You can also redo your time syncing to NTP servers using Tardis instead of the Windows Time service.

                    http://www.kaska.demon.co.uk/download.htm

                    If you run the tardis service in debug mode you can maybe see an issue if present:


                    C:\WINDOWS\system32>tardisnt debug
                    2013/10/01 21:08:18.53,Info : SNTP Client connecting to 192.168.244.159
                    2013/10/01 21:08:18.54,Debug: SNTP Client Ver: 3 Stratum: 1 Mode: 4 Poll: 10 Precision -8
                    2013/10/01 21:08:18.54,Info : Correction of 0.343 seconds used to adjust clock frequency
                    2013/10/01 21:09:18.54,Waiting for 1 hour 59 minutes
                    Attached Files
                    Last edited by Pete; October 1st, 2013, 09:16 PM.
                    - Pete

                    Auto mator
                    Homeseer 3 Pro - 3.0.0.548 (Linux) - Ubuntu 18.04/W7e 64 bit Intel Haswell CPU 16Gb- Mono 6.8X
                    Homeseer Zee2 (Lite) - 3.0.0.548 (Linux) - Ubuntu 18.04/W7e - CherryTrail x5-Z8350 BeeLink 4Gb BT3 Pro - Mono 6.8X
                    HS4 Pro - V4.0.5.0 - Ubuntu 18.04/W7e 64 bit Intel Kaby Lake CPU - 32Gb - Mono 6.8X
                    HS4 Lite -

                    X10, UPB, Zigbee, ZWave and Wifi MQTT automation. OmniPro 2, Russound zoned audio, Smartthings hub, Hubitat Hub, and Home Assistant

                    Comment


                    • #11
                      Gave up the ghost and installed a free time sync program.

                      Arrg!!

                      Thanks for all the help.

                      Over and out.
                      Don

                      Comment


                      • #12
                        nslookup is a good diagnostic tool, but it will not necessarily help you troubleshoot your local machine's DNS configuration. Try using ping instead, as that will force the DNS lookup through your local settings.

                        You won't necessarily get a ping response (most time servers block it), but you should at least see if trying the IP address. if you see something like pinging time-a.nist.gov [xx.xx.xx.xx] where xx.xx.xx.xx is an IP address your DNS configuration is working. If you get a hostname lookup failure start troubleshooting your DNS configuration.
                        HS Pro 3.0 | Linux Ubuntu 16.04 x64 virtualized under Proxmox (KVM)
                        Hardware: Z-NET - W800 Serial - Digi PortServer TS/8 and TS/16 serial to Ethernet - Insteon PLM - RFXCOM - X10 Wireless
                        Plugins: HSTouch iOS and Android, RFXCOM, BlueIris, BLLock, BLDSC, BLRF, Insteon PLM (MNSandler), Device History, Ecobee, BLRing, Kodi, UltraWeatherWU3
                        Second home: Zee S2 with Z-Wave, CT101 Z-Wave Thermostat, Aeotec Z-Wave microswitches, HSM200 occupancy sensor, Ecolink Z-Wave door sensors, STI Driveway Monitor interfaced to Zee S2 GPIO pins.

                        Comment


                        • #13
                          Sounds like it was more of a MS NTP (w32tm) issue, since he was able to connect with a 3rd party app.

                          Shouldn't Nslookup and ping both default to the local DNS server settings in his TCP/IP setup? Since there's not resolv.conf type file on MS, I thought DNS resolution order was pretty much preset internally? (I'm only partially fluent in Windows

                          Personally, I just install Host and Dig on my windows boxes and not worry about it

                          Z

                          Comment


                          • #14
                            Similiar to the etc/resolv.conf (which I always goof around with)

                            I do the same with the hosts file in windows located \system32\drivers\etc\hosts

                            On the linux box though I totally change the ntp.conf file around to my liking (my GPS) and historically have tweaked the wintel registry entries until I went to using tardis.

                            Just doing a quickie wintel network "repair" clears the DNS cache such that it will start again.

                            Here though the timekeeping is internal to the network; don't pass any NTP stuff through the router anyways. I redirect the linux appliance external links internally.

                            I also just use 8.8.8.8 or 4.4.4.4 for my DNS on the firewall rarely utilized the ISP provided DNS servers. Very small DHCP scope such that the static IPs get their DNS stuff from manual entries on the firewall (using Smoothwall transitioning to PFSense for multiple lans and load balancing wans.). I also occassionally google search "best DNS provider"; don't know if that is beneficial or not.
                            - Pete

                            Auto mator
                            Homeseer 3 Pro - 3.0.0.548 (Linux) - Ubuntu 18.04/W7e 64 bit Intel Haswell CPU 16Gb- Mono 6.8X
                            Homeseer Zee2 (Lite) - 3.0.0.548 (Linux) - Ubuntu 18.04/W7e - CherryTrail x5-Z8350 BeeLink 4Gb BT3 Pro - Mono 6.8X
                            HS4 Pro - V4.0.5.0 - Ubuntu 18.04/W7e 64 bit Intel Kaby Lake CPU - 32Gb - Mono 6.8X
                            HS4 Lite -

                            X10, UPB, Zigbee, ZWave and Wifi MQTT automation. OmniPro 2, Russound zoned audio, Smartthings hub, Hubitat Hub, and Home Assistant

                            Comment


                            • #15
                              Well it's always easy to fix if it's Linux. I find MS to be "unnecessarily complex"

                              Luckily I run my own redundant DNS, NTP and email servers in Dallas and DC, so I don't have to mess with MS much..

                              Z

                              Comment

                              Working...
                              X