Announcement

Collapse
No announcement yet.

Voice Recognition error - Fixed!

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Voice Recognition error - Fixed!

    The computer recognizes the attention phrase and answers however, when I say something like "turn on TV room lamp," homeseer responds, "turn on TV room lamp," but doesn't turn the device on. I do have the voice recognition box checked on the device page. I get this message: Device reference 2719 did not find device in voice command "turn on DVREF:2719"
    Also if I ask "time" which is the command name, I get an error:
    Event ID (6370) not found for recognized voice command: Time


    any ideas?

    #2
    What does your Grammar_HS-V2#Default_Final.xml file look like ?
    It should be structured like:


    Code:
    < RULE ID="153" TOPLEVEL="ACTIVE">
    < P>switch desktop to all displays< /P>
    
    < /RULE>
    < RULE NAME="RULEEvName7">
    < P PROPNAME="TYPE_STRING" VALSTR="EVREF:153">Switch To All Displays< /P>
    < /RULE>
    (there is an extra space added between the < and the next character, otherwise the forum parser sees it as code. So those spaces are not present in the actual .xml file)

    So, "< P> switch..." is the actual voice command to listen for and "EVREF:153" is the event number to fire.
    All comands should be structured like this.

    Alex
    Last edited by DomeAdept; December 12, 2010, 07:56 PM. Reason: Damn forum parser ;-)

    Comment


      #3
      Originally posted by jtodd View Post
      The computer recognizes the attention phrase and answers however, when I say something like "turn on TV room lamp," homeseer responds, "turn on TV room lamp," but doesn't turn the device on. I do have the voice recognition box checked on the device page. I get this message: Device reference 2719 did not find device in voice command "turn on DVREF:2719"
      Also if I ask "time" which is the command name, I get an error:
      Event ID (6370) not found for recognized voice command: Time


      any ideas?
      It appears your HomeSeer database is corrupt if the events and ID are not matching.
      -Rupp
      sigpic

      Comment


        #4
        @ Rupp what do you suggest? Do I need to reinstall Homeseer? I checked the grammar .xml folder but I haven't written any scripts yet so I don't think it's end-user.

        Comment


          #5
          I tested the voice recognition on the homeseer server and it works fine, I only get these errors when I give commands on clients.

          Comment


            #6
            I fixed the problem, the computer I had the client installed on was the issue, I reinstalled the client and it works now.

            Many thanks

            Comment

            Working...
            X