Announcement

Collapse
No announcement yet.

FitbitSeer, a Fitbit plugin for HS3 - Need beta testers

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Moskus
    replied
    Originally posted by JimBob View Post
    Do you mean the "Refresh Now" button?

    Just hit it and the data refreshed ok and the plugin stayed running, no crash.
    ... really? How is that possible (I wonder)?!

    Are the device values also updated?


    I'm not doing anything "every hour", I'm only doing something every 5 minutes (or at the refresh interval you have selected yourself, if you have overridden the setting). Is this with HS3 version .208? (I don't know if that matters, I've been running it on two different computers myself for weeks without issues, and I've kept upgrading HS3 too).

    Leave a comment:


  • JimBob
    replied
    Do you mean the "Refresh Now" button?

    Just hit it and the data refreshed ok and the plugin stayed running, no crash.

    Leave a comment:


  • Moskus
    replied
    ... and it crashes when you hit the Update button too (it should!).

    Can you try to add another account (re-authenticate your account)? It seems like the authentication data is messed up somehow, but I thought that should give an error in the log.

    I could be that the data stored in the Root device has been corrupted somehow. It shouldn't but that means the database could have a problem. (Or at least, my objects in the database. ).

    Leave a comment:


  • JimBob
    replied
    Originally posted by Moskus View Post
    Hmmm! I have a hard time wrapping my head around this. It's hard to debug when I can't replicate an error.

    I might have to release a new update with more debug logging so that we can trace it.


    To stop the plugin, it's easiest to disable the plugin, and then kill the process HSPI_FitbitSeer.exe (e.g. using Task Manager). Then re-enable the plugin.


    Can you reach www.fitbit.com from the HS3 server?
    Yep, I know it's next to impossible to fix if you can't reproduce it. I was just hoping the fact it occurred on the hour may give you an idea, if it's something you initiate on the hour.

    I can reach fitbit.com from my HS3 box.

    Leave a comment:


  • Moskus
    replied
    HSPI_MoskusSample is released. Get it here: http://board.homeseer.com/showthread.php?p=1204795

    Leave a comment:


  • Moskus
    replied
    Hmmm! I have a hard time wrapping my head around this. It's hard to debug when I can't replicate an error.

    I might have to release a new update with more debug logging so that we can trace it.


    To stop the plugin, it's easiest to disable the plugin, and then kill the process HSPI_FitbitSeer.exe (e.g. using Task Manager). Then re-enable the plugin.


    Can you reach www.fitbit.com from the HS3 server?

    Leave a comment:


  • cjohlandt
    replied
    I'm also seeing the plug in crash once an hour with matching application errors in the Windows event viewer. Running Windows 8.1, HomeSeer 3.0.0.208, FitbitSeer 0.1.0.1.

    -Chris

    Leave a comment:


  • mhn
    replied
    If debug is enabled for plugins you can have a hanging window that can look like that.

    Have you checked that the plugin process is dead when HS i shut down?

    Regards
    Morten

    Leave a comment:


  • JimBob
    replied
    mmm, thanks for that. I'm a bit reluctant now to restart HS or I could lose the plugin altogether like you.

    Leave a comment:


  • dcdelong
    replied
    And here is what happened....

    Seems to correlate with an attempt to refresh...

    Click image for larger version

Name:	Capture.PNG
Views:	1
Size:	10.6 KB
ID:	1180759
    Attached Files

    Leave a comment:


  • dcdelong
    replied
    I was getting the same error as you once an hour for the last few days as well. Yesterday I did a full reboot because of Windows updates and it started with the above messages. Disabled the plug-in last night when it was flooding the log. I'll jump on and re-enable it and see what happens.

    Chris

    Leave a comment:


  • JimBob
    replied
    Originally posted by dcdelong View Post
    Here as well
    Yours looks to be a slightly different error. Mine and Telefragger are the plugin crashing on the hour. Your error seems to be an unresponsive plugin, with the error message saying it won't restart it.

    Leave a comment:


  • dcdelong
    replied
    Here as well
    Attached Files

    Leave a comment:


  • JimBob
    replied
    Looks like the same issue then.

    Leave a comment:


  • TeleFragger
    replied
    Originally posted by JimBob View Post
    Are your errors every hour also?
    Oct-19 10:04:52 AM Warning I/O interface FitbitSeer is down, executable is not running, restarting ...

    Oct-19 9:21:46 AM Warning File does not exist: C:\Program Files (x86)\HomeSeer HS3\html\

    Oct-19 9:04:47 AM Warning I/O interface FitbitSeer is down, executable is not running, restarting ...

    Oct-19 8:04:42 AM Warning I/O interface FitbitSeer is down, executable is not running, restarting ...

    Oct-19 7:04:37 AM Warning I/O interface FitbitSeer is down, executable is not running, restarting ...

    Oct-19 6:04:33 AM Warning I/O interface FitbitSeer is down, executable is not running, restarting ...


    not sure about the 9:21am error..im still getting things going...

    Leave a comment:

Working...
X