Announcement

Collapse
No announcement yet.

Tried New Beta

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Tried New Beta

    Hi Frank,

    I just tried the beta in HS4 and I get the following error:


    Initializing plug-in(1): Withings Instance::Object reference not set to an instance of an object. Time to load: 1903 milliseconds

    Thanks

    Will

    #2
    Here is my withings log:
    2020-12-18 13:06:29.193 -05:00 [INF] Connecting to Homeseer at 127.0.0.1:10400 ...
    2020-12-18 13:06:29.303 -05:00 [INF] Connection to homeseer successful.
    2020-12-18 13:06:29.740 -05:00 [DBG] Start: Register Devicess Definitions.
    2020-12-18 13:06:29.740 -05:00 [DBG] Finish: Register Devicess Definitions.
    2020-12-18 13:06:29.740 -05:00 [DBG] Start: Registering Web Pages.
    2020-12-18 13:06:29.756 -05:00 [DBG] Finish: Registering Web Pages.
    2020-12-18 13:06:29.756 -05:00 [DBG] Registering Triggers
    2020-12-18 13:06:30.537 -05:00 [DBG] Refreshing Token for User: 20344268
    2020-12-18 13:06:30.771 -05:00 [DBG] Refreshing Token for User:
    2020-12-18 13:06:31.256 -05:00 [DBG] {"status":401,"body":{},"error":"XRequestID: Not provided invalid_token: The access token provided is invalid"}
    2020-12-18 13:06:31.256 -05:00 [WRN] Invalid Token: Request Access from Plugin Configuration Page
    2020-12-18 13:06:31.271 -05:00 [FTL] Error occurred in InitIO: System.NullReferenceException: Object reference not set to an instance of an object.
    at HSPI_Withings.Controllers.WithingsController.ValidateUserSub scriptions(User user, Int32 application)
    at HSPI_Withings.Controllers.WithingsController.SubscribeUserTo Notifications(User user, Int32 application)
    at HSPI_Withings.Controllers.WithingsController.SubscribeToNoti fications(Int32 application)
    at HSPI_Withings.Controllers.WithingsController.WithingsInit()
    at HSPI_Withings.Controllers.WithingsController..ctor(IHSPI plugin)
    2020-12-18 13:06:31.271 -05:00 [INF] Plugin started on version: 3.0.1.42
    2020-12-18 13:06:31.271 -05:00 [INF] Homeseer is asking to shutdown the plugin...
    2020-12-18 13:06:31.271 -05:00 [INF] Shutting down all services...
    2020-12-18 13:06:31.350 -05:00 [INF] Plugin has been shut down, exiting
    2020-12-18 13:07:02.255 -05:00 [INF] Connecting to Homeseer at 127.0.0.1:10400 ...
    2020-12-18 13:07:02.317 -05:00 [INF] Connection to homeseer successful.
    2020-12-18 13:07:02.677 -05:00 [DBG] Start: Register Devicess Definitions.
    2020-12-18 13:07:02.677 -05:00 [DBG] Finish: Register Devicess Definitions.
    2020-12-18 13:07:02.677 -05:00 [DBG] Start: Registering Web Pages.
    2020-12-18 13:07:02.692 -05:00 [DBG] Finish: Registering Web Pages.
    2020-12-18 13:07:02.692 -05:00 [DBG] Registering Triggers
    2020-12-18 13:07:03.427 -05:00 [DBG] Refreshing Token for User: 20344268
    2020-12-18 13:07:03.661 -05:00 [DBG] Refreshing Token for User:
    2020-12-18 13:07:04.208 -05:00 [DBG] {"status":401,"body":{},"error":"XRequestID: Not provided invalid_token: The access token provided is invalid"}
    2020-12-18 13:07:04.208 -05:00 [WRN] Invalid Token: Request Access from Plugin Configuration Page
    2020-12-18 13:07:04.208 -05:00 [FTL] Error occurred in InitIO: System.NullReferenceException: Object reference not set to an instance of an object.
    at HSPI_Withings.Controllers.WithingsController.ValidateUserSub scriptions(User user, Int32 application)
    at HSPI_Withings.Controllers.WithingsController.SubscribeUserTo Notifications(User user, Int32 application)
    at HSPI_Withings.Controllers.WithingsController.SubscribeToNoti fications(Int32 application)
    at HSPI_Withings.Controllers.WithingsController.WithingsInit()
    at HSPI_Withings.Controllers.WithingsController..ctor(IHSPI plugin)
    2020-12-18 13:07:04.208 -05:00 [INF] Plugin started on version: 3.0.1.42
    2020-12-18 13:07:04.208 -05:00 [INF] Homeseer is asking to shutdown the plugin...
    2020-12-18 13:07:04.208 -05:00 [INF] Shutting down all services...
    2020-12-18 13:07:04.364 -05:00 [INF] Plugin has been shut down, exiting
    2020-12-18 13:08:39.298 -05:00 [INF] Connecting to Homeseer at 127.0.0.1:10400 ...
    2020-12-18 13:08:39.376 -05:00 [INF] Connection to homeseer successful.
    2020-12-18 13:08:39.658 -05:00 [DBG] Start: Register Devicess Definitions.
    2020-12-18 13:08:39.673 -05:00 [DBG] Finish: Register Devicess Definitions.
    2020-12-18 13:08:39.673 -05:00 [DBG] Start: Registering Web Pages.
    2020-12-18 13:08:39.689 -05:00 [DBG] Finish: Registering Web Pages.
    2020-12-18 13:08:39.689 -05:00 [DBG] Registering Triggers
    2020-12-18 13:08:40.392 -05:00 [DBG] Refreshing Token for User: 20344268
    2020-12-18 13:08:40.626 -05:00 [DBG] Refreshing Token for User:
    2020-12-18 13:08:41.095 -05:00 [DBG] {"status":401,"body":{},"error":"XRequestID: Not provided invalid_token: The access token provided is invalid"}
    2020-12-18 13:08:41.095 -05:00 [WRN] Invalid Token: Request Access from Plugin Configuration Page
    2020-12-18 13:08:41.095 -05:00 [FTL] Error occurred in InitIO: System.NullReferenceException: Object reference not set to an instance of an object.
    at HSPI_Withings.Controllers.WithingsController.ValidateUserSub scriptions(User user, Int32 application)
    at HSPI_Withings.Controllers.WithingsController.SubscribeUserTo Notifications(User user, Int32 application)
    at HSPI_Withings.Controllers.WithingsController.SubscribeToNoti fications(Int32 application)
    at HSPI_Withings.Controllers.WithingsController.WithingsInit()
    at HSPI_Withings.Controllers.WithingsController..ctor(IHSPI plugin)
    2020-12-18 13:08:41.095 -05:00 [INF] Plugin started on version: 3.0.1.42
    2020-12-18 13:08:41.095 -05:00 [INF] Homeseer is asking to shutdown the plugin...
    2020-12-18 13:08:41.095 -05:00 [INF] Shutting down all services...
    2020-12-18 13:08:41.204 -05:00 [INF] Plugin has been shut down, exiting
    2020-12-18 13:09:56.467 -05:00 [INF] Connecting to Homeseer at 127.0.0.1:10400 ...
    2020-12-18 13:09:56.561 -05:00 [INF] Connection to homeseer successful.
    2020-12-18 13:09:57.061 -05:00 [DBG] Start: Register Devicess Definitions.
    2020-12-18 13:09:57.077 -05:00 [DBG] Finish: Register Devicess Definitions.
    2020-12-18 13:09:57.077 -05:00 [DBG] Start: Registering Web Pages.
    2020-12-18 13:09:57.092 -05:00 [DBG] Finish: Registering Web Pages.
    2020-12-18 13:09:57.092 -05:00 [DBG] Registering Triggers
    2020-12-18 13:09:57.874 -05:00 [DBG] Refreshing Token for User: 20344268
    2020-12-18 13:09:58.108 -05:00 [DBG] Refreshing Token for User:
    2020-12-18 13:09:58.592 -05:00 [DBG] {"status":401,"body":{},"error":"XRequestID: Not provided invalid_token: The access token provided is invalid"}
    2020-12-18 13:09:58.592 -05:00 [WRN] Invalid Token: Request Access from Plugin Configuration Page
    2020-12-18 13:09:58.608 -05:00 [FTL] Error occurred in InitIO: System.NullReferenceException: Object reference not set to an instance of an object.
    at HSPI_Withings.Controllers.WithingsController.ValidateUserSub scriptions(User user, Int32 application)
    at HSPI_Withings.Controllers.WithingsController.SubscribeUserTo Notifications(User user, Int32 application)
    at HSPI_Withings.Controllers.WithingsController.SubscribeToNoti fications(Int32 application)
    at HSPI_Withings.Controllers.WithingsController.WithingsInit()
    at HSPI_Withings.Controllers.WithingsController..ctor(IHSPI plugin)
    2020-12-18 13:09:58.608 -05:00 [INF] Plugin started on version: 3.0.1.42
    2020-12-18 13:09:58.608 -05:00 [INF] Homeseer is asking to shutdown the plugin...
    2020-12-18 13:09:58.608 -05:00 [INF] Shutting down all services...
    2020-12-18 13:09:58.811 -05:00 [INF] Plugin has been shut down, exiting
    2020-12-18 13:40:20.498 -05:00 [INF] Connecting to Homeseer at 127.0.0.1:10400 ...
    2020-12-18 13:40:20.561 -05:00 [INF] Connection to homeseer successful.
    2020-12-18 13:40:20.904 -05:00 [DBG] Start: Register Devicess Definitions.
    2020-12-18 13:40:20.920 -05:00 [DBG] Finish: Register Devicess Definitions.
    2020-12-18 13:40:20.920 -05:00 [DBG] Start: Registering Web Pages.
    2020-12-18 13:40:20.936 -05:00 [DBG] Finish: Registering Web Pages.
    2020-12-18 13:40:20.936 -05:00 [DBG] Registering Triggers
    2020-12-18 13:40:21.748 -05:00 [DBG] Refreshing Token for User: 20344268
    2020-12-18 13:40:21.967 -05:00 [DBG] Refreshing Token for User:
    2020-12-18 13:40:22.529 -05:00 [DBG] {"status":401,"body":{},"error":"XRequestID: Not provided invalid_token: The access token provided is invalid"}
    2020-12-18 13:40:22.529 -05:00 [WRN] Invalid Token: Request Access from Plugin Configuration Page
    2020-12-18 13:40:22.529 -05:00 [FTL] Error occurred in InitIO: System.NullReferenceException: Object reference not set to an instance of an object.
    at HSPI_Withings.Controllers.WithingsController.ValidateUserSub scriptions(User user, Int32 application)
    at HSPI_Withings.Controllers.WithingsController.SubscribeUserTo Notifications(User user, Int32 application)
    at HSPI_Withings.Controllers.WithingsController.SubscribeToNoti fications(Int32 application)
    at HSPI_Withings.Controllers.WithingsController.WithingsInit()
    at HSPI_Withings.Controllers.WithingsController..ctor(IHSPI plugin)
    2020-12-18 13:40:22.545 -05:00 [INF] Plugin started on version: 3.0.1.42
    2020-12-18 13:40:22.545 -05:00 [INF] Homeseer is asking to shutdown the plugin...
    2020-12-18 13:40:22.545 -05:00 [INF] Shutting down all services...
    2020-12-18 13:40:22.607 -05:00 [INF] Plugin has been shut down, exiting
    2020-12-18 14:12:41.322 -05:00 [INF] Connecting to Homeseer at 127.0.0.1:10400 ...
    2020-12-18 14:12:41.400 -05:00 [INF] Connection to homeseer successful.
    2020-12-18 14:12:41.806 -05:00 [DBG] Start: Register Devicess Definitions.
    2020-12-18 14:12:41.806 -05:00 [DBG] Finish: Register Devicess Definitions.
    2020-12-18 14:12:41.806 -05:00 [DBG] Start: Registering Web Pages.
    2020-12-18 14:12:41.822 -05:00 [DBG] Finish: Registering Web Pages.
    2020-12-18 14:12:41.822 -05:00 [DBG] Registering Triggers
    2020-12-18 14:12:42.618 -05:00 [DBG] Refreshing Token for User: 20344268
    2020-12-18 14:12:42.915 -05:00 [DBG] Refreshing Token for User:
    2020-12-18 14:12:43.400 -05:00 [DBG] {"status":401,"body":{},"error":"XRequestID: Not provided invalid_token: The access token provided is invalid"}
    2020-12-18 14:12:43.400 -05:00 [WRN] Invalid Token: Request Access from Plugin Configuration Page
    2020-12-18 14:12:43.400 -05:00 [FTL] Error occurred in InitIO: System.NullReferenceException: Object reference not set to an instance of an object.
    at HSPI_Withings.Controllers.WithingsController.ValidateUserSub scriptions(User user, Int32 application)
    at HSPI_Withings.Controllers.WithingsController.SubscribeUserTo Notifications(User user, Int32 application)
    at HSPI_Withings.Controllers.WithingsController.SubscribeToNoti fications(Int32 application)
    at HSPI_Withings.Controllers.WithingsController.WithingsInit()
    at HSPI_Withings.Controllers.WithingsController..ctor(IHSPI plugin)
    2020-12-18 14:12:43.400 -05:00 [INF] Plugin started on version: 3.0.1.42
    2020-12-18 14:12:43.400 -05:00 [INF] Homeseer is asking to shutdown the plugin...
    2020-12-18 14:12:43.400 -05:00 [INF] Shutting down all services...
    2020-12-18 14:12:43.446 -05:00 [INF] Plugin has been shut down, exiting

    Comment


      #3
      Had you run the "Get Withings Auth Code"? If so, Withings is returning a 401. I should be catching that, but it appears your token is bad. I will check about catching that error though.

      Also, did you start from scratch?

      On a side note, I'm installing HS4 now to run tests locally.
      MeiAutomtion Home

      Comment


        #4
        Frank

        So I uninstalled the plugin and deleted all files I could Identify as withing in the bin, config and html directory. Still get the same error. Log attached. It will not render the withing auth page to reconfigure withing oauth. I am not sure you are aware but I think withing has switched to oauth2. I don't know if this is the problem or not.

        Thanks. Will

        Comment


          #5
          The error log showS:
          A call was made to retrieve a global variable (MyHSToken) but there are none defined in the system.

          here is the withing log:

          2020-12-23 05:19:58.426 -05:00 [INF] Connecting to Homeseer at 127.0.0.1:10400 ...
          2020-12-23 05:19:58.504 -05:00 [INF] Connection to homeseer successful.
          2020-12-23 05:19:58.864 -05:00 [DBG] Start: Register Devicess Definitions.
          2020-12-23 05:19:58.864 -05:00 [DBG] Finish: Register Devicess Definitions.
          2020-12-23 05:19:58.864 -05:00 [DBG] Start: Registering Web Pages.
          2020-12-23 05:19:58.879 -05:00 [DBG] Finish: Registering Web Pages.
          2020-12-23 05:19:58.879 -05:00 [DBG] Registering Triggers
          2020-12-23 05:19:58.942 -05:00 [DBG] Start: Kicking off Polling timers.
          2020-12-23 05:19:58.957 -05:00 [DBG] Polling Timers: adding timer: UpdateTimer at pollInterval: 5580000
          2020-12-23 05:19:58.957 -05:00 [DBG] Polling Timers: timer: UpdateTimer Started
          2020-12-23 05:19:58.957 -05:00 [DBG] Polling Timers: adding timer: UpdateTimerDevices at pollInterval: 3600000
          2020-12-23 05:19:58.957 -05:00 [DBG] Polling Timers: timer: UpdateTimerDevices Started
          2020-12-23 05:19:58.957 -05:00 [DBG] Updating Withings Devices
          2020-12-23 05:19:58.957 -05:00 [DBG] Polling Timers: adding timer: UpdateTimerMeasureGroups at pollInterval: 3600000
          2020-12-23 05:19:58.957 -05:00 [DBG] Polling Timers: timer: UpdateTimerMeasureGroups Started
          2020-12-23 05:19:58.957 -05:00 [DBG] Polling Timers: adding timer: UpdateTimerActivity at pollInterval: 3600000
          2020-12-23 05:19:58.957 -05:00 [DBG] Polling Timers: timer: UpdateTimerActivity Started
          2020-12-23 05:19:58.957 -05:00 [DBG] Updating Withings Activity
          2020-12-23 05:19:58.957 -05:00 [DBG] Polling Timers: adding timer: UpdateTimerSleep at pollInterval: 3600000
          2020-12-23 05:19:58.957 -05:00 [DBG] Polling Timers: timer: UpdateTimerSleep Started
          2020-12-23 05:19:58.957 -05:00 [DBG] Updating Withings Sleep
          2020-12-23 05:19:58.957 -05:00 [DBG] Finish: Kicking off Polling timers.
          2020-12-23 05:19:58.957 -05:00 [INF] Plugin started on version: 3.0.1.42

          Comment


            #6
            I am using the OAuth 2.0 (as far as I know). I will double check tonight though.

            I couldn't even get it started though because I don't think myHS likes having an HS3 and HS4 system on the same machine (though not both running). So it just timed out making the call back to HS4.
            MeiAutomtion Home

            Comment


              #7
              When I click "Get Withings Auth code" from the plugin config section it opens a webpage(using chrome) on the withings website. Clicking "allow this app" button then returns

              {"errors":[{"message":"redirect_uri_mismatch: The redirect URI provided is missing or does not match partner callback url"}]}
              on the Withings page
              HS4 Pro on Shuttle NC10U, Win10; Z-NET
              Number of Devices: 449
              Number of Events: 210

              Plug-Ins: Arduino, BLLock, DirecTv, EasyTrigger, Honeywell WiFi Thermostat, MeiHarmonyHub, PHLocation2, Pushover 3P, UltraM1G3, WeatherXML, Worx Landroid, Z-Wave

              External applications: Homebridge-homeseer, Geofency, EgiGeoZone.

              Comment


                #8
                I am running 3.0.1.42 on HS4 (beta).

                Is the "In/Out Bed Notifications" working? I don't see that as a device and I am hoping to make some events happen once out of bed (after so many minutes).

                Comment


                  #9
                  Originally posted by jmaddox View Post
                  When I click "Get Withings Auth code" from the plugin config section it opens a webpage(using chrome) on the withings website. Clicking "allow this app" button then returns

                  {"errors":[{"message":"redirect_uri_mismatch: The redirect URI provided is missing or does not match partner callback url"}]}
                  on the Withings page
                  I have not run into that, but there is an official transition of the developer account going on right now. I'll give it a test tonight and see if it's acting up for me.
                  MeiAutomtion Home

                  Comment


                    #10
                    Originally posted by edstasneyjr View Post
                    I am running 3.0.1.42 on HS4 (beta).

                    Is the "In/Out Bed Notifications" working? I don't see that as a device and I am hoping to make some events happen once out of bed (after so many minutes).
                    It's not a device, but I'll add that tonight or tomorrow night and get another beta out (as well as more logging)
                    MeiAutomtion Home

                    Comment


                      #11
                      Frank,

                      I installed the beta and seems to be working better. Reauthorized my withings and devices still not updating. Thanks for your continued efforts on the Plugin. Happy New Year.

                      Will

                      Comment


                        #12
                        Originally posted by wkrasner View Post
                        Frank,

                        I installed the beta and seems to be working better. Reauthorized my withings and devices still not updating. Thanks for your continued efforts on the Plugin. Happy New Year.

                        Will
                        Did you start from scratch?

                        Can you turn on debug logging and then restart the plugin, let it run for a bit (maybe do something that would trigger data changes) and then send me the logs?
                        MeiAutomtion Home

                        Comment


                          #13
                          Frank,

                          Working now!!! Thank you and Happy NY

                          Will

                          Comment


                            #14
                            Originally posted by wkrasner View Post
                            Frank,

                            Working now!!! Thank you and Happy NY

                            Will
                            So glad to hear and so sorry for the long wait!
                            MeiAutomtion Home

                            Comment


                              #15
                              Originally posted by sirmeili View Post

                              It's not a device, but I'll add that tonight or tomorrow night and get another beta out (as well as more logging)
                              I updated the 3.0.1.43 and the device added but has not update the last two mornings. The last time stamp is that of when the device was created.

                              Did I miss something?

                              Comment

                              Working...
                              X