Announcement

Collapse
No announcement yet.

A Homeseer setup in New Zealand

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • A Homeseer setup in New Zealand

    This is follow-on post from another thread about xAP. I didn't want to thread hijack so have started a new thread (good forum manners I hope).

    I'm not an Homeseer or xAP expert and am still very much in the 'experimental' stage. We are planning a new build next year so I have taken the opportunity to 'retrofit' our existing old house with various home automation pieces. To that effect I have set up a home automation test bench.

    So, I'm not sure what you mean by 'new flash XAP'. But I use Michael xAP plug-in to control the xAP stuff. My setup so far:
    Kevin Hawkin's C-Bus xap interface for C-Bus lighting (works very well, stable and responsive)
    3 x WebControl interfaces via xAP with xapmcsWebControl (works well, took a bit of setting up, still a few minor kinks to sort out) to control rubbish bin detection, washer and dryer status etc
    EDS OneWireServer using Ultra1Wire2 plug-in for various environmental sensors
    DSC alarm system using BLDSC plug-in (works very well), use motion sensors for lighting control (lights on for motion etc)
    Way2Call for voice mail (works well, took a while to get working properly, driver issues etc), CID does not work here in New Zealand
    NetComm USB modem using Steve SnevlCID script (works well, Steve was amazing with his support)
    USB UIRT interface for IR (works well)
    CurrentCost power meter (works well but only moderately accurate)

    Rackmount UPS with power filter monitored by BLUPS
    Various scripts and plug-ins that I am experimenting with at this stage most still in trial mode (e.g. BLOutlook - having problems, BLIcon, VistaGadget - some minor bugs)
    All running on HSPro 2.5.0.44 in Windows 7 x64. Where possible I have used power over ethernet (POE) to power interfaces using splitters powered from a gigabit D-Link POE switch (see pitcure attached which is my test setup). In the new house there will be a utility room for all the services (HA, audio, video, switch boards etc).

    Still got a lot of learning to do. Trying to get my way around HSTouch (which is nice, but I have a few minor irks with the way it works).

    Also experimenting with security cameras using baluns over Cat5. Have a cheap 8ch linux based DVR but it's not that good because I can't access the video streams. It requires an IE activeX plug-in to work....grrrrr.

    Thanks for you interest.

    Marty
    Attached Files
    iCore5 Win 10 Pro x64 SSD

    HS3 Pro Edition 3.0.0.435 Windows

    BLOccupied:,Device History:,Yamaha:,UltraMon3:,mcsXap:,Restart:,UltraNetatmo3:, UltraM1G3:,Ultra1Wire3:,BLBackup:,Harmony Hub:,DoorBird:,UltraECM3:,Nanoleaf 3P:,UltraRachio3:,Z-Wave:,SDJ-Health:,BLGarbage:,Blue-Iris:,Chromecast:,Pushover 3P:,EasyTrigger:

  • #2
    An update.

    So just a quick update.

    I have started experimenting with motorised blinds and am able to use c-bus shutter relays (L5501RBCP) to control the blinds (Somfy mercure3/30). Kevin Hawkins UKUSA C-bus gateway identifies the shutter relay group as a light which in not a problem as you can use the dimming to set the actual blind height. The trick is to time how long the blind takes to rise (or fall) and set this as the 'time out' when configuring the relay in the c-bus tool kit. What happens then is 100% is fully open and dimming to 50% is half closed with 0% being fully close. Fantastic!!

    Kevin's gateway works like a charm. Just remember to reboot it after making changes with the c-bus tool kit.
    iCore5 Win 10 Pro x64 SSD

    HS3 Pro Edition 3.0.0.435 Windows

    BLOccupied:,Device History:,Yamaha:,UltraMon3:,mcsXap:,Restart:,UltraNetatmo3:, UltraM1G3:,Ultra1Wire3:,BLBackup:,Harmony Hub:,DoorBird:,UltraECM3:,Nanoleaf 3P:,UltraRachio3:,Z-Wave:,SDJ-Health:,BLGarbage:,Blue-Iris:,Chromecast:,Pushover 3P:,EasyTrigger:

    Comment


    • #3
      Marty, it's good to meet another member from the southern hemisphere, great to find another 220V HomeSeer user, and fantastic to find another C-Bus fan. I'm using Kevin's gateway too, but I do have one issue that perhaps you can help me overcome.

      The devices mcsXap creatres in HS all have On/Off and Dim% controls - but to get a light to come on I need to send 2 commands - "Dim 100%" AND "On". This makes nit awkward controlling via HSTouch or the web interface. Do you have the same problem or have I missed a tweak somewhere?

      Secondly, how are you triggering scenes or action control groups in C-Bus from HS?

      On a completely different note you say you're using CAI WebControl devices to control washer/dryer status - can you elaborate?
      Author of Highpeak Plugins | SMS-Gateway Plugin | Blue Iris Plugin | Paradox (Beta) Plugin | Modbus Plugin | Yamaha Plugin

      Comment


      • #4
        Hi Gaz,

        Great to hear from you.

        Yes I have the same issue with C-Bus and the gateway. Each device (light, blind etc) has to set ON and also to a DIM level. So my events that I run send 2 commands to the gateway. I think you can do the same from HS Touch.

        To be honest I haven't spent much time on the home automation side of things recently because we have been focusing on the plans for the new build.

        I haven't tried triggering scenes yet.

        And the CAI web control modules are great. I have had them running non-stop for several months now and they haven't faulted. I use them to detect motion using cheap $5 TTL motion sensors from eBay, infra red beams for driveway and rubbish bin detection, and dryer/washer status. The web controls use TTL levels so I use a basic induction coil and simple TTL driver circuit to see if the device is drawing power or not. That way HS can tell if the dryer (or any device) is switched on or not (a current sensor). See this thread http://board.homeseer.com/showpost.p...7&postcount=42

        Let me know how you get on.

        Cheers, Marty.
        iCore5 Win 10 Pro x64 SSD

        HS3 Pro Edition 3.0.0.435 Windows

        BLOccupied:,Device History:,Yamaha:,UltraMon3:,mcsXap:,Restart:,UltraNetatmo3:, UltraM1G3:,Ultra1Wire3:,BLBackup:,Harmony Hub:,DoorBird:,UltraECM3:,Nanoleaf 3P:,UltraRachio3:,Z-Wave:,SDJ-Health:,BLGarbage:,Blue-Iris:,Chromecast:,Pushover 3P:,EasyTrigger:

        Comment


        • #5
          Thanks for the link Marty, looks like I'l be dusting off the soldering iron for a new project. I'm working with Michael McSharry and Kevin to try and avoid the 2-events issue with C-Bus. I tried using a slider control to dim lights and it's not possible with the native controls, and I'm loathe to have to write a load of custom scripts.

          Michael and Kevin have been very helpful - follow the thread here if you like

          http://board.homeseer.com/showthread.php?t=139751
          Author of Highpeak Plugins | SMS-Gateway Plugin | Blue Iris Plugin | Paradox (Beta) Plugin | Modbus Plugin | Yamaha Plugin

          Comment


          • #6
            need a bit of help

            Hi Guys
            I am over in Perth W.A and am having some problems get my Location setup and weather. Do you have any advice on what I can look at to point me in the right direction

            Thanks
            Chris

            Comment


            • #7
              Originally posted by CrawTech View Post
              Hi Guys
              I am over in Perth W.A and am having some problems get my Location setup and weather. Do you have any advice on what I can look at to point me in the right direction

              Thanks
              Chris
              Can you elaborate on the location issue a bit more? Have a look at WeatherXML for a nice weather package.
              -Rupp
              sigpic

              Comment


              • #8
                Yes, Can you elaborate? Note that there has been some change in some weather plugins (blweather no longer works for example). WeatherXML appears to work reading the forums but I have yet to try it.

                Marty.
                iCore5 Win 10 Pro x64 SSD

                HS3 Pro Edition 3.0.0.435 Windows

                BLOccupied:,Device History:,Yamaha:,UltraMon3:,mcsXap:,Restart:,UltraNetatmo3:, UltraM1G3:,Ultra1Wire3:,BLBackup:,Harmony Hub:,DoorBird:,UltraECM3:,Nanoleaf 3P:,UltraRachio3:,Z-Wave:,SDJ-Health:,BLGarbage:,Blue-Iris:,Chromecast:,Pushover 3P:,EasyTrigger:

                Comment


                • #9
                  Hi
                  I have soted the Location problem (my fault )
                  I will have a look at weather part today thanks for your help

                  Comment


                  • #10
                    Originally posted by CrawTech View Post
                    Hi
                    I have soted the Location problem (my fault )
                    I will have a look at weather part today thanks for your help
                    Glad you got this sorted and welcome to the HomeSeer message board. If you have questions post away and we'll do our best to help you out.
                    -Rupp
                    sigpic

                    Comment

                    Working...
                    X