Announcement

Collapse
No announcement yet.

Alexa not working.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Alexa not working.

    Alexa has stopped working after update to newest skill.

    When I try to use Alexa (tell homeseer) she says that I need to link my account. My phone says the account *IS* linked.

    When I tell Alexa "turn on [whatever]" I get a double beep, but nothing in the Homeseer logs.

    Which skill or skills should I be using? And how do I go about troubleshooting and/or fixing this? TIA...
    HomeSeer Version: HS3 Pro Edition 3.0.0.500
    Operating System: Microsoft Windows 10 Pro - Work Station

    Enabled Plug-Ins:
    2.1.0.119: AmbientWeather | 3.0.21.0: BLLock | 2.0.24.0: BLUPS | 1.3.6.0: Device History | 3.0.0.56: EasyTrigger | 3.1.0.7: MeiHarmonyHub | 3.0.6681.34300: UltraCID3 | 3.0.6644.26753: UltraLog3 | 3.0.6554.33094: UltraMon3 | 3.0.0.91: weatherXML | 3.0.1.245: Z-Wave | 3.0.51: HS Touch Designer | 3.0.0.40 Z-Seer+

  • #2
    OK, a quick call to HS fixed this, immediately.

    Bottom line? Homeseer Smarthome Skill is just not ready for prime time. If it works for you, awesome, but it broke my system. Reverting to the two older skills restored function to my system, immediately.

    Kudos, again, to HS support.....
    HomeSeer Version: HS3 Pro Edition 3.0.0.500
    Operating System: Microsoft Windows 10 Pro - Work Station

    Enabled Plug-Ins:
    2.1.0.119: AmbientWeather | 3.0.21.0: BLLock | 2.0.24.0: BLUPS | 1.3.6.0: Device History | 3.0.0.56: EasyTrigger | 3.1.0.7: MeiHarmonyHub | 3.0.6681.34300: UltraCID3 | 3.0.6644.26753: UltraLog3 | 3.0.6554.33094: UltraMon3 | 3.0.0.91: weatherXML | 3.0.1.245: Z-Wave | 3.0.51: HS Touch Designer | 3.0.0.40 Z-Seer+

    Comment


    • #3
      I'm also having issues with Alexa. Sometimes it works and sometimes nothing... says "ok" and nothing.

      In the mobile app (Android) when I look at a device at the top of the screen is a message "There was a problem". The light shows as "off" but I can see that it's really on.

      HS shows the correct status. It's just Amazon not getting updated.

      Comment


      • #4
        Originally posted by jeubanks View Post
        I'm also having issues with Alexa. Sometimes it works and sometimes nothing... says "ok" and nothing.

        In the mobile app (Android) when I look at a device at the top of the screen is a message "There was a problem". The light shows as "off" but I can see that it's really on.

        HS shows the correct status. It's just Amazon not getting updated.
        I can't speak directly to your issue, as you are getting a different "error," but I'd check the HS log to see what HS "heard." Periodically, Amazon does have brief issues, but they always seem to resolve themselves. Rebooting *everything* may be in order.

        My particular issue was reading this forum, the HS website, and the Amazon website with the takeaway that the "HomeSeer Smarthome" skill was the latest and, therefore, best and current skill to use. Homeseer tech support described that understanding as being "misinformed." Anyhow, upon their advice, I deleting that skill and restored the two original skills, which fixed the problem with Alexa.
        HomeSeer Version: HS3 Pro Edition 3.0.0.500
        Operating System: Microsoft Windows 10 Pro - Work Station

        Enabled Plug-Ins:
        2.1.0.119: AmbientWeather | 3.0.21.0: BLLock | 2.0.24.0: BLUPS | 1.3.6.0: Device History | 3.0.0.56: EasyTrigger | 3.1.0.7: MeiHarmonyHub | 3.0.6681.34300: UltraCID3 | 3.0.6644.26753: UltraLog3 | 3.0.6554.33094: UltraMon3 | 3.0.0.91: weatherXML | 3.0.1.245: Z-Wave | 3.0.51: HS Touch Designer | 3.0.0.40 Z-Seer+

        Comment


        • #5
          You should be cautious about using the old Smart Home skill.

          The only reason we still have it is at the whim of Amazon, as it's a legacy skill, which they could shut down at any time. (they wanted us to write over the old skill with the new, but we opted for an entirely different skill)

          If you're having issues with the new skill, I'd be interested in finding out exactly why, so that it can be resolved for you.

          If you're interested, let me know and I'll grab your database from you (so I have your list of devices), and then I can see which device is causing the issue and why.
          Wade

          sigpic

          website | products | support | youtube
          I know nothing...., nothing!!!

          Comment


          • #6
            Originally posted by Sgt. Shultz View Post
            You should be cautious about using the old Smart Home skill.

            The only reason we still have it is at the whim of Amazon, as it's a legacy skill, which they could shut down at any time. (they wanted us to write over the old skill with the new, but we opted for an entirely different skill)

            If you're having issues with the new skill, I'd be interested in finding out exactly why, so that it can be resolved for you.

            If you're interested, let me know and I'll grab your database from you (so I have your list of devices), and then I can see which device is causing the issue and why.
            I'd be happy to work with you on debugging this. I'm new to HS so ignore my ignorance on finding/getting what you need. You said the database? What's the location/filename? I'll zip and PM to you or how do you want it?

            More details of the issue:
            1. Voice commands generally work but there's the intermittent "ok" response with no action taken.

            2. "multiple devices share that name" showing that the "smart groups" is not working.

            3. From the mobile app when I select a device I get the error at the top of the screen in small letters "there was a problem" and the device status is not updated and not correct. If I tap the icon, say light then it switches to "on" even though the light is already on. Then if I tap it again it does turn the device off and tap again it turns on. Something in the status not getting through to Amazon.

            Comment


            • #7
              I won't need your data for this, as it appears your devices are being discovered.

              I will go through your concerns here.

              "Voice commands generally work but there's the intermittent "ok" response with no action taken"

              The commands from Alexa are what are know as a 'fire and forget' process, meaning they generally have no knowledge of the results of a command that is issued.

              The 'ok' isn't a response to whether the action occurred, but more that the request was successfully sent.

              If you do get an 'ok' without the expected action occurring, you should look at the logs in the Echo app and HomeSeer to see what might have happened.


              "multiple devices share that name" showing that the "smart groups" is not working"

              This means the names you've picked aren't unique enough for the process to figure out which device you want to control.
              You'll need to add something to them to distinguish them from each other.

              " From the mobile app when I select a device I get the error at the top of the screen in small letters "there was a problem" and the device status is not updated and not correct. If I tap the icon, say light then it switches to "on" even though the light is already on. Then if I tap it again it does turn the device off and tap again it turns on. Something in the status not getting through to Amazon."

              As I said earlier, the information From Amazon to HomeSeer is one way(apart from the confirmation response).

              If the status of a device in HomeSeer has changed, Amazon does not know about it. (If you turn on the light with the echo, then turn it off with HomeSeer, the echo app will still show it as on.)

              A better approach might be to use the HSTouch app for your phone, which will update the status of devices as they change in HomeSeer.

              If the Echo app has an issue, it will iterate an error message which is what you saw.
              Wade

              sigpic

              website | products | support | youtube
              I know nothing...., nothing!!!

              Comment


              • #8
                Originally posted by Sgt. Shultz View Post
                You should be cautious about using the old Smart Home skill.

                The only reason we still have it is at the whim of Amazon, as it's a legacy skill, which they could shut down at any time. (they wanted us to write over the old skill with the new, but we opted for an entirely different skill)
                I was told, by HomeSeer, to revert to the original skills, because they knew the "HomeSeer Smarthome" skill didn't work for everybody. My follow-up email, to tech support, was referred to an engineer.

                Originally posted by Sgt. Shultz View Post
                If you're having issues with the new skill, I'd be interested in finding out exactly why, so that it can be resolved for you.

                If you're interested, let me know and I'll grab your database from you (so I have your list of devices), and then I can see which device is causing the issue and why.
                I'll be happy to provide anything you need to get to the bottom of the problem, but I don't *think* the issue is on my end. Let me tell you what I did....

                1) I deleted the two original skills.

                2) I installed the "HomeSeer Smarthome" skill, apparently without issue.

                3) I linked the account, apparently, without issue,

                4) I searched for devices and it found devices, but no new devices.

                At this point, Alexa was broken, because any attempt to use her gave the response that I needed to link the account. My android phone, however, clearly indicated that the account WAS linked. So, it wasn't like a particular device didn't work.... it was like Alexa wasn't getting permission to even talk to me.....
                Last edited by ewkearns; April 18th, 2018, 09:58 AM.
                HomeSeer Version: HS3 Pro Edition 3.0.0.500
                Operating System: Microsoft Windows 10 Pro - Work Station

                Enabled Plug-Ins:
                2.1.0.119: AmbientWeather | 3.0.21.0: BLLock | 2.0.24.0: BLUPS | 1.3.6.0: Device History | 3.0.0.56: EasyTrigger | 3.1.0.7: MeiHarmonyHub | 3.0.6681.34300: UltraCID3 | 3.0.6644.26753: UltraLog3 | 3.0.6554.33094: UltraMon3 | 3.0.0.91: weatherXML | 3.0.1.245: Z-Wave | 3.0.51: HS Touch Designer | 3.0.0.40 Z-Seer+

                Comment


                • #9
                  I'm not saying you can't use the old skill, but I can't guarantee that it won't go away at some point in the future.

                  As far as speaking to the engineer, I'm not recalling that conversation, as I am the engineer. (which means I actually can/will look at your problem in depth).

                  The echo app doesn't delete previous devices during a discovery, it just adds new ones (you need to use the echo app in your browser to forget them), so the discovery process might well have failed as you had no new devices and you might not realize it.

                  I'm suspecting one of the devices in your discovery list has something about it that is causing the discovery failure, so I want to grab your database so I can run the devices myself to see which it might be.

                  Then I can correct the issue, so you can use the new skill if you so choose.

                  (the new one has locks and events in it, so it's a little more robust)
                  Wade

                  sigpic

                  website | products | support | youtube
                  I know nothing...., nothing!!!

                  Comment


                  • #10
                    Originally posted by Sgt. Shultz View Post
                    You should be cautious about using the old Smart Home skill.

                    The only reason we still have it is at the whim of Amazon, as it's a legacy skill, which they could shut down at any time. (they wanted us to write over the old skill with the new, but we opted for an entirely different skill)

                    If you're having issues with the new skill, I'd be interested in finding out exactly why, so that it can be resolved for you.

                    If you're interested, let me know and I'll grab your database from you (so I have your list of devices), and then I can see which device is causing the issue and why.
                    I'm interested in how this corresponds with the Homeseer skill "tell/ask" skill. Is this a legacy skill as well and will it potentially go away as well?

                    So for further clarification, if I use the new Smarthome skill and the Homeseer skill moving forward, can I conclude that this should not be a problem?

                    Robert
                    HS3PRO 3.0.0.500 as a Fire Daemon service, Windows 2016 Server Std Intel Core i5 PC HTPC Slim SFF 4GB, 120GB SSD drive, WLG800, RFXCom, TI103,NetCam, UltraNetcam3, BLBackup, CurrentCost 3P Rain8Net, MCsSprinker, HSTouch, Ademco Security plugin/AD2USB, JowiHue, various Oregon Scientific temp/humidity sensors, Z-Net, Zsmoke, Aeron Labs micro switches, Amazon Echo Dots, WS+, WD+ ... on and on.

                    Comment


                    • #11
                      "multiple devices share that name" showing that the "smart groups" is not working"

                      This means the names you've picked aren't unique enough for the process to figure out which device you want to control.
                      You'll need to add something to them to distinguish them from each other.
                      How much more unique does it have to be compared to other systems? The same names I've used with SmartThings, Vera, Home Assistant and they work.

                      Room: Family Room
                      Echo: In Family Room
                      Smart Group: Family Room with echo associated
                      Devices:
                      Family Room Main Lights
                      Family Room Ceiling Fan
                      Family Room Floor Lamp
                      Family Room Desk Lamp

                      Same for Living room with change Family Room to Living room and have the following devices

                      Living Room Small Lamp
                      Living Room Tower Lamp
                      Living Room Floor Lamp

                      Each "room" has an echo and it is in a smart group. If I am in the family room and say turn on/off the floor lamp I get the "multiple devices have that name". Even though the echo that is responding is in the smart group.

                      Same with living room or with any other room, I have to use the Full Name of "Living Room Tower Lamp" otherwise I get the same error about multiple devices share that name.

                      Comment


                      • #12
                        The skill that uses 'Tell HomeSeer' is known as a 'custom' skill, which is different than the 'Smart Home' skill.

                        While it is considered a legacy product, Amazon has indicated that unless we want to make a change to it, it will remain as it is.

                        This is the reason we have not added any other English speaking countries to it..., as that will require a rework of the existing process if we do.


                        Having both the Smart Home skill and the custom skill on your echo app at the same time is fine, as they are different skill types.
                        Wade

                        sigpic

                        website | products | support | youtube
                        I know nothing...., nothing!!!

                        Comment


                        • #13
                          Originally posted by jeubanks View Post
                          How much more unique does it have to be compared to other systems? The same names I've used with SmartThings, Vera, Home Assistant and they work.

                          Room: Family Room
                          Echo: In Family Room
                          Smart Group: Family Room with echo associated
                          Devices:
                          Family Room Main Lights
                          Family Room Ceiling Fan
                          Family Room Floor Lamp
                          Family Room Desk Lamp

                          Same for Living room with change Family Room to Living room and have the following devices

                          Living Room Small Lamp
                          Living Room Tower Lamp
                          Living Room Floor Lamp

                          Each "room" has an echo and it is in a smart group. If I am in the family room and say turn on/off the floor lamp I get the "multiple devices have that name". Even though the echo that is responding is in the smart group.

                          Same with living room or with any other room, I have to use the Full Name of "Living Room Tower Lamp" otherwise I get the same error about multiple devices share that name.

                          You should check your echo app to see what it thinks it's hearing, as the 'floor lamp' should be enough for the echo to distinguish it. If it's having trouble with the word 'floor' then it would only use the word 'lamp' to find it.

                          Do you have other smart home skills running that have these devices in them?
                          The same device name across multiple skills might cause a problem with the echo, as it doesn't qualify which skill you want to use to execute the command.

                          I might be grabbing your database (HomeSeer.hsd) as well...
                          Wade

                          sigpic

                          website | products | support | youtube
                          I know nothing...., nothing!!!

                          Comment


                          • #14
                            Originally posted by Sgt. Shultz View Post
                            You should check your echo app to see what it thinks it's hearing, as the 'floor lamp' should be enough for the echo to distinguish it. If it's having trouble with the word 'floor' then it would only use the word 'lamp' to find it.

                            Do you have other smart home skills running that have these devices in them?
                            The same device name across multiple skills might cause a problem with the echo, as it doesn't qualify which skill you want to use to execute the command.

                            I might be grabbing your database (HomeSeer.hsd) as well...
                            I thought of the multiple skills and I removed everything else.

                            I will check and see what the echo thinks it is hearing.

                            Sent from my SAMSUNG-SM-G890A using Tapatalk

                            Comment


                            • #15
                              Originally posted by Sgt. Shultz View Post
                              You should check your echo app to see what it thinks it's hearing, as the 'floor lamp' should be enough for the echo to distinguish it. If it's having trouble with the word 'floor' then it would only use the word 'lamp' to find it.

                              Do you have other smart home skills running that have these devices in them?
                              The same device name across multiple skills might cause a problem with the echo, as it doesn't qualify which skill you want to use to execute the command.

                              I might be grabbing your database (HomeSeer.hsd) as well...
                              I checked the history and the echo is hearing "alexa turn on the floor lamp" and the response is "a few things share that name. Which one did you want?"

                              The history shows that it is the Family Room Echo that is hearing and responding. This echo is in a smart group with the devices all in the same group. This is the case with ALL of my echo's in all rooms.

                              Comment

                              Working...
                              X