Announcement

Collapse
No announcement yet.

Single light switch not discovered using "HomeSeer SmartHome" skill (v3 Alexa api)

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Single light switch not discovered using "HomeSeer SmartHome" skill (v3 Alexa api)

    Starting a thread here since it's more appropriate:

    So I have a single GE/Jasco binary switch on my network that is not being picked up by an Alexa discovery. It sees the others are just fine.
    I can interact with this switch, no problem, in HS3...

    1) Name is "Patio Light"
    2) "Voice Command" checkbox is checked
    3) "Voice Command" textbox is set: "Patio Light"
    4) "Is Light" checkbox is checked
    5) 31 neighbors, so it's not a communication issue.
    6) I've tried deleting the device and re-added it to HS. No luck.
    7) I've tried renaming the device. No luck.
    8) I've specified a "Code" of "P1" in case that mattered. No luck.
    9) Tried a "forget all" from alexa and re-discovery. All devices were found, again, except for this one.

    Manufacturer Jasco Products (ID=0x63)
    Product Type 0x5257 (model: 45709)
    Product ID 0x3533
    Supports Status Yes
    Library Type Routing Slave
    Z-Wave Lib Version 3.4 (ZDK 4.54)
    Application Version 3.25
    Command Class Switch Binary
    Command Class Version 1

    Granted it's an older switch, but it's still z-wave. Is there a minimum version of zwave or hardware in order to make the device available via Alexa? What's the requirements of the homeseer alexa skill for a device to show up?

    Alexa skills installed: "Homeseer Smarthome", "HomeSeer Home Automation Skill"

    -----

    To start this off, I've told alexa to forget all devices, unlinked all homeseer skills. Now that this is a fresh skill install...

    Linked & Discover --> "HomeSeer" skill (Alexa V2 api)
    I now see my "Patio Light" and can interact using Alexa, I'm showing 38 devices.

    I then unlinked & forgot all devices.

    Linked & Discover --> "HomeSeer SmartHome" skill (Alexa V3 api)
    I've lost my "Patio Light", but I've picked up a few locks (expected, since the v3 api sees locks).

    It really looks like this has got to be a bug in the "HomeSeer SmartHome" skill. Here's the deal. If I have that physical switch, and it's the only switch in a location (Floor/Room). There's other devices in that location, but nothing else marked as voice.

    While debugging scenarios, I created a virtual device, and put it in the same floor & room & left it as the default name, no voice name specified, "voice command" is checked, and did another discovery -- now that virtual device is found. It shows as "Outside Patio New Device". This is working as expected. I did a "Forget" on the virtual device.

    Next, I renamed that physical switch to "Patio Light Switch" (from "Patio Light") in HS and left the voice name "Patio Light". Discover, and still only the virtual device is found. I did a "Forget" on the virtual device.

    Next, I renamed the virtual device to "Patio Light VD" in HS, with NO other changes. I did another discovery. At this point, I would just expect alexa to show the virtual device with the new name... BUT... Low and behold, the physical switch appears now, but the virtual switch does not. So now after a big WTF, somehow the physical device is stomping on the virtual device (which is fine, I guess) -- except now I have a useless virtual device in HS. I guess I can now remove the virtual device and rediscover, since alexa doesn't seem to ever remove devices, but only add them. I'd only be stuck if I would have to rebuild my list from scratch.

    I replicated this twice just to be sure it wasn't a communication error or a fluke. Oh, and to be clear -- discovery & forgets were done through the alexa website to speed things along (https://alexa.amazon.com)

    Can a dev at HomeSeer try and replicate this behavior?

    If it helps:
    HS3 Pro Edition 3.0.0.435 (Windows)
    Operating System: Microsoft Windows 10 Home - Work Station
    OS Version: 10.0.16299 Service Pack: 0.0
    Plug-Ins Enabled: ImperiHome:,BLLAN:,Nest:,MeiHarmonyHub:,Z-Wave:,JowiHue
Working...
X