Announcement

Collapse
No announcement yet.

Problems With Device Discovery

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Problems With Device Discovery

    Posted in another thread, but decided to make this its own thread.
    I have a very similar issue, which Amazon support has not been able to fix. I had the Alexa-Homeseer interface working almost perfectly for months. I could even manage my Insteon thermostat (with some patience). But one day she told me I had two thermostats, and which one did I want to control? I have exactly one thermostat. So I called customer support. They had me disable and re-enable my HomeSeer skills (For some reason I had both running). Well, not only did that not work, it apparently created duplicates of all 200 of my devices. And I couldn't control any of them via Alexa. I would say, "Alexa, turn on such-and-such," and she would respond, "The skill associated with that device is not enabled." (You would think she would say "Several devices have that name, which one do you want?" But noooooo....) Both skills are currently enabled (and by the way, I would really like to keep just one enabled, the good one, but I'm afraid to screw things up even more).

    What I really want to do is delete all my smarthome devices en masse, but there is nothing in the Alexa app to accomplish this. Or is there? Somebody mentioned a "Forget All" function on the website???? Then I would attempt to re-discover all the devices in just one skill. Will that work, or is re-discovering devices a problem now?


    Jim Speiser
    30-year veteran of Home Automation
    Still don't know squat

  • #2


    Jim Speiser
    30-year veteran of Home Automation
    Still don't know squat

    Comment


    • #3
      Originally posted by JimSpy View Post
      Somebody mentioned a "Forget All" function on the website???? Then I would attempt to re-discover all the devices in just one skill. Will that work, or is re-discovering devices a problem now?
      Yes, go to https://alexa.amazon.com. Go to Smart Home->Devices and scroll all the way to the bottom. Click on "Forget All", and then "Discover". It should rediscover all your devices. It always worked for me in the past year, except a couple of weeks ago, when I had some trouble discovering, so I had to email HomeSeer tech support.

      Comment


      • #4
        Originally posted by randman View Post

        Yes, go to https://alexa.amazon.com. Go to Smart Home->Devices and scroll all the way to the bottom. Click on "Forget All", and then "Discover". It should rediscover all your devices. It always worked for me in the past year, except a couple of weeks ago, when I had some trouble discovering, so I had to email HomeSeer tech support.
        That's terrific, thanks. You just solved a problem I've been going back and forth with Amazon about for 2 months. I kept complaining that they didn't have a "forget all" function, and instead of telling me what you just did, they simply apologized.

        Now, a couple more questions:
        1. How long does it take the changes I made on the website to propagate to my smartphone app? So far, I don't see it....Retracted, I see it now.
        2. When I first had this configured, before it went haywire, the discovered devices named themselves in a very appropriate fashion: If the device had a unique name, like air purifier, it was simply named "air purifier." But if it was one of several with the same name, then the Alexa name became the room + the device name, or if the room existed on two floors, floor + room + device name, for example, "First Floor Guest Bath Exhaust Fan" and "Second Floor Guest Bath Exhaust Fan." So I didn't have to say a mouthful for every device I wanted to control.

        Now, it's ALL floor + room + device name. I guess I have to edit them individually, but I don't remember doing that the first time round. Oh well. Thanks again!


        Jim Speiser
        30-year veteran of Home Automation
        Still don't know squat

        Comment


        • #5
          Originally posted by JimSpy View Post
          Now, it's ALL floor + room + device name. I guess I have to edit them individually, but I don't remember doing that the first time round. Oh well. Thanks again!
          A while back, when the new version of the skill just came out, I inadvertently had the old and new versions of the Alexa skill. I had to say the floor name as part of voice commands. Then I realized I hadn’t gotten rid of the old skill. I removed it, and problem solved.

          I don’t have any room names that are used on more than one floor, so I have never had the need to use the floor name for voice commands. I try to make all my devices have a consistent naming convention (such as ceiling lights for any recessed lights on the ceiling, chandelier for any lights hanging down from the ceiling, lamp for any lamp, etc.). That way, it’s easy for people to know what to call a light as long as they know the room name. For most of my devices, I did not fill in the Voice Command field, and I just use room name + device name for them.

          I have an Echo or Echo in just about every room, so I created one group per room, and I assigned the Echo and all the lights in the room to the room’s group. This allows me to say “Alexa, turn off lights” without having to say the room name.


          Comment


          • #6
            CANNOT DISABLE THE SKILL

            I clicked on the disable skill button, told Alexa to forget all Smart Home devices (and confirmed they were gone), rebooted HS3, and changed the password on MyHS Remote to prevent linking. It STILL imports all HS3 devices whenever I tell Alexa to discover devices, unless HS3 is shut down. Alexa shows the HS skill is disabled.

            Any suggestions?

            Comment


            • #7
              Originally posted by CJVann View Post
              CANNOT DISABLE THE SKILL

              I clicked on the disable skill button, told Alexa to forget all Smart Home devices (and confirmed they were gone), rebooted HS3, and changed the password on MyHS Remote to prevent linking. It STILL imports all HS3 devices whenever I tell Alexa to discover devices, unless HS3 is shut down. Alexa shows the HS skill is disabled.

              Any suggestions?
              Join me and become a Luddite?


              Jim Speiser
              30-year veteran of Home Automation
              Still don't know squat

              Comment

              Working...
              X