Announcement

Collapse
No announcement yet.

Alexa is not discovering any devices.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Alexa is not discovering any devices.

    I moved over from vera to homeseer about 2 months ago, alexa was working fine with vera , now I found some time to set it up with Homeseer. But no luck.

    -I first deleted the vera skill and "forget all "in the alexa app.
    -Installed the Homeseer smarthome skill.
    -linked it with MyHS and it shows in green "linked"
    -back to the alexa app and clicked "discover"....... nothing , just my sonos devices are discovered , but nothing from Homeseer.

    -rebooted the Homeseer computer ( windows 10)
    -deleted the skill , and re enabled it , rediscovered ... nothing.

    What am I missing?
    Other threads I noticed this is important:
    Click image for larger version  Name:	2020-01-08 13_42_07-Setup.jpg Views:	0 Size:	20.8 KB ID:	1352773

    Anyone has an idea wat I am missing? or how to troubleshoot?

    Thanks,
    Cor

    Current Date/Time: 08/01/2020 13:46:58
    HomeSeer Version: HS3 Standard Edition 3.0.0.548
    Operating System: Microsoft Windows 10 Pro - Work Station
    System Uptime: 0 Days 0 Hours 30 Minutes 28 Seconds
    IP Address: 192.168.68.20
    Number of Devices: 478
    Number of Events: 115
    Available Threads: 1023
    HSTouch Enabled: True
    Event Threads: 1
    Event Trigger Eval Queue: 0
    Event Trigger Priority Eval Queue: 0
    Device Exec Queue: 0
    HSTouch Event Queue: 0
    Email Send Queue: 0
    Anti Virus Installed: Windows Defender
    In Virtual Machine: No MFG: asustek computer inc.
    Enabled Plug-Ins
    1.0.0.0: drhsEventEnabler
    3.0.0.40: ImperiHome
    3.1.0.16: MeiHarmonyHub
    0.0.0.47: Pushover 3P
    3.0.7.3: SDJ-Health
    3.1.0.51: Sonos
    3.0.1.252: Z-Wave

  • #2
    A lot of troubleshooting with help from homeseer support the last 2 weeks. Looking at (hardware) firewalls, settings etc didn't reveal anything.
    This morning a breakthrough, I deleted all my devices , created a new virtual device (with voice controll) and that one was discovered in Alexa.

    When I restore my backup with al my devices, Alexa discovers nothing. Something is wrong with my devices.

    I have 1 theory; When I used the vera plugin it created hundreds of devices for my motion detectors. The plugin wasn't working for me , so I deleted the plugin and all devices it created.I think due to the numourous (false) devices it created, something went wrong.

    But now , how do I solve this? Starting from scratch ..... it took me days to include all devices, all my events will be broken as well. This will be my absolute last resort.
    I tried to "import nodes from controller and scan" but that gave me a lot of errors "failed to get security scheme..........." I aborted since I also think that this will not get me the correct names I gave them.

    Anyone has an option what I can try?

    Thanks,
    Cor

    Comment


    • #3
      Theory was wrong.

      With help of Homeseer support , they suggested to delete devices by plugin. Now it seems that when I delete devices from the Plugin "sonos" and "Mei Harmony hub" Alexa is discovering devices.
      Afterwards I can enable the sonos plugin again , but as soon as I enable the "Meiharmony plugin" alexa stops discovering. When I disable both sonos and Harmony , therafter enable the sonos ... Alexa starts discovering again.


      Anyone has a suggestion why this is happening?

      With HS4 Harmony should be working without the MeiHarmony plugin, so I am willing to wait a short while , but can there be something wrong with the sonos pluginb/devices as well , something to check , not to have a problem in a year or so, when it is "impossible" to roll back for events and interaction between devices?

      Thanks,
      Cor

      Comment


      • #4
        2 other threads started for the 2 plugins what might be the issue:
        Sonos:
        https://forums.homeseer.com/forum/me...ugin-is-active
        Meiharmonyhub:
        https://forums.homeseer.com/forum/au...ugin-is-active

        Comment


        • #5
          I added a few new devices and they did not show up. I also had several devices just stop responding to voice commands. Deleting devices and rediscovery caused lots of problems last time so I was not going to do it again!!! This time I just disabled and reenabled both HS skills. It seems to have worked! My devices are now included and all are responding. Whew!!
          .

          Comment

          Working...
          X