Announcement

Collapse
No announcement yet.

Alexa skill doesn't work. Tried everything

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    #16
    Originally posted by spud View Post

    Could you do this:
    From Tools > Scripts commands, enter hs.debugmode=2048 then click run
    this will turn on json debugging
    then try the command that fails from Alexa, and post here what you get in the logs
    thanks
    I'll have to go through the upgrades to .17 again first. I'm not at home today but will hopefully be able to do this tomorrow.

    Comment


      #17
      Hi,
      works perfectly in French with HS3. ๐Ÿ˜๐Ÿ˜

      Even if it is not officially supported.๐Ÿ˜Š๐Ÿ˜Š

      Jean-Francois

      Comment


        #18
        Lately we've noticed that we're getting a lot of "sorry living room light is not responding" (or pick another device) particularly when we go to bed. My wife asked last night, "what's wrong with Alexa these days?" I told Alexa to discover then it works. This has happened the past two nights.
        HS3PRO 3.0.0.500 as a Fire Daemon service, Windows 2016 Server Std Intel Core i5 PC HTPC Slim SFF 4GB, 120GB SSD drive, WLG800, RFXCom, TI103,NetCam, UltraNetcam3, BLBackup, CurrentCost 3P Rain8Net, MCsSprinker, HSTouch, Ademco Security plugin/AD2USB, JowiHue, various Oregon Scientific temp/humidity sensors, Z-Net, Zsmoke, Aeron Labs micro switches, Amazon Echo Dots, WS+, WD+ ... on and on.

        Comment


          #19
          I'm trying to investigate the Alexa issues that happen specifically with HS 4.1.17.0
          If you have some problems with Alexa with other versions please open new threads
          Jez,
          zakrzep
          ,
          can you tell me if you are using the HomeSeer Home Automation Skill (i.e tell HomeSeer) or the HomeSeer SmartHome Skill ?

          Comment


            #20
            Originally posted by spud View Post

            Could you do this:
            From Tools > Scripts commands, enter hs.debugmode=2048 then click run
            this will turn on json debugging
            then try the command that fails from Alexa, and post here what you get in the logs
            thanks
            This is what I get in the logs when running debug and issuing an Alexa command:

            6/23/2021 11:10:19 AM
            HomeSeer
            DEBUG JSON
            Query: request=echocontrol&command=ON&ref=258&token=117244771818771 77534

            Alexa response: "XXX isn't responding. Please check its network connections and power supply." XXX represents all HS devices that are shown in Alexa.

            Comment


              #21
              Originally posted by chuckk9032 View Post

              This is what I get in the logs when running debug and issuing an Alexa command:

              6/23/2021 11:10:19 AM
              HomeSeer
              DEBUG JSON
              Query: request=echocontrol&command=ON&ref=258&token=117244771818771 77534

              Alexa response: "XXX isn't responding. Please check its network connections and power supply." XXX represents all HS devices that are shown in Alexa.
              Thanks that is helpful
              Can you tell me which skill you are using?

              Comment


                #22
                When I upgraded to V. 4.1.17 thatโ€™s when my problem started before that no issues at all.

                Comment


                  #23
                  Originally posted by phillb View Post
                  When I upgraded to V. 4.1.17 thatโ€™s when my problem started before that no issues at all.
                  Could you do this:
                  From Tools > Scripts commands, enter hs.debugmode=2048 then click run
                  this will turn on json debugging
                  then try the command that fails from Alexa, and post here what you get in the logs

                  Also, please tell me which skill you are using
                  thanks

                  Comment


                    #24
                    Originally posted by spud View Post

                    Could you do this:
                    From Tools > Scripts commands, enter hs.debugmode=2048 then click run
                    this will turn on json debugging
                    then try the command that fails from Alexa, and post here what you get in the logs
                    thanks
                    Hi Spud,

                    Sorry for the late response. I haven't been at home. Attached is a screenshot of the result that I got. Thanks. Click image for larger version

Name:	Alexa commands.png
Views:	106
Size:	604.9 KB
ID:	1480855

                    Comment


                      #25
                      Originally posted by spud View Post

                      Thanks that is helpful
                      Can you tell me which skill you are using?
                      This error was using the Homeseer skill, not the Homeseer SmarHome skill. However, I haven't gotten the HomeSeer SmartHome skill working again either. It is currently disabled.

                      Comment


                        #26
                        I am using the homeseer smarthome skill.

                        Comment


                          #27
                          I upgraded to 4.1.17.0 on Linux. I am using the "Homeseer" skill. All of my devices can still be controlled by Alexa, and I did not refresh or reconfigure anything on the Alexa side. It simply works.

                          In related news, 4.1.17.0 fixes the long-standing bug with Google Home getting device status from HS. I didn't have to re-sync or otherwise mess with my Google Home/HS4 settings. Yay!

                          Comment


                            #28
                            Originally posted by spud View Post
                            Could you do this:
                            From Tools > Scripts commands, enter hs.debugmode=2048 then click run
                            this will turn on json debugging
                            then try the command that fails from Alexa, and post here what you get in the logs

                            Also, please tell me which skill you are using
                            thanks
                            Jun-23 22:35:52 DEBUG JSON Query: request=echocontrol&command=ON&ref=414&token=437410865628173 08661

                            Spud I am using the homeseer skill

                            above is the single line that come up in the log

                            Could you tell me ow to turn this debug mode off some time please

                            let me know if you want anything else
                            Phill

                            Comment


                              #29
                              I am also using the homeseer smarthome skill. Stopped working after 4.1.17.0. And to clarify, I am on Windows. That might be the difference between some users working on Linux?

                              Comment


                                #30
                                Originally posted by phillb View Post
                                Jun-23 22:35:52 DEBUG JSON Query: request=echocontrol&command=ON&ref=414&token=437410865628173 08661

                                Spud I am using the homeseer skill

                                above is the single line that come up in the log

                                Could you tell me ow to turn this debug mode off some time please

                                let me know if you want anything else
                                Phill
                                thanks
                                To turn off json debugging, run the following script command
                                hs.debugmode=0

                                Comment

                                Working...
                                X