Announcement

Collapse
No announcement yet.

TUTORIAL: Setup your Amazon Echo UK to talk to HomeSeer (Workaround)

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • #46
    Originally posted by Jon798 View Post
    OK, so now my dot has arrived and I can use:

    "Alexa, tell the house to run the event test event". Works fine.

    I can't, though, get anything other than "Sorry, can't find device or group in your account" when try and control any devices.

    Also - is there a way to turn off having to confirm running events via voice control? Makes it all a bit long-winded...

    (and how do I migrate my account .com and back to .co.uk? Doesn't seem obvious.)

    Cheers,

    Jon.
    What phrase are you saying to try and control the devices? If events are working then devices should work too.

    With reguards to moving your account back to UK. Can I ask why you moved it to the US? This should only be needed if you are trying to configure the Raspberry pi version or the android apps. If you have an actual echo then you should register it in the UK and use the tutorial to set up the skill.

    If you need to move it back, then go to your Amazon.com account / manage devices / settings. Chnage the country to United Kingdom. Then log into amazon.Co.uk / manage devices. There should be a message at the top saying something about the kindle store. There is a link at the end of the message to migrate it back. Click that and it's done.

    Matt.

    Comment


    • #47
      Originally posted by NJS1964 View Post
      Ive now followed the Tutorial and got it working after a fashion.

      Two questions:

      I've had to change the name of a couple of test events to match their voice recognition phrase as otherwise they don't work - if these differ, is there a trick to ensuring both work (event name & phrase)

      Secondly is there a way to turn off the confirmation question?

      I've unticked the boxes on the setup screen and even blanked out the phrases (which aren't saved through stop/restart incidentally) but even then I get "Question mark?" spoken which I have to reply yes to.

      Have a play with this. It may make your life easier!
      Jon

      Comment


      • #48
        propblem recognising 'the house'

        I have set the phrase to 'the house' instead of 'tell homeseer'. That worked quite well. Now I am struggling, and looking at the history of what Alexa is understanding, when I say 'the house' most times she recognises 'the how's' Obviously that doesn't trigger. Is there a way of having a or ? So to be able to say the house or the how's ? Then it would work either way

        Comment


        • #49
          Unfortunately not. The one thing you could try is going into your alexa account and deleting your history.

          Alexa learns you voice so clearing this down might reset it back to normal. I have not tried this though so not sure if it would make any difference.

          "The house" is still working fine for me.

          Matt.

          Edit: Just checked and you need to do this from amazon.co.uk > manage content and devices > click on your device and then click manage voice recordings. Then click delete

          Comment


          • #50
            Originally posted by jon00 View Post
            Have a play with this. It may make your life easier!
            I'm surprised HS don't put you on the payroll with your contributions - many thanks, this will more than make up for the lack of certain functionality

            Comment


            • #51
              I had this setup and working earlier lat month with a Pi running as a Echo and was working fine.

              I've since purchased a couple of Echo Dots and was playing with the Skills from USA, I've since converted back to Amazon UK and lost these skills.

              I've deleted your Alexa skill and recreated but when I say 'Tell HomeSeer to turn off the kitchen lights' the response I get is 'Hmm Something went wrong please try again in a few minutes'. I have linked the account.

              Any idea what could be causing this?

              Comment


              • #52
                Originally posted by Simonk View Post
                I had this setup and working earlier lat month with a Pi running as a Echo and was working fine.

                I've since purchased a couple of Echo Dots and was playing with the Skills from USA, I've since converted back to Amazon UK and lost these skills.

                I've deleted your Alexa skill and recreated but when I say 'Tell HomeSeer to turn off the kitchen lights' the response I get is 'Hmm Something went wrong please try again in a few minutes'. I have linked the account.

                Any idea what could be causing this?
                Not 100% sure. If it was me I would start by doing the easy stuff like disbaling the skill and then re-enabling it, you will have to re-link your account too.

                Also try restarting Alexa.

                If none of that works still, you could try moving your account back to the US, delete all the skills, then delete your devices. Then move your account back to the UK, delete your devices and then re setup Alexa with the UK app.

                Hopefully the first option will work for you :P

                Matt.

                Comment


                • #53
                  For anyone that has had problems with phrases not being recognised you could give the following a try. I have done this since it is recommended in the Amazon Developer guide. It obviosuly does something since the when it "builds the model" for your skill, it takes a lot longer with these entries.

                  The more phrases you add, technically the more accurate it should get. It also says to vary the length of the phrases with examples of what can be spoken.

                  It may be a placebo but I think it has improved the accuracy for me. Would be interesting to here anyone elses experiences.

                  So here it is. Go into the skill and under sample utterences, delete the one line that is there and replace it with the following:

                  ParseText {to turn on the bedroom light|TextToParse}
                  ParseText {to get the status of the living room ceiling lamp|TextToParse}
                  ParseText {to turn on the living room television|TextToParse}
                  ParseText {to turn on the bedroom television|TextToParse}
                  ParseText {to turn on the black light|TextToParse}
                  ParseText {to turn on the aqaurium light|TextToParse}

                  As said, the more examples you give, the better the recognistion should be. If there are any phrases that give you problems, then add them here and see if it fixes it.

                  Matt.

                  Comment


                  • #54
                    Originally posted by Croccy22 View Post
                    Not 100% sure. If it was me I would start by doing the easy stuff like disbaling the skill and then re-enabling it, you will have to re-link your account too.

                    Also try restarting Alexa.

                    If none of that works still, you could try moving your account back to the US, delete all the skills, then delete your devices. Then move your account back to the UK, delete your devices and then re setup Alexa with the UK app.

                    Hopefully the first option will work for you :P

                    Matt.
                    Switched back to US, deleted skills, deleted devices, moved back to UK, deleted devices, reset up the devices, re enabled the skill, rebooted HomeSeer and all working again now.

                    Thanks for you help :-)

                    Comment


                    • #55
                      Originally posted by Simonk View Post
                      Switched back to US, deleted skills, deleted devices, moved back to UK, deleted devices, reset up the devices, re enabled the skill, rebooted HomeSeer and all working again now.

                      Thanks for you help :-)
                      Glad it fixed it for you

                      Comment


                      • #56
                        Originally posted by Simonk View Post
                        I've just setup a Raspberry Pi as an Echo as per instructions below:

                        https://github.com/alexa/alexa-avs-s...i/Raspberry-Pi

                        This all appears to be working, now I've followed your Guide to setup HomeSeer skill but all I am getting back is "Sorry I couldn't find a device or group called Kitchen Light in Simon's account".

                        I'm saying 'Tell James to turn on the Kitchen Light', James is the Invocation Name. However it doesn't seem to matter if I say James Fred, Bob or anything I get the same response when asking to turn things on or off!

                        Any help gratefully appreciated :-)
                        That's because your device is just called light, not kitchen light.

                        Comment


                        • #57
                          Anyone seen this happening....the wrong device being changed from the voice command - any ideas. They are both defined in HS as <Room> then Lights.

                          Nov-16 14:14:14 Z-Wave Device: Upstairs Guest Bathroom Lights Set to 0
                          Nov-16 14:14:14 TTS Speak (json:OK
                          Nov-16 14:14:14 ASR Device voice command: turn the cinema lights off
                          Nov-16 14:14:14 Info Heard: turn the cinema lights off
                          Nov-16 14:14:14 Jon00_Alexa Script processing time: 24 ms
                          Nov-16 14:14:14 Jon00_Alexa Response sent to Alexa: ''
                          Nov-16 14:14:14 Jon00_Alexa Alexa command heard: 'turn the cinema lights off'

                          Nov-16 14:13:51 Z-Wave Device: Upstairs Guest Bathroom Lights Set to 99
                          Nov-16 14:13:51 TTS Speak (json:OK
                          Nov-16 14:13:51 ASR Device voice command: turn the cinema lights on
                          Nov-16 14:13:51 Info Heard: turn the cinema lights on
                          Nov-16 14:13:51 Jon00_Alexa Script processing time: 25 ms
                          Nov-16 14:13:51 Jon00_Alexa Response sent to Alexa: ''
                          Nov-16 14:13:51 Jon00_Alexa Alexa command heard: 'turn the cinema lights on'

                          Comment


                          • #58
                            Any update on Uk HS/Alexa integration update. Last read it was just a few days away !


                            Sent from my iPhone using Tapatalk
                            Steve

                            Comment


                            • #59
                              'Version 239' of HS3 Required for Echo

                              Originally posted by Croccy22 View Post
                              If you have any problems with the above steps please let me know.

                              I had to try and remember a few steps as I already had an Amazon Developer account created.

                              Thanks, Matt.
                              I have run through the steps. Alexa doesnt see any devices, and when I say to echo 'Echo tell homeseer to turn on the light', it says 'Your HS3 system needs to be updated to version 239 or later in order to use this feature of your echo'.

                              This is further than I have gotten before however. On hearing the comment about upgrading, I upgraded HS3 Linux version to 'HS3 Standard Edition 3.0.0.297 (Linux)' which is the latest version, and still the same response. The fact that Echo can see Homeseer is progress however. Any ideas what it means by 'version 239'.

                              Many thanks

                              Dom

                              Comment


                              • #60
                                Originally posted by Duomi8 View Post
                                I have run through the steps. Alexa doesnt see any devices, and when I say to echo 'Echo tell homeseer to turn on the light', it says 'Your HS3 system needs to be updated to version 239 or later in order to use this feature of your echo'.

                                This is further than I have gotten before however. On hearing the comment about upgrading, I upgraded HS3 Linux version to 'HS3 Standard Edition 3.0.0.297 (Linux)' which is the latest version, and still the same response. The fact that Echo can see Homeseer is progress however. Any ideas what it means by 'version 239'.

                                Many thanks

                                Dom
                                Hi,

                                The error message is a bit of a red herring. As Kong as you are on the latest version it will work.

                                I also had this error when I first tried to get this working. There is a post somewhere on here with which step is wrong to cause this.

                                I will have a look for it later to give you a better clue. But for now let's assume you have made an error on one of the steps in the tutorial. Go back and check them one by one and look for any typos or bits where you have copied and pasted incorrectly. It will be something to do with the steps dealing with authentication but I can't remember which part off the top of my head.

                                Ignore the version error message completely as you are going down the wrong path trying to troubleshoot that.

                                Matt.

                                Comment

                                Working...
                                X