Announcement

Collapse
No announcement yet.

TUTORIAL: Setup your Amazon Echo UK to talk to HomeSeer (Workaround)

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • TUTORIAL: Setup your Amazon Echo UK to talk to HomeSeer (Workaround)

    ** UPDATE **

    The below Tutorial needs a few tweaks due to changes made by HomeSeer and Amazon. The first change to be made is referenced here: http://board.homeseer.com/showpost.p...&postcount=315

    The second change is for people getting the message saying about LITERAL not being allowed anymore. For this problem have a look here: http://board.homeseer.com/showpost.p...&postcount=176


    ------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------

    Hi,

    So after speaking to Wade from HS Support and looking through threads on here it looks like we can manually create a skill so we can use our UK echos with HomeSeer.

    This involves creating a developer account with Amazon which is easy and free.

    This is a bit of a work around but should be ideal until the official plugin gets fixed.

    So here goes:


    Step 1 - Create Amazon Developer Account
    -------


    Go to https://developer.amazon.com/ and click the sign in button in the top right. Log in with your Amazon account.

    If you don't already have a developer account, you will need to fill out some details on the next page such as telephone number, address, company name etc (Just make up a company name). Click save and continue once you have done this. Then accept the developer agreement.

    For payment, leave both options as no and continue.


    Step 2 - Create new Alexa Skill
    -------


    You will now be on the dashboard page. Up the top click on the Alexa tab. Then click Get Started under where it says Alexa Skills Kit.

    Now click on the button that says Add a New Skill.


    Step 3 - Skill Information
    -------


    From the Language drop down select English UK as the language. Leave the Skill Type set as Custom Interaction Model.

    Enter the Name as HomeSeer

    Enter the invocation name as homeseer

    Click Next


    Step 4 - Interaction Model
    -------


    In the Intent Schema box copy and paste the following:

    Code:
    {
    "intents": [
    {
    "intent": "ParseText",
    "slots": [ 
    {
    "name": "TextToParse",
    "type": "LITERAL"
    }
    ]
    }
    ]
    }
    In the sample Utterances box copy and paste the following:

    Code:
    ParseText {The Text|TextToParse}
    Click Next to continue.


    Step 5 - Configuration
    -------


    Change the Service endpoint type to HTTPS. Put a tick in the Europe box and copy and paste the following URL into the text box: https://myhs.homeseer.com/process_echo/

    Under the account linking section choose Yes and copy and paste the following URL into the Authorization URL text box: https://myhs.homeseer.com/echo/user_app/

    Where it says Redirect URL you will notice there is a web URL, at the end of it it says vendorID=??????????????. Copy down the code that is listed there as you will need this later.

    In the Client ID box copy and paste the following: amzn1.application-oa2-client.d839fbb21603478dbd332ab26fc1f1f1

    Change the Authorization Grant Type to Implicit Grant.

    Click next to continue


    Step 6 - SSL Certificate
    -------


    Select the option "My development endpoint has a certificate from a trusted certificate authority.

    Click next


    Step 7 - Testing
    -------


    That is the main configuration done. You should now be on the test screen. Here in the enter Utterence box type in "launch homeseer" without the quotes.

    In the service response box you should get a load of text saying "I'm sorry, your Amazon account is not linked to a homeseer system"

    This just verifies you are connecting OK.


    Step 8 - Setting up your Echo
    -------


    Go to alexa.amazon.co.uk and log in.

    Now click on Skills.

    In the top right click on Your Skills.

    Click on the HomeSeer Skill and Enable it.

    It will then prompt you for your MyHS username and password and a Vendor ID.

    The Vendor ID is the code you got in step 5.

    That should be it! You should now be able to says things like "Alexa, Tell Homeseer to turn off the lounge ceiling light"

    Good Luck!!!

    Matt.
    Last edited by Croccy22; December 15th, 2016, 10:18 AM.

  • #2
    If you have any problems with the above steps please let me know.

    I had to try and remember a few steps as I already had an Amazon Developer account created.

    Thanks, Matt.

    Comment


    • #3
      Matt,

      Thank you for the superb steps. I have followed them to the letter, however, I cannot get it to to turn off lamp. Screenshot attached.

      I am saying "Alexa, tell Homeseer to turn off Living room floor lamp"

      Would this have to do with anything with my "room labeling" ?

      Alexa confirms instruction by repeating it!
      Attached Files
      Steve

      Comment


      • #4
        Try just saying "Alexa tell homeseer to turn off the floor lamp"

        See if that works? Since you only have one device called that it should work.

        Matt.

        Comment


        • #5
          Try not to talk like a robot as well..., instead say it like you're talking to someone.

          Seriously, not having 'the' in the phrase can make a big difference, as those kinds of qualifiers help the parser sort out where the nouns are in the sentence.
          Wade

          sigpic

          website | products | support | youtube
          I know nothing...., nothing!!!

          Comment


          • #6
            Still no option to not use MyHS?

            Comment


            • #7
              Originally posted by IanIreland View Post
              Still no option to not use MyHS?
              I would imagine that's not very easy with how alexa works. When you write an alexa skill there is no way that I can see to give a user configuration options. To talk directly to your homeseer server you would have to tell alexa the ip address or hostname of your server. Since there is no way of configuring that it would have to be hard coded.

              So basically it is technically possible but you would have to run a parsing service on your local network and then write your own alexa skill that points directly to your homeseer server. I expect you could use the homeseer json feature to do the parsing to make things a bit easier.

              Alexa is designed to talk specifically to other cloud based services.

              Anybody feel free to correct me if I'm wrong. Only been looking at Alexa skills for one day so far :P

              Comment


              • #8
                Still no option to not use MyHS?

                sure..., build your own lambda function and point it to an .aspx page on your server.

                (you will need a dns address and route it to your lan IP once it gets there)

                Have the aspx page pull the JSON out of the data from Amazon.

                Reformat it and send it to HS3 once again in JSON.

                Easy peasy!

                I'm pretty sure there's a thread around here somewhere that shows you how to do that.

                Unfortunately, you can't cut Amazon out of the loop, 'cuz that's where the speech to text takes place.
                Wade

                sigpic

                website | products | support | youtube
                I know nothing...., nothing!!!

                Comment


                • #9
                  Originally posted by Sgt. Shultz View Post
                  sure..., build your own lambda function and point it to an .aspx page on your server.

                  (you will need a dns address and route it to your lan IP once it gets there)

                  Have the aspx page pull the JSON out of the data from Amazon.

                  Reformat it and send it to HS3 once again in JSON.

                  Easy peasy!

                  I'm pretty sure there's a thread around here somewhere that shows you how to do that.

                  Unfortunately, you can't cut Amazon out of the loop, 'cuz that's where the speech to text takes place.
                  Thanks for the reply - if I could, I would!!

                  Comment


                  • #10
                    Originally posted by Croccy22 View Post
                    Try just saying "Alexa tell homeseer to turn off the floor lamp"

                    See if that works? Since you only have one device called that it should work.

                    Matt.


                    Is there anywhere I can see the devices that "Alexa" has discovered ?
                    Steve

                    Comment


                    • #11
                      Stevieboy,

                      Do you get the response "That device was not found" for most things?

                      Anything I've tried so far gets that response for some reason although it did ask me to confirm an action on my Hue lights.

                      Than said that!

                      So far that's all I've got but he skill appears to be active and working and Alexa is obviously knowing what I'm asking.

                      K.

                      Comment


                      • #12
                        Originally posted by Stevieboy View Post
                        Is there anywhere I can see the devices that "Alexa" has discovered ?
                        Not with this one as it is Homeseer that parses the text using this method. Amazon doesn't know anything about your devices it just sends a text string to homeseer. The other homeseer API skill is the one that imports the devices but that's not available yet.

                        I have pretty good accuracy on mine. It gets about 95% of commands right. Just trying setting up a test device and call it something like bob. Then say alexa tell homeseer to turn on bob ( that sounds so wrong lol). Just make sure it can understand simple commands.

                        Sometimes I find I have to over pronounce some words to get it to understand them clearly. So saying Dave for example I have to clearly pronounce the V otherwise it gets detected as day.

                        Comment


                        • #13
                          Originally posted by kwatt View Post
                          Stevieboy,

                          Do you get the response "That device was not found" for most things?

                          Anything I've tried so far gets that response for some reason although it did ask me to confirm an action on my Hue lights.

                          Than said that!

                          So far that's all I've got but he skill appears to be active and working and Alexa is obviously knowing what I'm asking.

                          K.
                          Do you have your devices names clearly with no special characters or anything. For example a Device called "Ceiling Light" with a room set as Lounge.

                          Also make sure that your devices all have voice command enabled in the settings of the device.

                          Comment


                          • #14
                            Originally posted by Croccy22 View Post
                            Do you have your devices names clearly with no special characters or anything. For example a Device called "Ceiling Light" with a room set as Lounge.

                            Also make sure that your devices all have voice command enabled in the settings of the device.

                            Its getting better, I notice I too have to over pronounce some words. Things like T.V, works better naming the device television.

                            Not tried anything to do with events yet.

                            It appears to be more about training yourself what to say, then it works fine.

                            Matt, thanks for a great workaround
                            Steve

                            Comment


                            • #15
                              Originally posted by kwatt View Post
                              Stevieboy,

                              Do you get the response "That device was not found" for most things?

                              Anything I've tried so far gets that response for some reason although it did ask me to confirm an action on my Hue lights.

                              Than said that!

                              So far that's all I've got but he skill appears to be active and working and Alexa is obviously knowing what I'm asking.

                              K.
                              Yes, at first I did. Just saying room then device seems to work fine.
                              Steve

                              Comment

                              Working...
                              X