Announcement

Collapse
No announcement yet.

Homeseer Events (Scenes) no longer working in Alexa.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    #31
    Ok, so Alexa stopped discovery for me today. After many hours, I ended up removing all voice options from devices/events and removed all HomeSeer devices and scenes from Alexa. Then I removed one iBlind node that was giving me the most trouble and after re-adding it, the HS4 device was different; it was now a "light" with dim graphics attached to it. I added voice control to it and ran Alexa discovery. Not only did she find it but she CAN CONTROL IT unlike before. I've re-done about 1/2 of my "dimmable" Z-Wave devices and Alexa can control them now rather than displaying "Waiting for HomeSeer...". I think it may have been the new Z-Wave plug-in v 3.0.2.0 I upgraded to several days ago but than in and of itself was not enough nor was a device re-scan; I had to remove the node and re-add it.
    HS4 Pro Edition 4.1.14.0 (Linux - Debian 10) running on Lenovo ThinkCenter
    Plugins: Z-Wave, SDJHealth
    Z-Wave via Nortek USB stick
    HA 2021.3.4 running on HA "Blue" ODROID-N2
    Add-ons: Android Debug Bridge, AdGuard Home, Duck DNS, ESPHome, File Editor, Glances, Home Assistant Google Drive Backup, InfluxDB, Log Viewer, MariaDB, Mosquitto broker, NGINX SSL Proxy, Node-RED, Portainer, SSH & Web Terminal , Samba, TasmoAdmin, UniFi Controller, Visual Studio Code, WireGuard, Z-Wave JS 2 MQTT
    Integrations: AccuWeather, Adaptive Lighting, Alexa Media Player, Entity Controller, Glances, HACS, HomeSeer, Insteon, IPP, Life360, Local IP, Logitech Harmony Hub, Magic Areas, Mobile App, MQTT, Nest, OpenWeather, Ubiquiti UniFi, Zigbee
    Insteon: 2413S Dual Band PLM
    Zigbee: zzh! CC2652R Rev A
    Z-Wave: RaZberry daughtercard on RPi 1B via ser2net

    Comment


      #32
      I am running HS3 version 3.0.0.548 on a HS3 ZEE S2. I have enabled the Homeseer Smarthome skill, and has linked properly to my myhs account. I have had no problem at all discovering devices that have been voice enabled. My problem is that I am unable to have Alexa discover any events (scenes) that have been voice enabled. I have followed previous suggestions, and removed all my HS devices using the Alexa web interface, disabled and re-enabled the Homeseer Smarthome skill, and then re-discovered the HS devices and events. All the devices were discovered, but my single voice enabled test event was not discovered. I have had success in the past when using HS3 on my old Windows based server, but now that I am running on Zee S2 (Linux), nothing I do will enable Alexa to discover events. Currently, I am using Alexa to toggle virtual devices in order to trigger my HS events, but it is a bit cumbersome.

      I would really like my events to be discoverable by Alexa, so any advice / suggestions would be greatly appreciated.

      Comment


        #33
        Not sure if this is related to this thread but I'm running the latest version of HS4.

        To add a "scene" in Alexa, all you need to do is add a string to the "Voice Command" field on the event. This worked as I have 4 scenes in Alex mapping to their corresponding events in HS4. But now when I populate the "Voice Command" field for new events, scenes are no longer being added to HS4.

        I do not believe this is a configuration problem of the skill or my credentials because the following works:
        1. When renaming one of the scenes that did sync, it renames in Alex fine
        2. Running an Alex scene fires the corresponding HS4 event
        3. When adding new Z Wave devices, Alexa discovers them fine when I voice enable them
        The only thing that is not working now is when I voice enable additional HS4 events, they do not show up as an Alexa scene.

        Any ideas?

        Comment


          #34
          Basically, I was running HS3 on a Windows server for months, where events which were accessible via voice using the Alexa Smarthome skill. Then I moved and decided to automate my new home using the HS3 Zee S2. Everything works well with the exception of no longer being able to enable voice activation of my events via the Alexa Smarthome skill. I have actually started from scratch twice, hoping I made a mistake in setting up the Smarthome skill, but I got the same result each time I tried. If importing HS events as Scenes in the Alexa Smarthome skill has been removed, and no longer works, perhaps somebody can let me know. I know I can create virtual devices that act as triggers to execute the events, but that adds complexity to the HS events, so I would prefer to just run my HS events as I did previously wth my Windows installation. Any advice would be greatly appreciated.

          Comment


            #35
            Golfyankee,

            Any idea when this behaviour changed? When did you import the last event that properly Imports into the Alexa Smarthome Skill? Perhaps it is related to a change in the skill or an underlying change in HS.

            Comment


              #36
              You guys should put in a support ticket on this issue as it should work with HS4 with no issues.
              https://dev.homeseer.com/servicedesk/customer/portals
              -Rupp
              sigpic

              Comment

              Working...
              X