Announcement

Collapse
No announcement yet.

Alexa TTS that works better (IMHO) than the solution for Home Assistant.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • mterry63
    replied
    Is there any way to use replacement variables with the MQTT node red flow? If I put a replacement variable in the payload Alexa just reads it literally.

    Leave a comment:


  • AZweimiller
    replied
    <snip>

    Leave a comment:


  • mr.Magoo
    replied
    Originally posted by AZweimiller View Post
    Would it be offtopic to discuss the node-red-contrib-amazon-echo node?
    It's all HS / Node-Red and Alexa so I don't see any harm in that...

    Leave a comment:


  • Statikk
    replied
    Originally posted by AZweimiller View Post
    Would it be offtopic to discuss the node-red-contrib-amazon-echo node? I know this thread is ostensibly about TTS but as mr.Magoo mentioned, this node can do some cool stuff. I got it all set up and now have the ability to say "turn off the television" and it will turn off the one in the same room as the Echo that I activated. I can do the same for "fan" and "lamps".
    I can’t speak for everyone but I would be really interested in a quick how to on the room recognition stuff.

    Leave a comment:


  • AZweimiller
    replied
    Would it be offtopic to discuss the node-red-contrib-amazon-echo node? I know this thread is ostensibly about TTS but as mr.Magoo mentioned, this node can do some cool stuff. I got it all set up and now have the ability to say "turn off the television" and it will turn off the one in the same room as the Echo that I activated. I can do the same for "fan" and "lamps".

    Leave a comment:


  • mik3
    replied
    Originally posted by mr.Magoo View Post


    As long as you use it I think you're good, I have not updated/refreshed mine since I started this thread in August last year.
    Interesting, I've found even with the HomeAssistant method, I have to refresh my cookie after 14 days. Maybe it's my account.

    Leave a comment:


  • mr.Magoo
    replied

    Originally posted by mik3y View Post
    Does the cookie auto-refresh or do we need to login every 14 days to get a new cookie?
    As long as you use it I think you're good, I have not updated/refreshed mine since I started this thread in August last year.

    Leave a comment:


  • mik3
    replied
    Originally posted by mr.Magoo View Post
    It'll be in the debug window, top right of your screen (click the bug)

    Click image for larger version

Name:	debug.JPG
Views:	454
Size:	18.8 KB
ID:	1381698
    I realized I wasn't pushing the inject button. It's working now.

    Does the cookie auto-refresh or do we need to login every 14 days to get a new cookie?

    Leave a comment:


  • mr.Magoo
    replied
    It'll be in the debug window, top right of your screen (click the bug)

    Click image for larger version

Name:	debug.JPG
Views:	454
Size:	18.8 KB
ID:	1381698

    Leave a comment:


  • mik3
    replied
    Originally posted by mr.Magoo View Post
    1-5 for simple login (but you have to login every time you deploy) , 1-7 to grab the cookie

    You might have to change the host/page depending on what you guys use down under.


    Add this flow
    Code:
    [{"id":"8c611665.a086c8","type":"alexa-remote-init","z":"95ab52ba.bdd6d","name":"","account":"24975ac8.2d8616","option":"refresh","x":420,"y":560,"wires":[["d8ab29f.307b4d8"]]},{"id":"29bc7e29.6017c2","type":"inject","z":"95ab52ba.bdd6d","name":"","topic":"","payload":"","payloadType":"date","repeat":"","crontab":"","once":false,"onceDelay":0.1,"x":200,"y":620,"wires":[["8c611665.a086c8"]]},{"id":"d8ab29f.307b4d8","type":"debug","z":"95ab52ba.bdd6d","name":"","active":true,"tosidebar":true,"console":false,"tostatus":false,"complete":"true","targetType":"full","x":630,"y":500,"wires":[]},{"id":"24975ac8.2d8616","type":"alexa-remote-account","z":"","name":"MyAlexa","authMethod":"proxy","proxyOwnIp":"192.x.x.x","proxyPort":"3456","cookieFile":"","refreshInterval":"3","alexaServiceHost":"pitangui.amazon.com","amazonPage":"amazon.com","acceptLanguage":"en-US","userAgent":"","useWsMqtt":"on","autoInit":"on"}]

    1. Double click the Alexa Init / Refresh node and give it a name, and update the account settings (pen)

    Click image for larger version Name:	1.PNG Views:	0 Size:	17.4 KB ID:	1321197

    2. Change the IP to the IP of your device, if you're on a machine where you have a local webbrowser you can leave it as blank/local host but if you need to access it from another device you need to enter the IP it should listen from / bind to.
    Click image for larger version Name:	image_81173.png Views:	3 Size:	40.0 KB ID:	1321195

    3. Point your browser to your IP :3456 and it'll open up the alexa login
    Click image for larger version Name:	3.PNG Views:	0 Size:	15.7 KB ID:	1321193



    4. Login (it'll say "Amazon Alexa Cookie successfully retrieved. You can close the browser." when done
    Click image for larger version Name:	image_81180.png Views:	3 Size:	47.6 KB ID:	1321202


    5. There appears there's a bug so the cookie gets "lost" from the debug window the first time, so once the status says "ready" you can insert and have it refresh the cookie

    Click image for larger version Name:	5.PNG Views:	0 Size:	15.1 KB ID:	1321196


    6. Open the debug window and copy everything in the Local Cookie string (between the " ")
    Click image for larger version Name:	6.png Views:	0 Size:	18.1 KB ID:	1321194

    7. Create a new account and set the method to Cookie and paste your cookie into the cookie field
    Click image for larger version Name:	image_81181.png Views:	3 Size:	26.3 KB ID:	1321203
    I can't locate the debug messages to pull the cookie out.



    Leave a comment:


  • mr.Magoo
    replied
    Because you have your Alexa Account to authenticate via Proxy (and/or no cookie present), you also need to change that IP to the IP of your Node Red Box

    Personally I don't like that method since you need to re-authenticate every time you deploy the settings in Node-Red and/or restart your box,
    so I suggest grabbing the cookie and using cookie as your auth-method.

    See >> https://forums.homeseer.com/forum/ho...91#post1321191

    Leave a comment:


  • Bugman1400
    replied
    Was able to connect to HS4Pro but, I don't know why the Alexa Speak node is directing me to connect to 192.168.1.10:3456........

    Click image for larger version  Name:	Screenshot from 2020-04-26 11-09-40.png Views:	0 Size:	167.4 KB ID:	1380919

    Leave a comment:


  • mr.Magoo
    replied
    OK, tried copy/paste from the forum and had the same issue as you... must be something in the formatting from the forum posts so I added them as text files instead which works for me.

    Leave a comment:


  • Bugman1400
    replied
    Originally posted by mr.Magoo View Post
    When doing what ?


    I just checked the quoted config v.s. an export from what I'm running right now and they're identical except for naming / ip-addresses.
    Just simply tried to import the code into node-red and got the error message. Will try another route.

    Can you confirm Palette..

    Click image for larger version

Name:	Screenshot from 2020-04-25 12-01-47.png
Views:	363
Size:	47.5 KB
ID:	1380771

    Also, is there a way to send JSON file instead of copy & paste code?
    Last edited by Bugman1400; April 25, 2020, 11:04 AM. Reason: Update

    Leave a comment:


  • mr.Magoo
    replied
    When doing what ?


    I just checked the quoted config v.s. an export from what I'm running right now and they're identical except for naming / ip-addresses.

    Leave a comment:

Working...
X