Announcement

Collapse
No announcement yet.

ALEXA Insanity 101

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    ALEXA Insanity 101

    I am working with HS4 beta and have spent multiple hours over multiple days trying to get this to work..

    No matter what I seen to try, the results remain the same - the Alexa skill has only found 3 of 84 devices.

    I've done the below many times:
    In HomeSeer - turning off Voice for all devices
    In HomeSeer - turn on Voice only for control devices I choose

    In Alexa app - remove the HomeSeer skill
    In Alexa app - add the HomeSeer skill back in then scan.

    Any help would be greatly appreciated. WAF is sinking quickly





    #2
    Did you create a new user in HS4 that is the owner of the upgrade HS4 license and connect the Alexa app with that? I had the same issue until I did that.

    Comment


      #3
      Yes. Still no luck

      Comment


        #4
        Originally posted by gelessor View Post
        Yes. Still no luck
        So you changed your myHS user account to use your HS4 license and ensured that this same account credentials are within your HS4 user accounts with admin + local priviledges?
        -Rupp
        sigpic

        Comment


          #5
          Yep.

          Just checked and tried again..

          Comment


            #6
            Finally got it... not sure what the magic combination was but was able to add the devices about 5 to 10 at at a time after disabling the voice and then adding them back manually.

            WAF will be on the rise!

            Comment


              #7
              I just upgraded to HS4 today and was having the same issue with Alexa not recognizing any commands and the Alexa skill not discovering any of the configured HS devices. I did not create a separate user in HS... what resolved the issue for me was first disabling the Alexa Skill, then going to https://myhs.homeseer.com/ and selecting 'Manage Account' instead of 'Access System'. On the next screen I selected 'Change Primary License' instead of 'Change Password'. On the 'Change Primary License' screen I entered my original HS3 produce license and password then my new HS4 license and password.

              Next I enabled the Alexa Skill, entered my login information for myhomeseer.com to link my account and then the discover devices recognized my HS configuration.

              It is now working just as it was before with HS3.

              Hope this helps.

              Comment


                #8
                I am having the same issue. I have tried all the advice in this thread but so far nothing has helped. I switched my primary license from HS3 to HS4. I ensure the same account is being used for Alexa and it has both admin and local privileges. I disabled voice integration on some devices and enabled it again. After every change, I disabled the alexa skill and then enabled/linked it again. All of my previous devices in Alexa are listed as unresponsive. I added a test virtual switch in my HS4 setup just to see if Alex picked up a new device and it does not. Its obvious Alexa is not able to communicate with my HS4. Does anyone have any other advice?

                Comment


                  #9
                  For anyone still having this issue. This post resolved it for me. https://forums.homeseer.com/forum/de...63#post1365363

                  Comment


                    #10
                    For those still struggling with getting devices added to Alexa; are you checking the “control with voice” checkbox in the HS device at the root or feature level? I make sure that the root device is unchecked, and then check the box on the light feature only (save on each after a change to make it stick).

                    Also, devices that have custom status levels or values (I.e. On and Off changed or their value changed from the default 0 and 255) does not work for me.

                    Once I updated my devices accordingly, all imported successfully to Alexa on my end. Just in case it helps someone else :-)

                    Comment


                      #11
                      I'm finally up to 100%. Found that adding in small groups helped as well as DISCOVERING through a computer as opposed to trying to do it on an iPad. THANKS TO ALL THAT HELPED.

                      Comment


                        #12
                        Here's the best way to troubleshoot Alexa/GH issues.


                        Disable voice control for all devices, this can be done by using the check box and drop-down list directly under the words Device List, as seen in the above screenshot.

                        Once you use the check box to select all devices, you will want to use the drop down menu to select Disable Voice. Then, you will want to go through your device list and click the check boxes for the devices you would like to control. There are two rules about enabling voice control:

                        The device must have controls on the right hand side
                        The device must be on/off, dimmable, or thermostat controls.


                        For the device above, you would only want to enable voice control for the HomeSeer HS-WD100+ Switch Multilevel child device.

                        Once all appropriate devices have been selected, you will want to select Enable Voice from the drop down menu, then unlink and relink you account with HomeSeer.

                        It's best to try this with one or two devices at first and then move on to adding more and testing. I'd also recommend doing your connection to Alexa using the web site ie https://alexa.amazon.com/

                        Best,
                        -Rupp
                        sigpic

                        Comment

                        Working...
                        X