Announcement

Collapse
No announcement yet.

Alexa Homeseer Skill Executing Scenes (Events) Twice - Solved!

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Alexa Homeseer Skill Executing Scenes (Events) Twice - Solved!


    I have two separate HS4 systems running at two different properties. Both have been using the Homeseer Alexa skill successfully for years. Starting a few weeks ago my Alexa routines that call HS4 events is now executing every event twice. This starting happen at the same time at both properties. I have tried unlinking the HS4 skill and re-linking and rediscovering all devices/scenes multiple times and I still get the same result. Super frustrating. Any ideas what is happening??

    Thanks in advance.

    Todd


    #2
    I have just noticed this too. When you use a voice command to do an All Off around the house it causes extremely long execution times since the All Off event is executed twice simultaneously. Wanted to post a bug report but unsure where to do that.

    Using Alexa voice routine to run an event - The event runs twice
    -------------------------------------------------------------------------------------

    When I use an Alexa routine using a voice command to run an event, Alexa causes the
    event to run twice immediately.

    Steps to reproduce:

    1. Create a simple event on Homeseer, manually triggered, voice command on, to say .. turn a device on.

    2. Go into Alexa and scan for new scenes and verify the new event is discovered as a scene

    3. While in Alexa create a routine with voice and enter a voice command, add the scene as an action

    4. Tell Alexa the voice command. Verify the device turns on.

    5. Check the Homeseer log and see that the event was run twice.

    Comment


      #3
      What version of HS3/4 are you running.
      -Rupp
      sigpic

      Comment


        #4
        That would be HS4 - 4.1.15.0. I don't think it's the routine part causing this but the turning on of the scene.

        Comment


          #5
          You can create a support desk account here to put in a bug on this:
          https://dev.homeseer.com/servicedesk/customer/portal/2
          -Rupp
          sigpic

          Comment


            #6
            Support suggested setting the "Cannot re-run for 2 secs" on the events that you use voice commands for. That's a pretty good workaround and it does work but doesn't really address the bug.

            Comment


              #7
              Also, if you have more than one alexa device within earshot, double check that the location is set for each. It was getting pretty annoying trying to pause my dish dvr when each dot was performing a pause canceling each other out. I know location was set for each and am guessing an alexa update wiped one of them. Worked fine once that was corrected.

              Comment


                #8
                Not sure why this was marked as solved. Using the "cannot re-run" feature is not a legitimate fix.

                Comment


                  #9
                  The cannot rerun is not working for me it is still running the event twice. Is there a solution for this?

                  Thanks
                  Marcel

                  Comment


                    #10
                    Originally posted by MdeMan View Post
                    The cannot rerun is not working for me it is still running the event twice. Is there a solution for this?

                    Thanks
                    Marcel
                    Also, if there is more than one Alexa within earshot, are they both registered to the same user (in other words, not one for you and one for the little lady?) I ran into this problem. If they're all registered the same, the echo software is SUPPOSED to be able to discern the closest unit to the voice (and this works fairly well). But if one belongs to someone else in the household (not just another profile but a totally different owner) then this functionality does not work and you will see commands executed twice. My temporary solution was to give the more distant one a different wake word (Echo).


                    Jim Speiser
                    35-year veteran of Home Automation
                    Still don't know squat

                    Comment


                      #11
                      Finally after all this time I found what my problem was with events running twice when called through Alexa. For some reason(bug?) the event runs twice when you have the wait speech to finish option checked in the event. Very weird but unchecking this option resolved my issue. I tried checking and unchecking and the result is consistant. Checked event runs twice, unchecked the event runs once.

                      Comment


                        #12
                        Had the same issue -- all 8 of my actions within the event were repeated when using Alex to trigger the event.
                        According to MdeMan's post, removing the wait for speech to finish option in the speak action of the event resolved this.
                        I didn't have a speak option within my event, but I did have a WAIT action within the event just before the last action Private Messages
                        I removed the WAIT action - No duplicate runs of any of the actions. Worked fine.
                        So, I added an "after waiting" condition within the last event number 8 and it repeated only that last event action. Removing the wait within that action resolved it.
                        So -- It's something to do with any "WAIT" within an event and needs to be fixed within the Alexa - Homeseer skill.

                        Comment

                        Working...
                        X