Announcement

Collapse
No announcement yet.

Cant find any devices

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Cant find any devices

    I'm on the Linux version .245

    Everything connected ok, but I get "cannot find any devices".

    Can I turn on more debugging to troubleshoot?
    Attached Files
    HS4Pro Running on a Raspberry Pi4
    68 Z-Wave Nodes, 175 Events, 359 Devices
    UPB modules via OMNI plugin/panel
    Plugins: Z-Wave, OMNI, HSTouch, weatherXML, EasyTrigger
    HSTouch Clients: 3 Android, 1 Joggler

    #2
    Did you look in the amazon Alexa appreciate under settings and connected home to see if the devices were discovered? I added a couple,did rediscovery and was told none discovered, but they are listed there and they work.

    Comment


      #3
      Originally posted by wkomorow View Post
      Did you look in the amazon Alexa appreciate under settings and connected home to see if the devices were discovered? I added a couple,did rediscovery and was told none discovered, but they are listed there and they work.
      Yes - that is the first screenshot above - here it is in larger size:
      Attached Files
      HS4Pro Running on a Raspberry Pi4
      68 Z-Wave Nodes, 175 Events, 359 Devices
      UPB modules via OMNI plugin/panel
      Plugins: Z-Wave, OMNI, HSTouch, weatherXML, EasyTrigger
      HSTouch Clients: 3 Android, 1 Joggler

      Comment


        #4
        You have voice control turned on on those devices? I do have it working without issues. One other wild chance guess - do you have multiple homeseers on your account. I ask for this reason. I had a Zee that failed, I replaced it but the dead one was the primary license in the account and homeseer connect was trying to communicate with that one. I had to add a login to homeseerconnect and join my current system to make it work. I do have homeseer premium connect and can add logins. In fact homeseer needed to delete my login and let me recreate things.

        Comment


          #5
          I am having the same issue, but only it finds one door, not my 47 other devices and the door does not have on/off/dim i have the skill working fine now but not the API

          Originally posted by rmasonjr View Post
          Yes - that is the first screenshot above - here it is in larger size:

          Comment


            #6
            I will explain how your devices need to be configured for the Echo to discover your devices:

            1) The device must have the "Voice Command" check box checked

            2) Look that the "Status/Graphics" tab on your device and check the On/Off/Dim commands. There you will see a drop list labeled "Control Use". This needs to be set to ON/OFF or DIM. This piece of information is used to tell if if those are on/off/dim controls. We needed to add this since you could label your controls with other labels, maybe non US. This control has been there for quite a while and Z-Wave populates it. Also, if you create a virtual device, it gets set properly too. Its possible other plugins are not setting this, or you have some older devices created before we added this. Just select the proper setting for your On/Off/Dim devices.

            3) For thermostats,make sure the Control Use for the set points is set to the proper heat and cool value. The set point is the only device that will be discovered.
            Last edited by rjh; February 28, 2016, 11:06 AM.
            website | buy now | support | youtube

            Comment


              #7
              I guess what you could do then is to create a virtual device, make sure voice control is checked and it has on/off status. Then ask Alexa to rediscover devices. If it finds that one and not the others - then there is an issue with how those devices is set up and not your connection to the API.

              Comment


                #8
                that was the ticket!!! thanks found everything now, i must of missed that in the first instructions.

                Originally posted by rjh View Post
                I will explain how your devices need to be configured for the Echo to discover your devices:

                1) The device must have the "Voice Command" check box checked

                2) Look that the "Status/Graphics" tab on your device and check the On/Off/Dim commands. There you will see a drop list labeled "Control Use". This needs to be set to ON/OFF or DIM. This piece of information is used to tell if if those are on/off/dim controls. We needed to add this since you could label your controls with other labels, maybe non US. This control has been there for quite a while and Z-Wave populates it. Also, if you create a virtual device, it gets set properly too. Its possible other plugins are not setting this, or you have some older devices created before we added this. Just select the proper setting for your On/Off/Dim devices.

                3) For thermostats,make sure the Control Use for the set points is set to the proper heat and cool value. The set point is the only device that will be discovered.

                Comment


                  #9
                  Originally posted by rjh View Post
                  I will explain how your devices need to be configured for the Echo to discover your devices:

                  1) The device must have the "Voice Command" check box checked

                  2) Look that the "Status/Graphics" tab on your device and check the On/Off/Dim commands. There you will see a drop list labeled "Control Use". This needs to be set to ON/OFF or DIM. This piece of information is used to tell if if those are on/off/dim controls. We needed to add this since you could label your controls with other labels, maybe non US. This control has been there for quite a while and Z-Wave populates it. Also, if you create a virtual device, it gets set properly too. Its possible other plugins are not setting this, or you have some older devices created before we added this. Just select the proper setting for your On/Off/Dim devices.

                  3) For thermostats,make sure the Control Use for the set points is set to the proper heat and cool value. The set point is the only device that will be discovered.
                  Yep - that was very helpful - working great now!

                  Rupp, you can tag this thread as fixed, solved, etc.
                  HS4Pro Running on a Raspberry Pi4
                  68 Z-Wave Nodes, 175 Events, 359 Devices
                  UPB modules via OMNI plugin/panel
                  Plugins: Z-Wave, OMNI, HSTouch, weatherXML, EasyTrigger
                  HSTouch Clients: 3 Android, 1 Joggler

                  Comment


                    #10
                    As I said in the other post, you did a great job with this API. The only issue that I have is with the thermostat, see screen attached. It does not recognize it. The Thermostat Family Room Mode is set to Voice Command, am I missing something to proper set it?

                    Edit: I see you responded on the other post, sorry but I'm still confuse on what shoudl I set it at. I think it is setup properly as in the screen attached. On the last screen, the control use will set back to "No Specified"

                    Click image for larger version

Name:	02282016 Thermostat.png
Views:	1
Size:	52.3 KB
ID:	1183597
                    Click image for larger version

Name:	2016-02-28 Thermostat control.png
Views:	1
Size:	23.7 KB
ID:	1183598
                    Attached Files
                    Last edited by alphatech; February 28, 2016, 05:50 PM.

                    Comment


                      #11
                      Originally posted by aldo View Post
                      As I said in the other post, you did a great job with this API. The only issue that I have is with the thermostat, see screen attached. It does not recognize it. The Thermostat Family Room Mode is set to Voice Command, am I missing something to proper set it?

                      Edit: I see you responded on the other post, sorry but I'm still confuse on what shoudl I set it at. I think it is setup properly as in the screen attached. On the last screen, the control use will set back to "No Specified"

                      [ATTACH]52545[/ATTACH]
                      [ATTACH]52546[/ATTACH]

                      Try changing your thermostat heat to heat set point and your thermostat cool to cool set point. That is how mine is and it works great. Then rediscover.

                      Comment


                        #12
                        I was missing step 2.

                        Originally posted by rjh View Post
                        I will explain how your devices need to be configured for the Echo to discover your devices:

                        1) The device must have the "Voice Command" check box checked

                        2) Look that the "Status/Graphics" tab on your device and check the On/Off/Dim commands. There you will see a drop list labeled "Control Use". This needs to be set to ON/OFF or DIM. This piece of information is used to tell if if those are on/off/dim controls. We needed to add this since you could label your controls with other labels, maybe non US. This control has been there for quite a while and Z-Wave populates it. Also, if you create a virtual device, it gets set properly too. Its possible other plugins are not setting this, or you have some older devices created before we added this. Just select the proper setting for your On/Off/Dim devices.

                        3) For thermostats,make sure the Control Use for the set points is set to the proper heat and cool value. The set point is the only device that will be discovered.
                        Last edited by drmcp; February 28, 2016, 07:34 PM.

                        Comment


                          #13
                          This is actually working very well...

                          I have to ask: Why would you use "Alexa, Tell Homeseer to..." instead of this new API approach? Is there an advantage/disadvantage?
                          HS4Pro Running on a Raspberry Pi4
                          68 Z-Wave Nodes, 175 Events, 359 Devices
                          UPB modules via OMNI plugin/panel
                          Plugins: Z-Wave, OMNI, HSTouch, weatherXML, EasyTrigger
                          HSTouch Clients: 3 Android, 1 Joggler

                          Comment


                            #14
                            Originally posted by rmasonjr View Post
                            This is actually working very well...

                            I have to ask: Why would you use "Alexa, Tell Homeseer to..." instead of this new API approach? Is there an advantage/disadvantage?
                            For 90% of stuff, I would use the API (I really like the groups feature). The only time I would use the skill

                            To get the status of devices like temperature (not currently in API)
                            If you want to do fancy stuff - tell homeseer to for 2 hours turn on my porch light
                            Some events - tell homeseer to run good night - turns off all my lights. locks all the doors, set the thermostat to 63. I have been during that every night for a while that it feels really natural.

                            Comment


                              #15
                              Originally posted by wkomorow View Post
                              For 90% of stuff, I would use the API (I really like the groups feature). The only time I would use the skill

                              To get the status of devices like temperature (not currently in API)
                              If you want to do fancy stuff - tell homeseer to for 2 hours turn on my porch light
                              Some events - tell homeseer to run good night - turns off all my lights. locks all the doors, set the thermostat to 63. I have been during that every night for a while that it feels really natural.
                              Ah - gotcha. That makes sense.

                              So far, the family is loving it!
                              HS4Pro Running on a Raspberry Pi4
                              68 Z-Wave Nodes, 175 Events, 359 Devices
                              UPB modules via OMNI plugin/panel
                              Plugins: Z-Wave, OMNI, HSTouch, weatherXML, EasyTrigger
                              HSTouch Clients: 3 Android, 1 Joggler

                              Comment

                              Working...
                              X