Announcement

Collapse

Contacting HomeSeer This Week

HomeSeer is open and operational this week. All orders are being processed and shipped as usual. However, some staff are working from home. If you need to contact HomeSeer for support or customer service, please use our Email or Chat options. https://homeseer.com/contact-us/
See more
See less

Error, bad request with voice requests

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Error, bad request with voice requests

    Last week, I discovered that Google Home and Google assistant could control HS devices through voice commands. I successfully linked my HS account through the Google Home app and everything worked perfectly.

    Next, I linked my wife's phone with the same HS account, but started getting errors. Any time I ask Google home or Google assistant (phone app) to "tell HomeSeer to ....." I get confirmation that she passes the command to HS ("sure here's HomeSeer"). However, HomeSeer responds with "Error, bad request: Object reference not set to an instance of an object".

    I immediately unlinked my wife's phone and re-authorized mine, but still get the same error.

    I have a relatively small network, and this error gets returned on all devices (7 z-wave switches). I've tried linking HomeSeer from my Google home app, restarting the HS3 system, restarting the z-wave plugin, but nothing has worked. I've looked in the log and there are no error messages. Running latest version of HS3 and z-wave plugin. Commands through the web interface and ImperiHome app work perfectly. I desperately want to get the voice commands through google home working. Does anyone have any ideas?

  • #2
    I rebuilt my system and authorized google home access. Voice control has been restored. Has anyone successfully controlled a single HS system, with a single my HS account from two different phones (google accounts)?

    Comment

    Working...
    X