Announcement

Collapse
No announcement yet.

HomeSeer is now available under Home Control in the Google Home App!

Collapse
This is a sticky topic.
X
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Yeah, that might make sense. It saves having to create a virtual device for these situations. Here are a few other thoughts...

    For me the biggest thing to make these integrations better is to take advantage of new devices so that the voice commands are more natural. I am not sure if there is a way to take advantage of the modes/toggle traits to be able to make some of the commands more natural. For instance, I don't want to have to say, "turn the blinds on" instead of "open the blinds"

    I am going to give this a try soon, maybe tonight, so that I can start taking advantage of thermostats. However, do you know if this interface is currently requiring you to relink to update it with new devices? This is a common issue that I have noticed on the google forums from many vendors. If so, here is a note about this...

    To update users' devices without needing to unlink and relink their account, use Request Sync.

    I also think that the decision to add locations to the names might be problematic in the future. I think that you said that you did this so that people don't have to assign rooms in the Home app. However, I think that google knowing the rooms, hopefully, will be important in the future. I have don't my best to tell them that they need to add context/location awareness. If I am talking to the Home in the living room and say, "turn the lights on" it should be smart enough to know I want the living room lights on. They have something called the home graph which I am thinking it the data structure for this awareness.

    -Tom

    Originally posted by rjh View Post
    The V3 Alexa API has scene support also. Since HS does not really have "scenes" by themselves, I was thinking of adding our events as scenes. This way you can run events as scenes. Not sure if we should add a checkbox though to only include the events you want. Some users have hundreds of events so adding all them might just mess things up. Also, it might be nice to have a separate voice command that you can set on each event so you can have descriptive names but a friendly voice command. Hate to complicate the HS UI but this may be the best way to configure it.
    - Tom

    HSPro/Insteon
    Web Site
    YouTube Channel

    Comment


      We talked internally and agree this is the best approach. So the changes are done.

      A "Voice Command" texbox has been added to the event
      In the options section of an event there is a new checkbox: "Include as Voice Command'

      So events will be added as scenes for Google and Alexa. For Alexa, we are not allowed to control locks, security systems, or garage doors. So events with these devices will not be included. I am not aware of any limitation for Google Home, so any event will work.

      I will post when the server side is working.
      website | buy now | support | youtube

      Comment


        Originally posted by rjh View Post
        I wil take a look at the Google docs.

        FYI, I did add a post to the developer forum including details on how to make a plugin work with Google and Alexa, it appears some authors are not seeing this. The info is in the SDK, but I just updated that with more info (Alexa now supports door locks and color light bulbs, and Google supports color bulbs also so I added info on that)

        https://forums.homeseer.com/showthread.php?t=192613
        I don't wish to hijack this but could you comment perhaps on this thread or in the SDK how to use the colour functions? (https://forums.homeseer.com/showthread.php?t=191055) - I would like to use them in a plugin and whilst I see the controluse setting for colorcontrol I don't know how this is expected to behave to set a lamp.

        Comment


          Hi,
          Originally posted by rjh View Post
          Thermostat support is in there and should be working now. If not, tell what model thermostat you have.

          As for scenes, not sure what work has to be done there. Is this something in the Google Home app?
          What is the right version of HS3 with the thermostat support?

          I have three SRT-323 (Zwave) and it's not OK

          if i want to set the heatsetpoint, i give a message:

          Jean-Francois.

          Current Date/Time: 12/12/2017 09:02:11
          HomeSeer Version: HS3 Pro Edition 3.0.0.372
          Operating System: Microsoft Windows 10 Famille - Work Station
          System Uptime: 2 Days 4 Hours 49 Minutes 15 Seconds
          IP Address: 192.168.50.53
          Number of Devices: 423
          Number of Events: 147
          Available Threads: 200

          Enabled Plug-Ins
          2.0.38.0: BLLAN
          1.0.3.0: BLShutdown
          4.8.6.0: BULLET
          0.0.0.28: drhsIpPlugIn
          3.0.0.64: mcsXap
          3.0.0.14: NetCAM
          3.0.1.109: PHLocation
          30.0.0.36: RFXCOM
          5.0.2.0: SCREPOSITORY
          3.0.0.44: X10
          3.0.1.130: Z-Wave

          Comment


            Open a helpdesk ticket by sending an email to support@homeseer.com. We will need to get access to your system through MyHS so we can have a look. It should be working with Google Home.

            Originally posted by jfla View Post
            Hi,


            What is the right version of HS3 with the thermostat support?

            I have three SRT-323 (Zwave) and it's not OK

            if i want to set the heatsetpoint, i give a message:



            Jean-Francois.

            Current Date/Time: 12/12/2017 09:02:11
            HomeSeer Version: HS3 Pro Edition 3.0.0.372
            Operating System: Microsoft Windows 10 Famille - Work Station
            System Uptime: 2 Days 4 Hours 49 Minutes 15 Seconds
            IP Address: 192.168.50.53
            Number of Devices: 423
            Number of Events: 147
            Available Threads: 200

            Enabled Plug-Ins
            2.0.38.0: BLLAN
            1.0.3.0: BLShutdown
            4.8.6.0: BULLET
            0.0.0.28: drhsIpPlugIn
            3.0.0.64: mcsXap
            3.0.0.14: NetCAM
            3.0.1.109: PHLocation
            30.0.0.36: RFXCOM
            5.0.2.0: SCREPOSITORY
            3.0.0.44: X10
            3.0.1.130: Z-Wave
            website | buy now | support | youtube

            Comment


              Running HS3 .368, using an Insteon thermostat 2441TH with thermostat plugin 3.0.6.3 and Insteon plugin 3.0.6.23.

              Thermostat program (root) is defined in GH. I also have 'voice command' set for other components of the thermostat, but none are picked up by GH.

              GH responds to commands for thermostat, but nothing logged in HS, no change on thermostat.

              The status graphics page follows: wondering if those values, used by the plugin for thermostat programs, are incompatible with GH/HS3. If that's the case, can anyone suggest what they should be for a thermostat to work with GH?

              I also realize that all the 'Control use' fields are set to 'Not specified'. I thought of defining some additional value sets, but I don't know how the plugin would even deal with them if I did.
              Attached Files

              Comment


                That thermostat looks odd. You need devices for the MODE and SETPOINTS. I do not see devices there for those. How do you set the mode? (heat/cool) and the setpoints for heat cool? Without those, GH will not work.

                When the thermostat is controlled, HS looks for devices that have the ControlUse set to "HEAT or COOL" and "MODE". It then knows how to control it.

                Originally posted by claude View Post
                Running HS3 .368, using an Insteon thermostat 2441TH with thermostat plugin 3.0.6.3 and Insteon plugin 3.0.6.23.

                Thermostat program (root) is defined in GH. I also have 'voice command' set for other components of the thermostat, but none are picked up by GH.

                GH responds to commands for thermostat, but nothing logged in HS, no change on thermostat.

                The status graphics page follows: wondering if those values, used by the plugin for thermostat programs, are incompatible with GH/HS3. If that's the case, can anyone suggest what they should be for a thermostat to work with GH?

                I also realize that all the 'Control use' fields are set to 'Not specified'. I thought of defining some additional value sets, but I don't know how the plugin would even deal with them if I did.
                website | buy now | support | youtube

                Comment


                  Rich,

                  I have same thermostat, but didn't get to test last night. I can answer the questions as I, at least, scanned through the device setup. The program device he display is the root. There are child devices for mode, heat setpoint, cool setpoint, etc. I looked at those devices and the control use is setup to use the thermostat values. I think that you said that it would scan through child devices, right?

                  -Tom
                  - Tom

                  HSPro/Insteon
                  Web Site
                  YouTube Channel

                  Comment


                    I was sure Rich mentioned that only the root gets picked up, but I can't find that post now. In any case, GH only picks up the root in my experience.

                    Unfortunately, with the Insteon thermostat, the good stuff is in the child devices.

                    I've notified Nathan (Tstat plugin) to see what he thinks could be done.

                    Question for Rich: why does GH only pick up the root device? Is it that GH can't deal with the children presented or is it HS that only publishes the root?

                    Comment


                      Originally posted by claude View Post
                      I was sure Rich mentioned that only the root gets picked up, but I can't find that post now. In any case, GH only picks up the root in my experience.

                      Unfortunately, with the Insteon thermostat, the good stuff is in the child devices.

                      I've notified Nathan (Tstat plugin) to see what he thinks could be done.

                      Question for Rich: why does GH only pick up the root device? Is it that GH can't deal with the children presented or is it HS that only publishes the root?
                      Pass this on to Nathan. Bob did this to the isy plugin to make it work. Specifically post #6 on this thread.

                      https://forums.homeseer.com/showthread.php?t=192467

                      Comment


                        HS only gives the ROOT to GH, but that is only for reference, like the name or voice command setting so it knows how to listen for it. But when GH tries to control it, it passes the ref ID of the root to us, then we cycle through the child devices looking for the correct device to control. We use the ControlUse settings for this. If those are set, it should be work.

                        Open a helpdesk ticket so we can connect to your system, then we can check the server logs and find out why its not finding the correct child device.

                        Originally posted by tpchristian View Post
                        Rich,

                        I have same thermostat, but didn't get to test last night. I can answer the questions as I, at least, scanned through the device setup. The program device he display is the root. There are child devices for mode, heat setpoint, cool setpoint, etc. I looked at those devices and the control use is setup to use the thermostat values. I think that you said that it would scan through child devices, right?

                        -Tom
                        website | buy now | support | youtube

                        Comment


                          Hi, Rjh

                          Originally posted by rjh View Post
                          Open a helpdesk ticket by sending an email to support@homeseer.com. We will need to get access to your system through MyHS so we can have a look. It should be working with Google Home.
                          Mail send

                          Thanks

                          Jean-Francois.

                          Ps :here the time is 08H 57 PM

                          Comment


                            Rich,

                            I have added the ControlUse properties for my Sinope thermostats. GH successfully discover them, but when I try to change the setpoint, I get the following warning and nothing happens

                            Code:
                            Warning	JSON controldevicebyvalue caused an error: Input string was not in a correct format.
                            Here are the devices for my thermostat

                            Click image for larger version

Name:	gh_devices.png
Views:	1
Size:	71.1 KB
ID:	1194335

                            Click image for larger version

Name:	hh_setpoint.png
Views:	1
Size:	53.7 KB
ID:	1194336

                            Comment


                              The value needs to be passed to HS as a double. The first thing we do is convert the value string to a double and it might be throwing an exception there. The ref parameter has to be an integer. Those are the only 2 parameters we need so the issue has to be with one of them.

                              You can enable JSON debugging by going to the Control Panel from the Tools menu then enter this in the textbox:

                              hs.debugmode=2048

                              Now send the command and take a look at the json. If the value is not a number, that is the problem. If it looks ok, post the json here and I can then tell you what the issue is.

                              Originally posted by spud View Post
                              Rich,

                              I have added the ControlUse properties for my Sinope thermostats. GH successfully discover them, but when I try to change the setpoint, I get the following warning and nothing happens

                              Code:
                              Warning	JSON controldevicebyvalue caused an error: Input string was not in a correct format.
                              Here are the devices for my thermostat

                              [ATTACH]65118[/ATTACH]

                              [ATTACH]65119[/ATTACH]
                              website | buy now | support | youtube

                              Comment


                                here is what I get:

                                Code:
                                Dec-13 3:22:52 PM	 	Warning	JSON controldevicebyvalue caused an error: Input string was not in a correct format.
                                Dec-13 3:22:52 PM	 	DEBUG JSON	Query: request=controldevicebyvalue&ref=253&value=&token=xxxx&source=Google
                                Dec-13 3:22:52 PM	 	DEBUG JSON	Query: request=getstatus&devref=253&voiceonly=False&token=xxxx&source=Google
                                Dec-13 3:22:52 PM	 	DEBUG JSON	Query: request=getsetting&setting=gGlobalTempScaleF&token=xxxx&source=Google
                                Dec-13 3:22:51 PM	 	DEBUG JSON	Query: request=getstatus&devref=251,0,253,249&token=xxxx&source=Google
                                so the value is empty...

                                why does it try to get the values of devices 251, 0, 253, and 249 before trying to control the device?

                                Comment

                                Working...
                                X