Announcement

Collapse

Contacting HomeSeer This Week

HomeSeer is open and operational this week. All orders are being processed and shipped as usual. However, some staff are working from home. If you need to contact HomeSeer for support or customer service, please use our Email or Chat options. https://homeseer.com/contact-us/
See more
See less

Google Home fails to link to homeseer

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • #16
    For those that are having issues, try this and see if it works for you.

    Disconnect from the Home Wifi or the network that your homeseer is connected to then link your account.

    This works for me.

    Comment


    • #17
      Originally posted by dannieboiz View Post
      For those that are having issues, try this and see if it works for you.

      Disconnect from the Home Wifi or the network that your homeseer is connected to then link your account.

      This works for me.
      Disconnect what? The mobile device Google Home app is running on or the Google Home device itself?

      Edit: disconnected my phone from the network so it was on mobile data. Same error.
      -Wade

      Comment


      • #18
        dannieboiz not sure what you meant but your post prompted me to try shutting down HomeSeer thereby forcing it off my home network, I then reset (for the n'th time !) the Google Home speaker, powered it off, powered it on and went through the registration process again (all without HomeSeer running). I then tried to link my HomeSeer account to it. Strangely (or not?) I got a different error, this time Google Home did not show the "Unable to update Account settings, Check your connection" error but flashed up, very briefly, a different message (something about assigning a room) so that for a moment I thought that it had worked but back at the Google Home device screen it does not show HomeSeer.
        Google failed to call me back as promised so no progress there. I will chase them but it appears to me that this is some sort of firmware problem in their device which will only be fixed when they provide an update.

        Comment


        • #19
          Also getting the “Couldn’t update the settings. Check your connection.”

          Comment


          • #20
            My issue was similar to you guys where it said couldn't update setting. Then at some point it actually tried to sync but then failed to do so and came back to the original screen to select a system to sync.

            This made me remember a comment here on the forum that when you try to sign onto homeseer on your local network, it actually redirect you to the local IP address. Not sure if it had anything to do with anything but I switch from WiFi to my cellular network. Close out of Home App. (make sure it's closed out and not minimized on your phone) launch the app and sync again and it actually work.


            BTW: go to http://find.homeseer.com and make sure it's pointing back to the correct IP address

            Comment


            • #21
              Originally posted by dannieboiz View Post
              My issue was similar to you guys where it said couldn't update setting. Then at some point it actually tried to sync but then failed to do so and came back to the original screen to select a system to sync.

              This made me remember a comment here on the forum that when you try to sign onto homeseer on your local network, it actually redirect you to the local IP address. Not sure if it had anything to do with anything but I switch from WiFi to my cellular network. Close out of Home App. (make sure it's closed out and not minimized on your phone) launch the app and sync again and it actually work.


              BTW: go to http://find.homeseer.com and make sure it's pointing back to the correct IP address
              Unfortunately this doesn't work in my case.
              -Wade

              Comment


              • #22

                Same here: Unfortunately this doesn't work in my case

                Comment


                • #23
                  Just had another update from Google who asked me to check that all my devices were allocated to Rooms and Floors (all but one of the plug in devices had rooms and floors and changing that had no effect) and also to try changing the device name of 2-3 devices, again I tried that but without success. Others with this problem might want to give this a go?
                  I also noticed, when checking this, that I have 6 orphan devices with 'Unknown' Room and Floor. I have no idea if these are a problem but I cannot remove them via the GUI. I will look elsewhere on the forum for advice (rather than starting another rabbit running on this thread) but just in case anyone else with this Google Home problem notices same.

                  Comment


                  • #24
                    Syncing devices with homeseer is terribly unreliable.. sometimes it takes 10x tries before it syncs without errors... but I have found that I have better success if I type in "sync homeseer" into the google assistant app (versus speaking it to my google home mini).. just FYI

                    Comment


                    • #25
                      Must be an individual situation: Telling GH to "sync my devices" has worked flawlessly, so far.

                      Comment


                      • #26
                        Originally posted by claude View Post
                        Must be an individual situation: Telling GH to "sync my devices" has worked flawlessly, so far.
                        Unfortunately "sync my devices" only works with services that are already connected. Since we can't get Homeseer service to connect with GH in the first place, this command doesn't work.
                        -Wade

                        Comment


                        • #27
                          Claude - it may indeed be a localised problem but if you are feeling brave and would like to try de-linking your HomeSeer account from Google Home and then re-linking it I would be very interested to hear how you get on.

                          Comment


                          • #28
                            Hi all

                            I previously had Google Home and Homeseer working well with about 20 devices. My Homeseer network went tits up for some reason (the z-wave devices at least) and support couldn't fix it, so I reset/removed/re-added/rebuilt everything recently. One of the things I can't get working again is the Google Home integration.

                            It looks like Google Home doesn't like too many devices being added at once, and doesn't like certain devices or device types. I've disabled voice commands for all my Homeseer devices (you can mass enable/disable with that top left dropdown menu) and Google Home picks it up and links no problem. It links (and indeed syncs) with one or two specific devices; for instance the Fibaro Dimmer 1 device, but as soon as I enable voice for certain other devices (Fibaro Dimmer 2 for example) it won't sync, and if I de-link and attempt to re-link the account it won't re-link either.

                            The infuriating thing is that all these devices worked with Google Home and Homeseer previously! I remember I had to keep on trying to link the accounts (like, A LOT) but it eventually worked. Not happening this time though.

                            Would appreciate any ideas!

                            Comment


                            • #29
                              bazyr - thank you this was interesting. FYI, my situation was similar to yours, 25 physical devices with account linked and all working fine until I added one more device and, being under the impression that the only way to get GH to sync the new device was to de-link and re-link my HomeSeer account, did that and since then GH refuses to link my HS account.
                              After reading your post I disabled voice control on all devices and this time I did not get an error but a response saying 'Please Choose room'. Unfortunately my account was still not linked. So I then enabled voice control on one device and tried again and again got as far as the 'Please Choose room' message. I then said 'OK, Google, sync my HomeSeer devices'. Each time I have previously tried this the response has been 'Sorry but I don't know how to help you with that' but this time 'she' said 'You need to link your HomeSeer account before I can do that'. Not sure if this is progress or not but I will explore this a bit more and will certainly report it back to the Google Tech support guys for whom it might ring some bells.

                              Comment


                              • #30
                                Google Home is having issues with keeping the linking from timing out. Try unchecking all of your voice commands and then only check the ones you need that are lights and or thermostats. Then try linking. This has worked around their issues so far.
                                -Rupp
                                sigpic

                                Comment

                                Working...
                                X