Announcement

Collapse
No announcement yet.

Google Home fails to link to homeseer

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    #46
    Originally posted by dannieboiz View Post

    34 HS3 devices
    Ah, yeah thats likely the difference. I've had linking work up to ~42 HS devices. But, I've got ~75 switches, and this is where it bombs.

    Comment


      #47
      Originally posted by jon102034050 View Post

      Ah, yeah thats likely the difference. I've had linking work up to ~42 HS devices. But, I've got ~75 switches, and this is where it bombs.
      Maybe is a timing thing?

      Comment


        #48
        Originally posted by dannieboiz View Post

        Maybe is a timing thing?
        yeah, i would bet google home's timeout is just set too low

        Comment


          #49
          I have 30 switches and 3 door locks. Some things just won't add. I tried unchecked the voice on all of my devices and just tried the 3 door locks and I could only ever get just one of the door locks. No amount of syncing devices or anything seems to make them show up.

          Comment


            #50
            Just want to chime in and mention that I also have this issue - unable to link HomeSeer with Google Assistant - and being frustrated by this. I suspect that there is something wonky in the HomeSeer database that trips Google. Note that Alexa is able to cope with it; had no issues with my Alexa device being able to control my devices.

            It is frustrating to see this issue persist for so long without any noticeable progress towards some sort of a resolution...

            Comment


              #51
              There are now at least 3 threads about this same thing. As I wrote the other day in the thread Totally broken please fix:

              I am able to sync using the Google Home app on my phone (Android) by clicking the mic at the bottom and saying, "Sync HomeSeer." If I use the Assistant (squeeze sides of phone - Pixel 2xl) and say the same, or if I initiate the sync from my home unit, I get the error.
              Maybe it will work for you as well.

              Since I have not changed my HomeSeer installation, but Google Home and Assistant has updated multiple times, I wonder where the problem really is.

              Karl
              Karl S
              HS3Pro on Windows 10
              96 Devices
              54 Z-Wave Nodes
              37 Events
              HSTouch Clients: 3 Android, 1 iOS
              Google Home: 3 Mini units

              Comment


                #52
                HS support told me its a GH timeout issue, they are waiting on GH to fix. I've nagged their support team quiet a bit now, they are very friendly agents, terrific support, but the answer for this problem is always the same, they are waiting on Google to fix. It would be nice if some other customers nag them a little so it doesn't appear to HS that its only affecting one person. If many people complain it might move up the priority list and they will nag Google or whoever fault this isn't working to get a move on it. HS not reading this forum or they would have posted something by now, you need to email HS directly and they will reply to you, probably same what they told me, but if enough people say they are affected by this issue then maybe... just maybe!

                Go here and fill out form with GH integration complaint: https://homeseer.com/support-home/

                Comment


                  #53
                  Ok, so, here goes,

                  I've had a case open with homeseer support for quite a while now regarding this issue (since August 15). At first they told me that it was because I had serveral devices with the same name which might give problems with Google Home, which I thought sounded very far fetched, but sure I gave it a try. That is when I bumped in to the sync/number-of-devices-issue. I did extensive testing, but when that didn't work I tried syncing just four switches named "Window Lamp" in different rooms which worked fine. Then I found another thread on this forum ("Google Home not linking now? - https://forums.homeseer.com/forum/ho...king-now/page6) where it was clear that the number of devices you could sync varied over time. I could clearly confirm that, varying from 28 to 23 devices for me depending on the hour of day.

                  The fact that the number of devices you can sync varies over time to me clearly states that this is a performance issue from the HomeSeer side. From the Google Documentation:

                  As described under "Smart Home intents" at https://developers.google.com/action...e/rest/intents intent action.devices.SYNC requires fulfilment.

                  And as described under "Response Format" at https://developers.google.com/action...sation-webhook it states:
                  "When you receive a request, your fulfillment must return a response that's defined by the conversation webhook response." and "Note: Your response must occur within about 5 seconds or the Assistant assumes your fulfillment has timed out and ends your conversation."

                  As we users can not see the communication between Google and HomeSeer, I can only guess, but to me it seems quite logical that this is exactly what is happening. If you have to many devices with voice control enabled the query from Google to HomeSeer times out. And since the number of devices vary depending on the hour of day it is very likely due to heavy load on the HomeSeer-servers.

                  As getmp3s wrote, the support people are very friendly but they are always trying to pin it on Google and nothing has happened for quite a while now. I am sorry HomeSeer but I am quite fed up with getting "empty" answers from you now My smart home development has been at a standstill for two months now and I have plenty of new devices I want to enable just lying around getting dusty because there is no point in installing them. I switched to HomeSeer from Fibaro HomeCenter 2 just because of the Google Home support working flawlessly at first. Now I am not so sure anymore.

                  Regards
                  /zyrgh

                  Comment


                    #54
                    So i have a weird issue. I noticed the Home android app looks different now so its been updated. I can launch the app...navigate and control lights from the Home app. Now if i say Ok Google.. it loads and if i say my normal.. turn master bathroom lights on... it launches a button and says turning on master bathroom lights but it doesnt. I hit control button on or off and it doesnt work.. weird.. but like said at other screen it works for control in app...
                    HW - i5 4570T @2.9ghz runs @11w | 8gb ram | 128gb ssd OS - Win10 x64

                    HS - HS3 Pro Edition 3.0.0.435

                    Plugins - BLRF 2.0.94.0 | Concord 4 3.1.13.10 | HSBuddy 3.9.605.5 | HSTouch Server 3.0.0.68 | RFXCOM 30.0.0.36 | X10 3.0.0.36 | Z-Wave 3.0.1.190

                    Hardware - EdgePort/4 DB9 Serial | RFXCOM 433MHz USB Transceiver | Superbus 2000 for Concord 4 | TI103 X-10 Interface | WGL Designs W800 RF | Z-Net Z-Wave Interface

                    Comment


                      #55
                      I've had a few occations where Google Assistant would confirm turning on the lights, but nothing happens or there is a very long delay before anything happens (30+ seconds). That goes both for direct commands like "turn on the living room lights", and IFTTT aliases that I have set up to run a HomeSeer event. But after either waiting or issuing the command again it worked. This has happened both before and after the "new" Google Home App. TeleFragger, do you still have this problem or was it just a temporary glitch?

                      On another note, has anyone dared to unlink and relink their HomeSeer-account to Google recently? Two days ago Google Assistant started responding with "An error occured while syncing HomeSeer. Please re-link your account to enable this feature for HomeSeer." when trying to sync.

                      Personally I don't dare to unlink and re-link until someone has confirmed that everything is working OK again. I don't want to have to scale down and remove even more devices than I already have.

                      Click image for larger version

Name:	google-homeseer.jpg
Views:	111
Size:	35.3 KB
ID:	1256887

                      Comment


                        #56
                        zyrgh - still an issue. I have unlinked and relinked. Will give a go now ...
                        HW - i5 4570T @2.9ghz runs @11w | 8gb ram | 128gb ssd OS - Win10 x64

                        HS - HS3 Pro Edition 3.0.0.435

                        Plugins - BLRF 2.0.94.0 | Concord 4 3.1.13.10 | HSBuddy 3.9.605.5 | HSTouch Server 3.0.0.68 | RFXCOM 30.0.0.36 | X10 3.0.0.36 | Z-Wave 3.0.1.190

                        Hardware - EdgePort/4 DB9 Serial | RFXCOM 433MHz USB Transceiver | Superbus 2000 for Concord 4 | TI103 X-10 Interface | WGL Designs W800 RF | Z-Net Z-Wave Interface

                        Comment


                          #57
                          Yup - just read this AFTER unlinking HS from GH after receiving the "Please re-link your account" message and guess what ? Now everything is totally f&*d . It won't re-link at all.

                          I've tried umpteen times and no joy. There does seem to be a consistent 10 second period between logging in and the error "Couldn't update the setting...."

                          The Fix - more of a workaround.

                          1) Go to your HS ipaddress/voice URL - make a note of all the devices that are currently listed
                          2) Go to your main Home screen, select every device, choose DISABLE VOICE
                          3) Go back into GH and re-link, login etc

                          Low and behold, HS now links immediately with no errors ! (it's a timing issue right)

                          4) Now select in batches of 5 your items from 1) above
                          5) Say/type Resync Homeseer on GH
                          6) Goto 4 until done

                          7) Add devices to your rooms

                          #paininthearse

                          Comment


                            #58
                            ^^

                            Update on this. You may need to reduce the batch number, 5 worked for me, but when I tried it again, I had to use 3, then 2, then 1.

                            Finally things stalled again when a total of 10 devices have been synced. Even only adding 1 at a time the "Re-link your account" error comes back.

                            Comment


                              #59
                              Everyone interested in having Google Home integration working please ping support@homeseer.com in hopes of making/keeping this a top priority.
                              -Wade

                              Comment


                                #60
                                ........and another bit of analysis if it helps anyone in the future (I've also reported this to Google).

                                After around 10 devices are added things go wrong again. If I then remove Voice activation in HS from 1 or 2 then everything resyncs. ok. If I'm persistent and keep repeatedly trying to 'Resync Homeseer" then by adding one at a time and being very patient I can peak out at 11 devices added MAX. But these are the same 11 devices, most of the time I get the response "Re-link your account" - ignore this DO NOT DO IT.

                                I've also disabled EVERY plugin on my server to reduce load but this made no difference at all. Still time outs.

                                So it seems that it's definitely a timing issue dependent upon load probably at Google when re-syncing. I reckon that Google has a timeout on the ENTIRE process and if it doesn't complete within (around) 10 seconds then it barfs. Hopefully time will develop this process better but it would be much better if the timeout was relative to the number of devices. e.g. if you've got 70 devices to sync, then Google should have the timeout set to 5 minutes. Problem is Google won't know how many devices to sync to begin with (it's not synced ANY yet) so how long do you set the timeout for ? A 5 minute timeout is pants if you've got one device and something else has gone wrong.

                                It would be better if the sync process did some type of handshake - I've done that one, have you got any more ? Yes, okay then I'll reset the timeout whilst you send it to me.

                                I honestly do not think there is anything at the HS end that could be configured to make this better. Possibly those that are getting more devices configured are in fact a couple of hops nearer to the Google server and/or have a faster Internet connection and/or less latency.

                                Anyway.........more things to get on with.

                                Comment

                                Working...
                                X