Announcement

Collapse
No announcement yet.

Google Home fails to link to homeseer

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • #61
    yeah I relinked and like said.. I have all my devices in GH and I can manually click buttons in the GH app and they work... but voice wont work.. that is the weird part. GH manual trip works but voice no go. it says.. ok turning on 2 lights and thinks it did but nothing turns on..
    HW - i5 4570T @2.9ghz runs @11w | 8gb ram | 128gb ssd OS - Win10 x64

    HS - HS3 Pro Edition 3.0.0.435

    Plugins - BLRF 2.0.94.0 | Concord 4 3.1.13.10 | HSBuddy 3.9.605.5 | HSTouch Server 3.0.0.68 | RFXCOM 30.0.0.36 | X10 3.0.0.36 | Z-Wave 3.0.1.190

    Hardware - EdgePort/4 DB9 Serial | RFXCOM 433MHz USB Transceiver | Superbus 2000 for Concord 4 | TI103 X-10 Interface | WGL Designs W800 RF | Z-Net Z-Wave Interface

    Comment


    • #62
      Originally posted by Daveyboy View Post
      Yup - just read this AFTER unlinking HS from GH after receiving the "Please re-link your account" message and guess what ? Now everything is totally f&*d . It won't re-link at all.

      I've tried umpteen times and no joy. There does seem to be a consistent 10 second period between logging in and the error "Couldn't update the setting...."

      The Fix - more of a workaround.

      1) Go to your HS ipaddress/voice URL - make a note of all the devices that are currently listed
      2) Go to your main Home screen, select every device, choose DISABLE VOICE
      3) Go back into GH and re-link, login etc

      Low and behold, HS now links immediately with no errors ! (it's a timing issue right)

      4) Now select in batches of 5 your items from 1) above
      5) Say/type Resync Homeseer on GH
      6) Goto 4 until done

      7) Add devices to your rooms

      #paininthearse
      This is basically what I suggested many post back. I've been lucky to get 40 devices but I'm stick there.

      Comment


      • #63
        This makes me so sad. I’ve submitted my complaint. If this worked we could completely circumvent ifttt for 99% of my commands.

        Comment


        • #64
          Originally posted by CameronHilliard View Post
          This makes me so sad. I’ve submitted my complaint. If this worked we could completely circumvent ifttt for 99% of my commands.
          Also submitted a tech support ticket yesterday. Seem like this problem has been festering for a while.

          Comment


          • #65
            hmm............. I experienced it today. Unlinked account and am now screwed......

            Comment


            • #66
              Originally posted by darkjamzi View Post
              hmm............. I experienced it today. Unlinked account and am now screwed......
              elaborate more please??

              so last night I did some stupid testing - I'm good at that.

              so I said.. Ok Google (google home kicked in) and I said.. turn off the kitchen lights and it said.. Ok Turning off 2 lights and nothing...
              I went into the Home app and clicked my lights and they worked....
              while I was looking at that screen, there was the mic you can click... so I clicked it and it brought up the "ok google" screen (that's what I call it).. and I said.. Turn off the kitchen lights and it said.. Ok turning off 2 lights and boom they turn off....

              so...
              from in the home app, I can click buttons and control lights... I can click the mic and have that google control lights via voice....

              it is almost like when I say OK Google... that it is a different app that has nothing to do with or no tie ins on the home app....
              HW - i5 4570T @2.9ghz runs @11w | 8gb ram | 128gb ssd OS - Win10 x64

              HS - HS3 Pro Edition 3.0.0.435

              Plugins - BLRF 2.0.94.0 | Concord 4 3.1.13.10 | HSBuddy 3.9.605.5 | HSTouch Server 3.0.0.68 | RFXCOM 30.0.0.36 | X10 3.0.0.36 | Z-Wave 3.0.1.190

              Hardware - EdgePort/4 DB9 Serial | RFXCOM 433MHz USB Transceiver | Superbus 2000 for Concord 4 | TI103 X-10 Interface | WGL Designs W800 RF | Z-Net Z-Wave Interface

              Comment


              • #67
                Originally posted by zyrgh View Post

                The fact that the number of devices you can sync varies over time to me clearly states that this is a performance issue from the HomeSeer side. From the Google Documentation:

                As described under "Smart Home intents" at https://developers.google.com/action...e/rest/intents intent action.devices.SYNC requires fulfilment.

                And as described under "Response Format" at https://developers.google.com/action...sation-webhook it states:
                "When you receive a request, your fulfillment must return a response that's defined by the conversation webhook response." and "Note: Your response must occur within about 5 seconds or the Assistant assumes your fulfillment has timed out and ends your conversation."

                As we users can not see the communication between Google and HomeSeer, I can only guess, but to me it seems quite logical that this is exactly what is happening. If you have to many devices with voice control enabled the query from Google to HomeSeer times out. And since the number of devices vary depending on the hour of day it is very likely due to heavy load on the HomeSeer-servers.
                Same here. Large-ish HS system (~100 zwave devices). Trying to link google home using the phone app fails (I actually got the message saying "accounts linked", but nothing would show up in the application). Mass-disabling "voice control", enabling 10 devices and linking HS to GH works likae a charm. Adding more devices and trying to sync results in an error.

                So. It does look like a timeout that depends on the number of devices in your HS system that you have enabled for voice control and are trying to sync to GH. Between Google increasing this timeout and HS speeding up their backend by an order of magnitude we might be up a creek. Since HS is a way smaller company, we might have a bit more luck with getting them to do something about the problem. If the current implementation of this "sync" is naive and has MyHS service ask your local HS box for the device list every time (especially if it's a network call in a loop), before sending the data to Google, then there could be couple approaches to fixing this:

                - getting the entire list up-front and caching it inside MyHS
                - starting the HTTP connection to Google in parallel to asking the HS3 box for devices, and then shoveling the data from one connection to another (under the assumption that google is OK with long-running connections)

                In any case we need somebody from HS to seriously look into this. Would it help if I create another support ticket?

                Comment


                • #68
                  Today I unlinked and attempted to re-link after adding a new device, and I get an error saying "Cannot link. Check your connection." After reading this thread, I reduced my number of devices with voice enabled to 10. I tried again, got the same error. I then tried a few more times, and then it worked! I then enabled voice commands on a few devices at a time and then told Google Assistant to "Sync Homeseer" (had to type it out) on my phone each time. I only have 17 devices so got there fairly quick. Thanks for the advice from people above to do it this way. I wish HomeSeer would fix this integration soon!! I feel like I've been fighting it since I got my first Google Home last January.

                  Comment


                  • #69
                    A quick update -- it looks like the GH sync might actually succeed after you get an explicit error -- I tried three times today -- first with 5 devices (worked fine), then with 11 (worked fine), and then with 24 (got an error). I then went out for lunch, and when I came back there were 24 devices in the GH app. So I guess GH service issues the sync request, waits for callback for 5 seconds, and then reports an error. If the callback does come at some later point it might succeed and populate devices in GH.

                    Comment


                    • #70
                      Originally posted by twka90 View Post
                      A quick update -- it looks like the GH sync might actually succeed after you get an explicit error -- I tried three times today -- first with 5 devices (worked fine), then with 11 (worked fine), and then with 24 (got an error). I then went out for lunch, and when I came back there were 24 devices in the GH app. So I guess GH service issues the sync request, waits for callback for 5 seconds, and then reports an error. If the callback does come at some later point it might succeed and populate devices in GH.
                      I have yet had a problem getting all of my devices in to GH.. my problem is I lost the ability to use voice... albeit as I listed above... voice works if I hit the mic buttin IN GH on my cell .. but wont do it if I do ok google outside of GH app and my GH devices say turning lights on or off but don't do it...
                      HW - i5 4570T @2.9ghz runs @11w | 8gb ram | 128gb ssd OS - Win10 x64

                      HS - HS3 Pro Edition 3.0.0.435

                      Plugins - BLRF 2.0.94.0 | Concord 4 3.1.13.10 | HSBuddy 3.9.605.5 | HSTouch Server 3.0.0.68 | RFXCOM 30.0.0.36 | X10 3.0.0.36 | Z-Wave 3.0.1.190

                      Hardware - EdgePort/4 DB9 Serial | RFXCOM 433MHz USB Transceiver | Superbus 2000 for Concord 4 | TI103 X-10 Interface | WGL Designs W800 RF | Z-Net Z-Wave Interface

                      Comment


                      • #71
                        I joined the club tonight. I have been getting the error for a little while "there was an error synchronizing homeseer". I unlinked homeseer and now I cannot link it back up. This is going to suck, I use it constantly. I mean.... whats a light switch?

                        Comment


                        • #72


                          Wow, I finally got it to re-sync again! I followed your suggestion and went through my extensive list of devices, doing a bulk disable of the voice command setting.
                          Then I selectively enabled devices for Voice, re-synced and it worked.

                          I think the issue in my case (from reading the threads) is that the weather plugin I'm using, creates hundreds of devices and when I checked, they all have voice enabled, even though they're query-only devices (I.e. weather forecast values).
                          So disabling all of these likely hugely reduced the amount of devices needed to sync and hence it worked. (fingers crossed it keeps working)

                          Comment


                          • #73
                            Originally posted by Otto-mation View Post
                            doing a bulk disable of the voice command setting.
                            Is there some way to rapidly "bulk disable" - i.e., an automated way to disable voice command for all devices? Or was it actually an "individual" disable - i.e., did you select each device and turn off the "Voice Command" check box from the configuration page? I'm having this problem too and have about a hundred devices to disable.

                            Comment


                            • #74
                              Originally posted by jvm View Post

                              Is there some way to rapidly "bulk disable" - i.e., an automated way to disable voice command for all devices? Or was it actually an "individual" disable - i.e., did you select each device and turn off the "Voice Command" check box from the configuration page? I'm having this problem too and have about a hundred devices to disable.
                              Yes there is bulk disable. It's in the drop-down menu at top left of the device management page.
                              -Wade

                              Comment


                              • #75
                                Originally posted by cc4005 View Post

                                Yes there is bulk disable. It's in the drop-down menu at top left of the device management page.
                                Yep, that's what I did, on a room by room basis, rather than all at once as I wanted to keep certain ones enabled.
                                Once you select at least one device, the drop down in the upper left will show, near the bottom of the list - Enable Voice or Disable Voice as needed.

                                Comment

                                Working...
                                X