Announcement

Collapse
No announcement yet.

Seeing someone else's devices in IFTTT / IFTTT events failing or not received

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    #16
    I now see my own devices again, thank you.

    Comment


      #17
      I had the same issue. In fact a gentlemen from France emailed me with the issue that he could see my devices. I did receive some errant notifications over the past 24 hours. I logged out of homeseer and back in and also my IFTTT account. I changed associated passwords.

      I am most concerned about a security issue and someone else have access to my system. Is anyone else concerned about the security issue beyond the functionality issue. I think this is a BIG deal. I have lost some faith in IFTTT and HomeSeer. I hope we hear who is responsible for this issue and how they prevent it from happening again...…..

      Comments on security?

      Thanks

      Comment


        #18
        Welcome to the non-silver lining of the cloud services like IFTTT. Not only are you at their mercy for up-time and thru-put, you are one bit twiddle away from a big security issue like this.

        Comment


          #19
          Originally posted by rjh View Post
          Taffic has been moved back to the main server, if you are still seeing an issue please post.
          IFTTT-Homeseer working now for me. Thanks.

          Comment


            #20
            I too had/am having this issue. On Friday my IFTTT triggers stopped working and no matter how many times I tried to disconnect and re-connect it always signed me in as the wrong user. I sent screen captures of this to Homeseer support but at the time they said they did not see this issue before. I tried relinking on Saturday morning (before rjh said that traffic was moved back to the other server) and at that time it signed me in correctly and I was able to see my own devices. Even though it seemed to be working for me as of yesterday, I am still getting "random" trigger fires and failures. As in the first post, I am getting applet failed notices in the log with "The Homeseer service or it's API may temporarily be down". The thing is the applet failed notices are showing up at times that my vswitches would not have been turning off or on. So it seems that something else is causing these applets to fire. (Possibly another user?) I agree with Bernieo, I hope that Homeseer can provide an explanation and also what was done to fix and ensure this doesn't happen again. This seems like a huge security issue.

            Comment


              #21
              Oddly, this problem seemed solved for me yesterday - my IFTTT applets started working fine again, although in my IFTTT to Homeseer link it was still showing someone else’s email address (remember the guy with the fountain etc) and re-linking wouldn’t correct this. But, hey, it was working again.

              That was yesterday. This morning it’s all back to not working again, just as before. Well, almost as before. Now, I can’t see the other guy’s devices and events, I just get an empty list.

              In fact, although IFTTT to HS has sort of worked, I’ve been getting loads of strange errors for months. I often get an error that the HS API is down or missing. These errors often occur in the middle of the night (UK time) when the trigger could not have happened. Was someone else trying to trigger the event? Will IFTTT be the next big data breach - getting users’ login details for not one but many different services?

              Comment


                #22
                Is anyone still seeing this issue? I see posts that say its working ok now. From what we can see it looks like it was an IFTTT issue. I am in contact with IFTTT and I gave them details on the issue and am waiting to here back. I do think its a big deal, having access to someone else's home is a really bad thing. I want to see if IFTTT can explain what happened. Since the "connected as" setting for the service showed another user, that implies an IFTTT issue as we don't supply that info, it comes from their system. When I get more info I will post.
                website | buy now | support | youtube

                Comment


                  #23
                  Originally posted by rjh View Post
                  Is anyone still seeing this issue? I see posts that say its working ok now. From what we can see it looks like it was an IFTTT issue. I am in contact with IFTTT and I gave them details on the issue and am waiting to here back. I do think its a big deal, having access to someone else's home is a really bad thing. I want to see if IFTTT can explain what happened. Since the "connected as" setting for the service showed another user, that implies an IFTTT issue as we don't supply that info, it comes from their system. When I get more info I will post.
                  I have had my Homeseer account disconnected from IFTTT for the last couple of days and just tried it again, I still see the wrong user, wrong events and, wrong devices.

                  Comment


                    #24
                    Ok, still waiting on ifttt.

                    Originally posted by thomauto@aol.com View Post

                    I have had my Homeseer account disconnected from IFTTT for the last couple of days and just tried it again, I still see the wrong user, wrong events and, wrong devices.
                    website | buy now | support | youtube

                    Comment


                      #25
                      Like ThirdSectorMan, mine started working yesterday and is now again broken. I see the French user's devices and my triggers are not firing.

                      Are multiple users seeing these French devices I posted in the original screenshot? That would suggest that somehow one user's devices are being shared to many other users.

                      When I first saw it I assumed this must be a test account of some sort. Maybe the original Homeseer developer was French? But it sounds like this might be a real user's devices.

                      Comment


                        #26
                        You won't believe it, those devices in french are mine!! Working on figuring out how to connect my homeseer system to a new IFTTT account, (I discovered that I can only see someone else devices) and trying to get help from the forum, I see a screen shot of my own system! Pretty surprising I have to admit...

                        I deleted my account and recreated a new one, still connected as someone else!

                        So to answer the question, yes I still experience the issue.

                        Comment


                          #27
                          IFTTT got back to me and they are looking into it. They told me that they user should delete their connection to the HS service and connect again. But it sounds like you tried that and it did not help. Can you try to create a new IFTTT account and see if that works ok? I think that will force the OATH connection to generate a totally new token. It will be interesting if that fixes it.

                          Originally posted by yleveill View Post
                          You won't believe it, those devices in french are mine!! Working on figuring out how to connect my homeseer system to a new IFTTT account, (I discovered that I can only see someone else devices) and trying to get help from the forum, I see a screen shot of my own system! Pretty surprising I have to admit...

                          I deleted my account and recreated a new one, still connected as someone else!

                          So to answer the question, yes I still experience the issue.
                          website | buy now | support | youtube

                          Comment


                            #28
                            Like if something happened last few minutes, now logged as myself! Pretty strange.... Will let you all know if this is happening again.

                            Comment


                              #29
                              If you are still having an issue, please go into the HomeSeer service after logging into IFTTT, cick on the gear in the upper right corner, then delete the HS connection. Then re-connect and see if all is ok. We have made a change that forces a new token to be generated if you reconnect. We would like to know if that fixes the issue. It looks like IFTTT may have bad copies of tokens, maybe duplicating them. So creating a totally new token may fix it.

                              Thomauto, can you try and delete your HomeSeer connection then connect again and see if the "connected as" displays your HS login?
                              website | buy now | support | youtube

                              Comment


                                #30
                                Though my account is now linked correctly and showing my correct userID, I am still getting tons of event failures in the log. In fact I got 22 of these today and there should have only been one HS device change which would have caused an applet to fire.

                                Click image for larger version

Name:	Screen Shot 2018-12-31 at 4.28.16 PM.png
Views:	73
Size:	26.4 KB
ID:	1271021

                                Comment

                                Working...
                                X