Announcement

Collapse
No announcement yet.

Connected2.homeseer.com not working

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    #46
    So this surely explain what happened with alexa https://forums.homeseer.com/forum/ho...-does-not-work

    Comment


      #47
      reference closed thread https://forums.homeseer.com/forum/ho...y-home-network

      Several folks were reporting issues over past day. This wasn't universal. According to my monitoring script, running on two systems, I've been connected (thru connected33) since 3/30 @8:28 AM PDT. (I see that both did a quick reconnect this morning @ 8:04 AM PDT, but that was so quick that the 30 second event poll missed it). I used Alexa during that time as well.

      Not sure what the reasoning is to close that new thread so quickly ... maybe the forum moderators are trying to "flatten the curve?" ...

      Comment


        #48
        Originally posted by zwolfpack View Post
        ... maybe the forum moderators are trying to "flatten the curve?" ...
        ROFL ...

        Whatever the case, after being up for a grand total of 14 hours, MyHS is down for me again! Went down 2 hours ago.

        Click image for larger version  Name:	2020-04-05 16_55_35-Window.png Views:	0 Size:	11.7 KB ID:	1375192

        Comment


          #49
          MyHS (backend) back up 20 minutes ago.

          Click image for larger version

Name:	2020-04-05 19_50_53-Window.png
Views:	213
Size:	11.1 KB
ID:	1375220

          Comment


            #50
            What's up with the MyHS backend? Seems unstable to me. Been down and up 4 times in the last 3 hours. Playing havoc with my Google Home. One minute it works. The next there's no homeseer.

            Comment


              #51
              rjh Rich this problem is back.

              Comment


                #52
                Which problem, can you be more specific?

                Originally posted by integlikewhoa View Post
                rjh Rich this problem is back.
                website | buy now | support | youtube

                Comment


                  #53
                  rjh connected2 doesn't work for phlocation and imperihome apps on any of my devices for multiple HS3 installs. If I use connected22 it works.

                  Comment


                    #54
                    Originally posted by integlikewhoa View Post
                    rjh connected2 doesn't work for phlocation and imperihome apps on any of my devices for multiple HS3 installs. If I use connected22 it works.
                    Something odd with you DNS. connected2 is currently aliased to connected22 (meaning they both resolve to the same IP).
                    Code:
                    $ nslookup connected2.homeseer.com
                    Server:         192.168.1.1
                    Address:        192.168.1.1#53
                    
                    Non-authoritative answer:
                    connected2.homeseer.com canonical name = connected3.trafficmanager.net.
                    connected3.trafficmanager.net   canonical name = connected22.homeseer.com.
                    [COLOR=#FF0000]Name:   connected22.homeseer.com
                    Address: 45.76.21.192[/COLOR]
                    What result do you get for this command (works on Windows or Linux) ?

                    Comment


                      #55
                      So I have to houses in different states. One is currently using connected33 and one is using connected22.

                      If I use those two for each of the houses they work. But normally I use connected2 and it works. Right now neither house works with connected2.

                      Comment


                        #56
                        Originally posted by zwolfpack View Post
                        What result do you get for this command (works on Windows or Linux) ?
                        C:\Windows\system32>nslookup connected2.homeseer.com
                        Server: ubnt
                        Address: 192.168.1.1

                        Non-authoritative answer:
                        Name: connected33.homeseer.com
                        Address: 45.77.216.233
                        Aliases: connected2.homeseer.com
                        connected3.trafficmanager.net

                        and the other house I

                        get C:\WINDOWS\system32>nslookup connected2.homeseer.com
                        Server: Router
                        Address: 192.168.1.1

                        Non-authoritative answer:
                        Name: connected22.homeseer.com
                        Address: 45.76.21.192
                        Aliases: connected2.homeseer.com
                        connected3.trafficmanager.net

                        Comment


                          #57
                          do not enter $

                          Comment


                            #58
                            I run unifi controllers at both houses. I went and rebooted both HS3 servers without a fix.
                            I rebooted both routers and seems I have fixed the issue. Problem is I don't know why I have this problem.

                            Can someone explain in easy to understand lingo of my issue and how i prevent it from happening again.

                            Thanks,
                            Jim

                            Comment


                              #59
                              I monitor my MyHS connection with the script posted earlier in this thread and save the results with the Device History plugin. connected2 hasn't pointed to connected33 since 4/17 @12:11PM PST.

                              Your first house appears to have a weird DNS caching issue.
                              Attached Files

                              Comment


                                #60
                                Right now we have moved to load sharing for our servers. The load sharing is using the Azure traffic manager to direct traffic to the server that is the closest to your location. Your HS system will connect to one of our servers and stay connected unless the server goes down or it detects that there is a better server. When you try to connect to your home system using a JSON request you need to use the URL https://connected2.homeseer.com. Sounds like you are using that. If you happen to connect to a server that your HS system is NOT connected to, it detects this and issues a redirect to the correct server.

                                So a couple of things:

                                The system issuing the request needs to handle DNS OK in that the TTL (timeout) is very short, so the resolved IP address could change at any time. I do know that some of the connected systems are not honoring the DNS changes. I can tell this as some systems were not switching to the correct system when we changed the DNS.

                                Second, your system that is issuing the request needs to handle a redirect. I don't see why it wouldn't but it's something to check.

                                You can figure out which system your HS system is connected to by pinging connected2.homeseer.com, then one of the actual servers (connected22.homeseer.com and connected33.homeseer.com). See which IP matches one of the servers.

                                If you think your system is honoring the DNS and the redirect, let me know the URL you are using and I can check the logs and see if the request is getting dropped, and for what reason. (the parameters are important)
                                website | buy now | support | youtube

                                Comment

                                Working...
                                X