Announcement

Collapse
No announcement yet.

Energy History showing double kW hours reported by ZW905

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Energy History showing double kW hours reported by ZW905

    I installed an Aeotec ZW095 a week ago, and the kW hour totals seem to match the utility meter readings very well. I have noticed that the kW hour readings on the HS Energy History page are double what is shown in the device view.

    I have a script that triggers whenever there is a change in kW Hours 1 or kW Hours 2, then adds the 2 values together and sets the value and string for a virtual device called kW Hours This Month. I have further scripts which keep track of kW Hours Today, kW Hours Yesterday, kW, kW Hours Last Month and kW Hours at midnight. The kW Hours this month accurately reflects kW Hours 1 + kW Hours 2, but when I go to the Energy History view, it shows the kW usage for Today, This Month and Last Hour as double what is being reported by the ZW095 in the device view. However, the current Watts on the Energy History view accurately reflects the sum of Watts 1 and Watts 2 in the device view.

    For example, kW Hours Today shows 5.193, but Energy History shows 10.3. kW Hours This Month shows 253.675, but Energy History shows 505.1. However, adding Watts 1 + Watts 2 shows 151.707 Watts (.1517 kWh) currently being consumed, and Energy History correctly shows .1517 kWh being consumed.

    Click image for larger version

Name:	3.jpg
Views:	1
Size:	83.5 KB
ID:	1211983Click image for larger version

Name:	4.JPG
Views:	1
Size:	81.9 KB
ID:	1211984



    Any ideas why the HomeSeer Energy History view would be showing double the usage of what is being reported by the ZW095? Am i misunderstanding the way HomeSeer calculates the kW hours consumed?

    Thanks!

    #2
    Jerry,
    I can't help you with your question but am watching the thread. My problem with the Energy plugin is that my Aeotec energy monitor shows negative values. Also from some reason I haven't been able to get scripts working on my HomeSeer Pi system.
    I have had pretty good support from Aeotec but they don't know why it is showing negative. I haven't gotten any support from HomeSeer but have seen a few people with the same problem suggesting that the energy management part of HomeSeer is not working correctly. One guy uses a script to "fix" the negative values which I haven't been able to use. Needless to say I am not too impressed with the support. I will be watching to see if you get an answer, maybe it will help me as well.

    Comment


      #3
      sesykes71,
      You might want to make sure the clamps are installed in the right direction. On the clamp there is an arrow showing how to connect it. The arrow should be pointing towards your main breaker. Basically it should be pointing in the direction the energy is flowing. Don't know if that's it but doesn't hurt to double check.

      Comment


        #4
        Jerry,

        Not sure what is causing it, but I am seeing the same thing. On a side note are you willing to share the scripts you are using to keep track of daily and monthly consumption?

        Thanks

        Chris

        Comment


          #5
          Jerry, I was having the same problem. Talked to Aoetec support and got firmware 1.35 beta and installed but nothing changed. Even with beta 1.35 firmware, device was reporting 0.001 amps and watts. Then I reverted back to original firmware 1.31.

          Then I tried to figure out the issue myself.

          I opened the Energy DB with SQLite and figured it out that values are written double. Please see the screenshot. Clamp1 (ID:491) and Clamp2 (ID:487) values are recorded 2 times at the same reporting time 08:10:38. I believe that was the issue causing for us to see double on energy graph.

          Click image for larger version

Name:	energyDB.png
Views:	126
Size:	97.5 KB
ID:	1239240
          I was checking the ZWave commands for the device and found the below.

          Parameter 13 - Enable /disable reporting CRC16 Encapsulation Command. (0 == disable, 1 == enable)

          Once I enabled the parameter 13, values no longer recorded double on Energy DB. Now, Energy Graph is showing perfectly fine.

          Please check the attached pdf for ZWave command.

          I clicked on Aeon Labs Meter from my devices and opened up ZWave tab. Under the Settings -> Set Configuration Parameters, I've set Parameter 13, Value 1 and byte 1.

          I hope it helps.

          Comment


            #6
            Kaan, thanks so much for this. I have been dealing with this for over two years. I just changed Parameter 13 from 0 to 1. Let's see what happens.
            -Rick

            Update 02/17/2020
            Kaan, sorry for the long delay with the update. Changing Parameter 13 from 0 to 1 did indeed resolve the double reporting of the kWh readings. Thanks so much!
            -Rick

            Comment


              #7
              Hi Kann, Hi Archantor,

              I have the very old Aeon Labs HEM Gen1 and never had issues in HS3. Since I upgraded to HS4 everything related to that Energy meter wasn't working correct. I wrote a post and Archantor pointed me to this thread.
              Because I have that old generation of the HEM I do not have that parameter 13 and i cannot find anything related to it in the extended manual. So I started testing different thing and was always watching the energy database.
              So the result for me is that the default z-wave setting are not working with HS4. I had to change "Automatic report rate (seconds)" for both groups. Group 1 from 10 to 120 seconds and Group 2 from 120 to 10 seconds while Group 1 for me is "(kWh) Clamp 2" and "(kWh) Clamp1". Group 2 is "(W) Clamp 2" and "(W) Clamp1". On top of that i cannot setup a "Polling Interval" for that device.
              Since I run the above settings i do not have double entries anymore in the Energy database and it seems that it is counting correct.

              However, in the normal Energy history (Tools > Energy) I do not get a value for "Last Hour", "Today Projected" and "This month Projected"! If i go to the old HS3 legacy energy page (just delete the ".html" from the web address. Thanks again to Archantor) I do have values for everything. Any idea what that could be?

              -Patrick

              Comment


                #8
                Patrick339 I too have the older ZW028 without parameter control. I have a 7.6kW system that will affect the numbers and the first full day, yesterday saw nothing but clouds from Fay.

                I haven't had it long enough to wrap my head around the numbers but I have a feeling it's adding the solar totals to actual consumption totals. Time will tell. I wrote down my meter reading this morning and will have to do that for the next few days to confirm numbers.

                I'm curious as to your reporting choices for Groups and wonder why that would make a difference.

                Comment


                  #9
                  Well that didn't take long to figure out. The ZW028 Gen 1 records all electrical flow as consumption, regardless of direction. I shut off all the major energy users in the house, leaving only a couple of lights and a couple of PCs. At that point solar was producing about 3100w of electricity and that's almost exactly what the ZW028 showed being consumed.

                  So I will have to take the recorded consumption of the HEM1 and subtract the daily production of my solar panels to get net consumption. Not ideal, that's for sure. I may just have to spring for the ZW095 when it goes on sale.

                  Comment


                    #10
                    I kept on drilling into the ZW028 and found that if I change parameter 2 to value 1 watts drops to zero when I am making more than I consume. However it's getting the right number somewhere because the kWHours 1 and 2 actually start decreasing. So it appears I will get net consumption even though negative numbers are not displayed, they are taken into account.

                    Comment


                      #11
                      I re-enabled the Energy option in HS4 and got some interesting results. Considering that this is the original ZW028, by changing parameter #2 to value 1, I get accurate graphs of my daily consumption and solar production. Although watts shows zero when production exceeds consumption, all the correct math is being done.

                      Click image for larger version

Name:	Screen Shot 07-13-20 at 02.47 PM.PNG
Views:	26
Size:	282.1 KB
ID:	1402239

                      Comment


                        #12
                        This is interesting. Even more interesting for me is that in your screenshot it shows “0” for “last hour”, “today projected” and “this month projected”. I have the same problem and nobody knows how to fix that.

                        Comment


                          #13
                          It's only been up and running for a couple of days so I'll have to see what the display looks like a week/month from now and how it does projected, etc.

                          Comment

                          Working...
                          X