Announcement

Collapse
No announcement yet.

teslaSeer, plugin using tesla motors "API"

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Originally posted by salvesen View Post

    When I was doing the testing of the SW I think people tried using it on linux and said it worked fine. But I am not sure to be honest.
    I can confirm it works just fine on linux. Running this plugin now on a HomeTroller SEL, and may have been one of the people referred to :-)
    HomeSeer Version: HS3 Standard Edition 3.0.0.435
    Linux version: Linux hometrollerSEL 3.16.0-031600-generic #201408031935 SMP Sun Aug 3 23:56:17 UTC 2014 i686 i686 i686 GNU/Linux System

    Comment


    • Originally posted by Morten View Post

      I can confirm it works just fine on linux. Running this plugin now on a HomeTroller SEL, and may have been one of the people referred to :-)
      HomeSeer Version: HS3 Standard Edition 3.0.0.435
      Linux version: Linux hometrollerSEL 3.16.0-031600-generic #201408031935 SMP Sun Aug 3 23:56:17 UTC 2014 i686 i686 i686 GNU/Linux System
      Thanks, been on my list to check...

      Comment


      • Originally posted by NotYetRated View Post

        Thanks for the comment! However that doesn't seem to have fixed it for me. I tried removing plugin. Deleting devices/ Deleting tesla.ini files. Restarting Homeseer. Readding plugin files, starting plugin, adding my credentials. Still get no updates. It does however successfully see my car when i get a token, as it pulls my VIN into the log. I am seeing this error now on my plugins page

        "WARNING: Failed getting InterfaceStatus from teslaSeer - the interface was not found in the list of active interfaces, the list may need to be refreshed."

        And the following in my log when restarting the plugin:
        Nov-21 2:40:39 PM Error Initializing plug-in(2): teslaSeer Instance::Index was outside the bounds of the array.STACK: Server stack trace: Exception rethrown at [0]: at System.Runtime.Remoting.Proxies.RealProxy.HandleReturnMessag e(IMessage reqMsg, IMessage retMsg) at System.Runtime.Remoting.Proxies.RealProxy.PrivateInvoke(Mess ageData& msgData, Int32 type) at HomeSeerAPI.IPlugInAPI.InitIO(String port) at Scheduler.clsHSPI.CheckInterfaces()
        Nov-21 2:40:39 PM tesla debug Response from vehicleState: {"response":{"api_version":4,"autopark_state_v3":"ready","au topark_style":"dead_man","calendar_supported":true,"car_vers ion":"2018.42.3 eb373a0","center_display_state":0,"df":0,"dr":0,"ft":0,"home link_nearby":false,"is_user_present":false,"last_autopark_er ror":"no_error","locked":true,"media_state":{"remote_control _enabled":true},"notifications_supported":true,"odometer":10 47.667919,"parsed_calendar_supported":true,"pf":0,"pr":0,"re mote_start":false,"remote_start_supported":true,"rt":0,"soft ware_update":{"expected_duration_sec":2700,"status":""},"spe ed_limit_mode":{"active":false,"current_limit_mph":90.0,"max _limit_mph":90,"min_limit_mph":50,"pin_code_set":false},"sun _roof_percent_open":null,"sun_roof_state":"unknown","timesta mp":1542829237936,"valet_mode":false,"valet_pin_needed":true ,"vehicle_name":"Life, the Universe, and Everything"}}
        Nov-21 2:40:39 PM tesla debug Response from getVehicleList: {"response":[{"id":XX,"vehicle_id":XX,"vin":"XX","display_name":"Life, the Universe, and Everything","option_codes":"AD15,MDL3,PBSB,RENA,BT37,ID3W,RF 3G,S3PB,DRLH,DV2W,W39B,APF0,COUS,BC3B,CH07,PC30,FC3P,FG31,GL FR,HL31,HM31,IL31,LTPB,MR31,FM3B,RS3H,SA3P,STCP,SC04,SU3C,T3 CA,TW00,TM00,UT3P,WR00,AU3P,APH3,AF00,ZCST,MI00,CDM0","color ":null,"tokens":["faf978de3410d02b","fe21bad4c7303f8b"],"state":"online","in_service":false,"id_s":"431761609616405 79","calendar_enabled":true,"api_version":4,"backseat_token" :null,"backseat_token_updated_at":null}],"count":1}
        Nov-21 2:40:38 PM tesla debug Response from getAccessToken: {"access_token":"XX","token_type":"bearer","expires_in":3888 000,"refresh_token":"XX","created_at":1542829239}
        Nov-21 2:40:36 PM Warning Attempt by plugin to register a duplicate link of teslaSeerConfig. Plugin: teslaSeer Instance:


        Hello,

        Sorry for late response. As far as I gather teslaseer is putting the information down into ini file, but not over to the devices? As mentioned before, there is one report of GPS info not being sent to devices. I am not sure why though.

        Comment


        • Originally posted by Morten View Post

          I can confirm it works just fine on linux. Running this plugin now on a HomeTroller SEL, and may have been one of the people referred to :-)
          HomeSeer Version: HS3 Standard Edition 3.0.0.435
          Linux version: Linux hometrollerSEL 3.16.0-031600-generic #201408031935 SMP Sun Aug 3 23:56:17 UTC 2014 i686 i686 i686 GNU/Linux System
          Thanks for the info! Good to know that it works

          Comment


          • PS. If any of you that are facing issues with devices not being updated could send me the ini files for teslaseer and a screenshot of the devices that would help get me started on troubleshooting this issue. I have been trying to figure something out the last days but I am not sure where it is stopping really.

            Comment


            • Originally posted by salvesen View Post
              PS. If any of you that are facing issues with devices not being updated could send me the ini files for teslaseer and a screenshot of the devices that would help get me started on troubleshooting this issue. I have been trying to figure something out the last days but I am not sure where it is stopping really.
              Message with the requested files sent. Please let me know if there is anything I can do to help! Thanks so much.

              Comment


              • Just installed teslaseer went to plugin settings, entered login info and clicked "get token". No visual indicator that it took. Is there supposed to be a confirmation? When I go into the log I see:
                error Error: The remote server returned an error: (408) Request Timeout.
                once per minute

                HS3 Pro Edition 3.0.0.435 (Windows)

                Thanks!

                Comment


                • Originally posted by MarkSeer View Post
                  Just installed teslaseer went to plugin settings, entered login info and clicked "get token". No visual indicator that it took. Is there supposed to be a confirmation? When I go into the log I see:
                  error Error: The remote server returned an error: (408) Request Timeout.
                  once per minute

                  HS3 Pro Edition 3.0.0.435 (Windows)

                  Thanks!
                  Hello,

                  I did not implement any check really. Try turning on debug and see if you get any valid information. Request timeout usally only means that server is not available. Does your phone app work?

                  Comment


                  • For all facing issues, check the teslaSeer.ini file for TimerInterval setting. If it is missing, if it is. Try to adjust the interval time on the config page. Then it should show up in the ini file. I use 2 min.

                    Comment


                    • Is it a known fact that enabling polling in this plugin will not let your car sleep and cause excessive phantom drain? Is the only solution at this time to use an event to disable plugin polling until you want to get info from the vehicle or send it a task? Is there anything in the works that will auto adjust the polling to say if it's still asleep and nothing has changed to let it continue to sleep unless a request is sent to wake it up?

                      Thanks,

                      Comment


                      • I saw the phantom drain soon after I installed this plug-in. I ended up setting the PI timer to 5 hours as my car went to sleep the PI update would fail anyway. For a check up I execute an event every 30 mins to Wake Up and then a delay of 30 seconds and then an Update. Seems to work ok for me.

                        Comment


                        • Originally posted by integlikewhoa View Post
                          Is it a known fact that enabling polling in this plugin will not let your car sleep and cause excessive phantom drain? Is the only solution at this time to use an event to disable plugin polling until you want to get info from the vehicle or send it a task? Is there anything in the works that will auto adjust the polling to say if it's still asleep and nothing has changed to let it continue to sleep unless a request is sent to wake it up?

                          Thanks,
                          Not sure if there is any best practise to reduce phantom drain at this point. Not sure how the other 3-party apps does it. But, you can increase the polling time in config or use the poll device and leave it disabled.

                          For my case I always plug it in and dont have any issues regarding this.

                          Comment


                          • New version on first page, please read changelog as it comes with some requirements.

                            Merry Christmas!

                            Comment


                            • Hey Guys, how do I download this? I don't see it anywhere.

                              Comment


                              • Originally posted by jumper4000 View Post
                                Hey Guys, how do I download this? I don't see it anywhere.
                                First post first page, bottom of graphic is the zip file link...

                                Click image for larger version

Name:	Screen Shot 2019-01-03 at 5.15.58 PM.png
Views:	62
Size:	211.5 KB
ID:	1272140

                                Comment

                                Working...
                                X