Announcement

Collapse
No announcement yet.

Growing very tired of Z-Wave..

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Growing very tired of Z-Wave..

    I continue to have problems with my z-wave network/devices. One problem after another; one device(s) after another. Once things seem to be working, it turns out to be just an illusion because something else is getting ready to break. Most of these problems started when adding (2) 200 series switches to my network, but I know this has to be a coincidence.

    My latest problem, I just discovered. I have like 5 Aeon Labs Smart switches that only the binary switch works. No reporting and the z-wave settings tab looks like this (no setting can be changed).

    I'm getting ready to loose it, I need to be talked from the edge. Now it appears I'm going to have to perform the whole exclude/reset/include/fix a bunch events dance for each on these things..

    There MUST be a better way


    Click image for larger version  Name:	2018-09-13_19-22-31.png Views:	1 Size:	263.4 KB ID:	1247239



    Click image for larger version  Name:	2018-09-13_19-24-29.png Views:	1 Size:	307.6 KB ID:	1247240



    Current Date/Time: 9/13/2018 8:03:04 PM
    HomeSeer Version: HS3 Pro Edition 3.0.0.470
    Operating System: Microsoft Windows 10 Pro - Work Station
    System Uptime: 1 Day 0 Hours 48 Minutes 19 Seconds
    IP Address: 192.168.1.26
    Number of Devices: 714
    Number of Events: 184
    Available Threads: 1200
    HSTouch Enabled: True
    Event Threads: 3
    Event Trigger Eval Queue: 0
    Event Trigger Priority Eval Queue: 0
    Device Exec Queue: 0
    HSTouch Event Queue: 0
    Email Send Queue: 0
    Anti Virus Installed: Windows Defender

    Enabled Plug-Ins
    3.3.1.2: APCUPSD
    2.0.59.0: BLBackup
    3.0.19.0: BLLock
    2.0.36.0: BLSecurity
    3.1.3.33206: Blue-Iris
    3.0.0.21: Chromecast
    1.3.4.2: Device History
    3.0.0.50: EasyTrigger
    1.3.2.0: Honeywell WiFi Thermostat
    3.0.0.28: ImperiHome
    3.4.9.0: mcsMQTT
    3.1.0.1: MeiHarmonyHub
    1.0.5687.23871: MySensors
    3.0.1.109: PHLocation
    0.0.0.42: Pushover 3P
    1.0.0.7: Restart
    30.0.0.36: RFXCOM
    3.0.6.5: SDJ-Health
    3.0.6644.26753: UltraLog3
    3.0.6554.33094: UltraMon3
    3.0.0.88: weatherXML
    3.0.2.234: Z-Wave
    Last edited by ServiceXp; September 14th, 2018, 05:02 AM.
    RJ_Make On YouTube

  • #2
    what do you have a znet or a stick?

    Comment


    • #3
      Z-Net
      RJ_Make On YouTube

      Comment


      • #4
        welcome to my world. Just when I get most everything working correctly a new Zwave or HS update comes out and things go downhill...
        HS3 Prod - Win10 - DSC - HVAC-GC-TBZ48 x3 - CurrentCost - BLRadar - RFXCOM/FRXTRX433 -ADIO - HSTOUCH - BLUPS - AB8SS - SONOS - Alexa - 1 wire - BlueIris -MyQ

        Comment


        • #5
          If the switches are in range you should be able to simply rescan the switches causing issues. Which Z-Wave interface are you using?
          -Rupp
          sigpic

          Comment


          • #6
            Originally posted by Rupp View Post
            If the switches are in range you should be able to simply rescan the switches causing issues. Which Z-Wave interface are you using?
            I wish it was that simple, but sadly it is not. Here are the results. As you can see everything looks like fine on the rescan, but groups are not populated and you can't change any z-wave setting (Even though the log reports the change). Not to mention the only thing that works is the binary switch.

            If you know of a way to re-include (fix this problem) without having to reprogram all my events and such, I would be ecstatic. I'm so disgusted with it, I've not done anything with the 'failed' switches....

            I'm using the Z-NET

            Click image for larger version  Name:	2018-09-18_6-08-27.png Views:	1 Size:	347.4 KB ID:	1247958

            Click image for larger version  Name:	2018-09-18_6-08-54.png Views:	1 Size:	335.3 KB ID:	1247959
            RJ_Make On YouTube

            Comment


            • #7
              If your are having trouble with that many devices it might be worth trying a house reboot to see if that clears a possible device that is babbling sending out bad information. I also have seen a few issues with the non-production version of the zwave plugin when adding or rescanning devices. For normal use the current beta works great, but for some reason I ran into issues the last few times I had to add or rescan so you might try downgrading to 3.0.1.190 and see if that makes any difference. The last few things I tried to add were Aeon Labs 6-1 motion sensors and on the current version of the plugin at the time it would only add a few of the child devices and not all of them. I tried multiple times of removing and readding them and would never get a clean addition. So I tried rolling back to .190 and the devices all added without issue. I then upgraded again to the current beta and things were fine while running and with newer support for devices that were added since .190. That issue I had was a month or so ago and I don't recall which zwave plugin I was on, but probably close to the version you are currently on. I haven't had to add anything since then so I don't know about the current beta .237.

              Jeff

              Comment


              • #8
                Not related to zwave issues... I recently had some weird power related issues and powered down the entire house for a few minutes. Cleared everything up.

                More than likely will not address your issue, but it is worth a try.
                HomeSeer 2, HomeSeer 3, Allonis myServer, Amazon Alexa Dots, ELK M1G, ISY 994i, HomeKit, BlueIris, and 6 "4k" Cameras using NVR, and integration between all of these systems. Home Automation since 1980.

                Comment


                • #9
                  I've had to jump through hoops numerous times and many of my z-wave devices don't behave the way they should. Child devices are missing or do not function as they should. Other times there are child devices that I have no idea where they came from. Obviously, numerous devices do not report energy use properly.

                  To me it seems that HS3 needs the equivalent of Samsung SmartThings device handlers. The Homeseer Floodlight Sensor is a great example. HS released a device handler for Samsung but had to update the z-wave plugin. Why couldn't they just release that bit of code as an add-on? That way we don't have to wait for HS3 updates that might not focus on an individual's problem.

                  Then I have a Qubino FLush Shutter device. It will not behave as it should and it is listed as compliant. https://products.z-wavealliance.org/products/2505 This is frustrating because submitting a ticket will just create a ticket that doens't get acted on and creates more frustration.

                  I do love the JowiHue plugin because it makes the zigbee sensors mesh seamlessly. I wish there were more zigbee devices since their batteries last longer and they cost a lot less, but that's for another discussion.

                  Somehow I usually find workarounds and I have a love/hate relationship because of all these quirks. I love it because I came from X-10 and I'm not willing to try a new system and spends thousands of dollars. But I don't appreciate the fact that i devote enough hours to call this a part-time job.

                  Comment


                  • #10
                    This is discouraging to read. Like you, I came from X-10 and still use that technology along side about 17 or so Z-wave devices. In my case, my system has been so stable that I wonder if I'm beginning to forget stuff since I never (at least in the current context of time) seem to do anything to it. I worry about my Z-wave failing somewhere down the road, then I'd be scrambling trying to dig up ways to t/s and fix it.
                    One thing I wonder is - and it's just a question, do you shutdown your system or rather does it need to shutdown for some unknown reason and by doing so, does it shutdown cleanly? The fact that you're loosing/gaining child devices troubles me.

                    Robert
                    Last edited by langenet; September 19th, 2018, 09:19 AM.
                    HS3PRO 3.0.0.500 as a Fire Daemon service, Windows 2016 Server Std Intel Core i5 PC HTPC Slim SFF 4GB, 120GB SSD drive, WLG800, RFXCom, TI103,NetCam, UltraNetcam3, BLBackup, CurrentCost 3P Rain8Net, MCsSprinker, HSTouch, Ademco Security plugin/AD2USB, JowiHue, various Oregon Scientific temp/humidity sensors, Z-Net, Zsmoke, Aeron Labs micro switches, Amazon Echo Dots, WS+, WD+ ... on and on.

                    Comment


                    • #11
                      I've had reasonable success using the Z-wave "Replace Node" function to re-include a device while allowing existing events and HSTouch references to still work. I don't remember the exact sequence that makes it work, but if it the Replace Node function says it can't remove the existing device, you may have to reset the device first before trying it again.

                      Comment


                      • #12
                        If its a few devices, you might try excluding them and then replacing them.

                        But I've had problems where the Z-Wave database has become corrupted and removing/adding a few devices isn't sufficient. Here's how I fixed it the "widescale corruption" problem . . .

                        1. First do a backup from the Tools / Setup menu and shut down HomeSeer. Before doing the backup from the Tools/Setup menu, make sure you first also do a "Backup This Interface" from the Z-Wave plugin.
                        2. In the HomeSeer directory, delete the Z-Wave database. In Windows, its at: C:\Program Files (x86)\HomeSeer HS3\Data\Z-Wave
                        3. Reboot Homeseer. This will cause HomeSeer to re-create the Z-Wave database. Give it a few minutes - say 5-10
                        4. From the z-wave plugin, run "Optimize A Network, No Return Route Changes"
                        5. Ideally, do step #4 as many as 3 times
                        6. Followed by "Fully Optimize A Network"
                        7. Followed by "Test Node Connectivity On a Network" - if any of your nodes aren't connected, you may not have run step #4 enough times to compute a path to all your devices. Repeat #4, #6.
                        7. Followed by "Scan Existing Devices (Full Scan)"
                        8. Curse or rejoice. If Curse, restore your backup.

                        9. If you have security devices such as locks which don't support Network Wide Inclusion, you may have to remove them from the network and re-add, or else move them close to your Z-Wave interface and do a re-scan.

                        I'll also say that I share much of your frustration with HomeSeer. However, like the old joke, its only bad until you've tried the rest. I've tried out all of Smartthings, Vera, Wink, and Axial Control. Each of those was much worse. HomeSeer has far better device support. SmartThings relies too much on network control so its slow and it seems the user has to rewrite the device handlers if they want more than basic control (just try to set associations, parameters, or user Central Scene commands with Smartthings). Vera is a bit better than SmartThings, but again, no Central Scene commands which were important to me. Wink and Axial were similarly limited and had poor device support. HomeSeer is far from perfect, and the user interface isn't as polished or 'modern' as many of the competitors, but it at least gets the job done.
                        Last edited by jvm; September 20th, 2018, 11:12 AM.

                        Comment


                        • #13
                          langenet - This is what's weird. The system, hardware and software are pretty much bulletproof. If something works, it works. I've never had a device fail, I don't recall the system ever shutting down or me shutting it down. I do disable plugins before I update them (including z-wave) and then fire them up again.

                          My PC that runs HS3 has been restarted a few times because of Microsoft updates, but that's it.

                          My beef is with HS3 properly handling devices whether it's adding the proper child devices or sometimes losing some functionality after a z-wave or HS3 update. But for me, this is the most critical part. This is more important than mobile connectivity, HS Touch panels or newer devices, when so many devices that exist still don't work as they should. I should be able to buy any certified z-wave device and have it work as designed without issue.

                          Comment


                          • #14
                            jvm, Your procedure worked awesome for me! Went from most of my 71 devices not working to all working except for 3 unused devices. Many thanks for posting that!
                            Ted

                            Comment

                            Working...
                            X