Announcement

Collapse
No announcement yet.

Smart Cat Door - Cat Flap Connect

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    #31
    It could be that the plugin author ignored the command line and just connected unconditionally to 127.0.0.1

    Comment


      #32
      Originally posted by mrhappy View Post

      Well it's a head scratcher really as 404 errors, the error where it was closed by the server, timeouts, name resolution failures etc all say to me more of a network issue than a plugin issue, quite what that network issue im not sure what to suggest without knowing about how it is set up. Are you running any kind of smart firewall/anti virus program that could be periodically blocking it?

      Do you have any other computers you could try running it on, the plugin is able to remotely connect to HS if you run it with with the command line argument instance=192.168.1.4 where that is your HS server IP. That might eliminate whether or not it is specific to that computer running the plugin or it is a wider issue.
      Adam,

      I was unable to get the PI running remotely, but I did run it independently on at test HS3 system on the same LAN. Over an 18hr +/- period I received one "underlying connection was closed" log entry, but no 404s and the HS devices appeared to update correctly--at least during the times I was actively testing/watching. This seems to narrow the 404 issue to my production server.

      The 404 errors began at the same time the pet status in/out child device was last updated. The catflap lock/unlock device continued to update intermittently though unreliably. Clicking any of the controls on either child device will throw the 404 error every time.

      So far I've tried the following:

      1. Uninstalled/reinstalled the PI. Deleted (renamed) .ini files in config folder but did not delete HS devices.
      2. Disabled Windows firewall on server
      3. Disabled pi-hole

      Thoughts on what else to troubleshoot on my HS server? Should I try a more complete uninstall/reinstall of the plugin?

      Thanks.

      edit: I went ahead and did a more thorough uninstall/reinstall: 1. Disabled then deleted the plugin, shut down HS, deleted PI files in HS root, config, config\selectors and bin folders, copied PI files into root and bin folders, restarted HS and put credentials back in. No change in behavior so apparently not due to a bad install unless I overlooked a file that should have been deleted.
      Attached Files
      -Wade

      Comment


        #33
        Originally posted by cc4005 View Post
        I went ahead and did a more thorough uninstall/reinstall: 1. Disabled then deleted the plugin, shut down HS, deleted PI files in HS root, config, config\selectors and bin folders, copied PI files into root and bin folders, restarted HS and put credentials back in. No change in behavior so apparently not due to a bad install unless I overlooked a file that should have been deleted.

        I notice the status device address is different in that it has no suffix. First image is my production configuration. Second image is the test box. Maybe my reinstall wasn't complete afterall?

        Click image for larger version  Name:	Annotation 2019-12-08 172642.jpg Views:	0 Size:	48.7 KB ID:	1345360
        Click image for larger version  Name:	Annotation 2019-12-08 173825.jpg Views:	0 Size:	40.8 KB ID:	1345361
        -Wade

        Comment


          #34
          For your remote access try server=xxx.xxx.xxx.xxx rather than instance=xxxx

          Comment


            #35
            Originally posted by Michael McSharry View Post
            For your remote access try server=xxx.xxx.xxx.xxx rather than instance=xxxx
            Bingo! Thanks!

            mrhappy Adam, with the plugin running remotely, I observe the following:

            1. Using the pet status controls (in/out), the change isn't reflected in the app and the 404 error is thrown. The pet status HS device does not update when I manually change the status in the phone app.
            2. Using the lock controls (lock in, lock both ways, etc.), the command is successfully sent to the server and reflected in the app, but "underlying connection was closed" entry is logged.

            This seems to be the same behavior I'm seeing when the PI is running locally.

            To summarize my testing the past couple days:

            - The issues are the same whether the plugin is running locally or remotely.
            - I observed no 404 errors and only 1 "connection closed" error while running the PI on a test box with a separate HS3 instance running (same LAN / VLAN). The PI devices' status and controls appeared to work.
            - The pet status device address seems wonky on my production installation, leading me to think my uninstall/reinstall may have not been complete.

            I hope this helps narrow down the possible issues. Thanks.
            -Wade

            Comment


              #36
              Originally posted by cc4005 View Post

              - The pet status device address seems wonky on my production installation, leading me to think my uninstall/reinstall may have not been complete.
              After another uninstall / reinstall, being careful to find and delete every related file, all devices appear to be updating correctly. And the status device address is now of a normal-looking format. I'm also able to use the controls. The "connection closed" error still gets logged every time I control the lock/unlock device, but it doesn't seem to be affecting its function. I'll continue to watch it, but it appears the reinstall fixed the 404 issue. Something must've become corrupted along the way.
              -Wade

              Comment


                #37
                mrhappy Adam, it's somehow happened again, only this time the door lock device has seemingly become corrupted. I've never seen this sort of thing before. Any idea why it might be happening? Any reason the PI would try to recreate the device or change it's address?

                Here's the current device. Note there's no suffix on the Den CatFlap device address, and it's no longer updating. Same thing happened to the Angus Status device previously. See post #33 above.


                Here's what it looked like before.
                Click image for larger version  Name:	Annotation 2020-01-06 173055.jpg Views:	0 Size:	8.5 KB ID:	1352482
                ​​
                I suspect a complete uninstall / reinstall will fix it again. I'll give it a try when I have time to rebuild the associated events. Would be great if we can get to the bottom of why it's happening in the first place.

                Thank you for all the time you've put in on this great plugin. It's a great addition to my HA.


                edit: Should have mentioned that this is resulting in the 404 error again.
                -Wade

                Comment


                  #38
                  Hi mrhappy Adam,
                  I realise you are busy and probably have a few things you are working on.
                  I wonder if it would be possible to add a 'Battery Status' device to the plugin. I see the API supports a number of battery parameters including battery voltage, battery percent, and low battery status (https://github.com/renescherer/openh...ng.surepetcare).

                  Battery voltage and percent devices would be very useful for me. There are a few discussions about battery life on the offical SurePet forums. And in my case the door starts to fail reading our cats chip long before the low battery indicator comes on. This results in our cat being locked outside. So getting a warning of a low(ish) battery from HS would be a great feature.

                  I also see there are curfew time/status parameters.

                  I'm happy to beta test any updates.

                  Thanks, Marty.
                  iCore5 Win 10 Pro x64 SSD

                  HS3 Pro Edition 3.0.0.435 Windows

                  BLOccupied:,Device History:,Yamaha:,UltraMon3:,mcsXap:,Restart:,UltraNetatmo3:, UltraM1G3:,Ultra1Wire3:,BLBackup:,Harmony Hub:,DoorBird:,UltraECM3:,Nanoleaf 3P:,UltraRachio3:,Z-Wave:,SDJ-Health:,BLGarbage:,Blue-Iris:,Chromecast:,Pushover 3P:,EasyTrigger:

                  Comment


                    #39
                    Originally posted by mminehan View Post
                    Hi mrhappy Adam,
                    I realise you are busy and probably have a few things you are working on.
                    I wonder if it would be possible to add a 'Battery Status' device to the plugin. I see the API supports a number of battery parameters including battery voltage, battery percent, and low battery status (https://github.com/renescherer/openh...ng.surepetcare).

                    Battery voltage and percent devices would be very useful for me. There are a few discussions about battery life on the offical SurePet forums. And in my case the door starts to fail reading our cats chip long before the low battery indicator comes on. This results in our cat being locked outside. So getting a warning of a low(ish) battery from HS would be a great feature.

                    I also see there are curfew time/status parameters.

                    I'm happy to beta test any updates.

                    Thanks, Marty.
                    Apologies I missed this first time around - if you send me in a PM your login details I can take a look see what I can do.

                    Comment


                      #40
                      mrhappy Do you need the main account details? Or will an additional user account do?
                      iCore5 Win 10 Pro x64 SSD

                      HS3 Pro Edition 3.0.0.435 Windows

                      BLOccupied:,Device History:,Yamaha:,UltraMon3:,mcsXap:,Restart:,UltraNetatmo3:, UltraM1G3:,Ultra1Wire3:,BLBackup:,Harmony Hub:,DoorBird:,UltraECM3:,Nanoleaf 3P:,UltraRachio3:,Z-Wave:,SDJ-Health:,BLGarbage:,Blue-Iris:,Chromecast:,Pushover 3P:,EasyTrigger:

                      Comment


                        #41
                        I am considering upgrading my cat door and was considering getting the connected version of this one. I didn't see the plugin on the post referenced and I did not see it in the list of Plugins. Is it still available?

                        Comment


                          #42
                          Originally posted by Grundcm View Post
                          I am considering upgrading my cat door and was considering getting the connected version of this one. I didn't see the plugin on the post referenced and I did not see it in the list of Plugins. Is it still available?
                          It certainly was but it appears to have gone from the updater, I'm not sure why - I don't remember deleting it myself (I won't rule anything out though in case I was careless!) so HST may have removed it. I've checked the developer page and there is no way to get historic information.

                          I've not had any contact from HST however, the only concern in the back of my mind is that this uses an unofficial API and if Sure were/are aware of the integration they may have approached HST to express their wish that it not be advertised.

                          I can send you the plugin but please keep in mind that it uses an unofficial API (which could get broken at any time by Sure and there is nothing I can do about it) and also is HS3 only, it will not be updated for HS4. Whilst it probably will work it won't look as good as a native HS4 plugin. Send me a PM if you do decide you want it.

                          Comment


                            #43
                            I currently have the non-connected version of this door and it stopped working so I was thinking of upgrading. We have a pretty bad problem of raccoons coming in the house (which is how I was aware it was broken) without the lockable door. I was able to fix it so the rush is not there anymore, but did put the bug in the wife's ear that they make one you can control remotely. I may take you up on in in the future, but will hold off for now. Thank you for the offer!

                            Comment


                              #44
                              Hi, Is this plugin still active? I can't see a download link anywhere?
                              edit: just seen last post from mrhappy if you don't mind sending me a link - would really appreciate it!

                              Would also be great to see a HS4 version

                              Comment


                                #45
                                Originally posted by OliP View Post
                                Hi, Is this plugin still active? I can't see a download link anywhere?
                                edit: just seen last post from mrhappy if you don't mind sending me a link - would really appreciate it!

                                Would also be great to see a HS4 version
                                This is the latest copy attached here, I honestly have no idea if it works or not. You will need to extract this into your HomeSeer directory.

                                I'm afraid you will not see a HS4 version and if it does not work then support is on a sort of best effort basis because I don't own this hardware myself and any integration has been done on the back of me reversing their API...it is not official.

                                Attached Files

                                Comment

                                Working...
                                X