Announcement

Collapse
No announcement yet.

LiftMaster MyQ - Free, open source plugin

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • sbessel
    replied
    Appreciate the update - sorry I missed that it was HS4.

    Gonna have to go a completely different route.

    Leave a comment:


  • Dr. McKay
    replied
    I'm not supporting this anymore since MyQ is built into HS4 and HS4 has been out for over a year at this point. Plus I don't personally use MyQ anymore.

    I don't know if it still works or not.

    Leave a comment:


  • Wade
    replied
    Originally posted by sbessel View Post
    Is this still working and supported?

    With the MyQ (kingfetty) officially dead this may be a great replacement.

    Hoping to find out before I send time trying to get it working.

    thanks,

    Scott
    It's likely you're using HS3 and therefore the "free" HomeSeer MyQ HS4 plugin is of no help. If by chance you are on HS4 then that's the PI to go with.

    Leave a comment:


  • sbessel
    replied
    Is this still working and supported?

    With the MyQ (kingfetty) officially dead this may be a great replacement.

    Hoping to find out before I send time trying to get it working.

    thanks,

    Scott

    Leave a comment:


  • tdosten
    replied
    Awesome plugin Dr. Mackay! Synced immediately to my two Liftmaster and one Craftsman openers. Works well with voice commands via Alexa and MyQ with Amazon Key. Not sure who gets all the credit there, but nice integration regardless. Glad to hear it’s being included in HS4.

    Leave a comment:


  • Dr. McKay
    replied
    When I get a chance, I'll take a look and see if I can figure out why it's not recovering properly. Until then, you should probably figure out some way to automatically restart the plugin. I won't be home for at least another week and a half or so.

    I have no idea how HS4 is going to go about adding first-party MyQ support. All I've seen is that MyQ is listed in the marketing material.

    Leave a comment:


  • feman
    replied
    I don't think it is recovering. After 4am when my internet connection is unstable for a few minutes, I get this message in my log every 7 minutes, exactly, until I shut the plugin down. I then start it up and and everything is great.

    Is HS4 going to work specifically with the MyQ line? Is HS4 going to suck up all of the 3rd party developer's work? Are they paying?

    Leave a comment:


  • Dr. McKay
    replied
    The plugin should be able to recover if it loses internet connectivity for a period of time. Are you saying that's not the case?

    Also, I'm not sure how much longer I'm going to support this since it's going to be included in HS4.

    Leave a comment:


  • feman
    replied
    What happens to your plugin if it cannot connect to MyQ online?

    I have just installed your plugin on a test HS3 platform and it seems to be working pretty well. However, I have a situation with my internet access that may be causing your plugin to issue this warning: Plugin LiftMaster MyQ is not responding but it is still running, not restarting yet.

    I live in a very rural area of Tennessee and my internet access is via 4G modem with a reseller of AT&T services. The system is very reliable, fast and no data limits (sort of). The one thing that causes several problems with this system is that every morning at around 4AM, the 4G modem has to re-negotiate for an IP address. The resell does not have fixed IP services.

    Every morning at 4AM I get a message in my HS3 log that says: Have not heard from MyHS in over 3 minutes, disconnecting for re-connection. which corresponds to the DHCP negotiation.

    Since I installed your plugin a couple of days ago, I see the lift master MyQ warning message right at 4am.

    As a workaround I could use Jon00's plugin enable/disable utility to disable your plugin just before 4am and then enable it sometime after 4am. I haven't tried the yet but was going to set that up later today.

    So far your plugin has worked very well for me and I plan on installing it on my production HS3 server soon.

    Leave a comment:


  • Dr. McKay
    replied
    Originally posted by spknapp View Post

    I downloaded and tried the new version but I keep getting an Unauthorized (216) error. I went to chamberlain.com and changed my password in case I had it wrong, but still get the error.

    What am I doing wrong?
    Maybe you need to switch your make in the plugin settings?

    Leave a comment:


  • jvm
    replied
    New version released this morning (1.3.7144.7171) fixed the errors I was having. Thanks.

    Leave a comment:


  • spknapp
    replied
    Originally posted by Dr. McKay View Post
    I think the previous build might have been corrupted. Please try the latest.
    I downloaded and tried the new version but I keep getting an Unauthorized (216) error. I went to chamberlain.com and changed my password in case I had it wrong, but still get the error.

    What am I doing wrong?

    Leave a comment:


  • Dr. McKay
    replied
    I think the previous build might have been corrupted. Please try the latest.

    Leave a comment:


  • usLEDsupply
    replied
    Mine hasn't worked for a few weeks either Win 7 Pro
    Jul-24 12:21:41 AM Starting Plug-In Plugin LiftMaster MyQ started successfully in 51 milliseconds
    Jul-24 12:21:41 AM Starting Plug-In Initializing plugin LiftMaster MyQ ...
    Jul-24 12:21:41 AM Starting Plug-In LiftMaster MyQ loaded in 15065 milliseconds
    Jul-24 12:21:26 AM Info Plugin LiftMaster MyQ has connected. IP:127.0.0.1:56541
    Jul-24 12:21:26 AM Warning I/O interface LiftMaster MyQ is down, executable is not running, restarting ...
    Jul-24 12:21:02 AM Info Plugin LiftMaster MyQ with instance: has disconnected
    Jul-24 12:19:56 AM Starting Plug-In Plugin LiftMaster MyQ started successfully in 59 milliseconds
    Jul-24 12:19:55 AM Starting Plug-In Initializing plugin LiftMaster MyQ ...
    Jul-24 12:19:55 AM Starting Plug-In LiftMaster MyQ loaded in 15087 milliseconds
    Jul-24 12:19:40 AM Info Plugin LiftMaster MyQ has connected. IP:127.0.0.1:56520
    Jul-24 12:19:40 AM Warning I/O interface LiftMaster MyQ is down, executable is not running, restarting ...
    Jul-24 12:19:14 AM Info Plugin LiftMaster MyQ with instance: has disconnected
    Jul-24 12:18:11 AM Starting Plug-In Plugin LiftMaster MyQ started successfully in 3093 milliseconds
    Jul-24 12:18:08 AM Starting Plug-In Initializing plugin LiftMaster MyQ ...
    Jul-24 12:18:08 AM Starting Plug-In LiftMaster MyQ loaded in 15070 milliseconds

    Leave a comment:


  • jvm
    replied
    Originally posted by Dr. McKay View Post
    I've just released v1.3.7133.39646 on GitHub, which should fix the plugin for anyone who's having issues with it not connecting to myQ properly. I tested this both on my Windows 10 box and on Linux under mono, and it worked under both environments. If it doesn't work for you on Linux, I would suggest trying to update mono.
    I had posted the issue on Github. However, even the "new" plugin version didn't fix my problem. I'm on Windows 10.
    Do you know - are other still having a problem?

    Leave a comment:

Working...
X