Announcement

Collapse
No announcement yet.

Alexa is saying the wrong temp setting on stat?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • gwingharry
    replied
    I am seeing this same problem.

    I am using ZEE S2 controller with Trane XR524 thermostat and recently activated Alexa and an Echo Dot (3rd Gen.) and noticed as soon as I added tstat to Alexa that headings were reversed for Heat & Cool and that Current Temp shows in Celsius in Alexa thermostat display and voice response from Echo.

    I also have HS2TOUCH APP on my iPhone and titles and current temperature all display correctly.

    Leave a comment:


  • Rotech
    replied
    Same issue here ,just checked the app, and it report Celsius readings..

    Leave a comment:


  • srodgers
    replied
    Forgot actual temp here in Panama City Beach is a nice 65deg. This worked great a few day ago. I have a thermostat RCS TR-16 connected to the Elk M1G with UltraM1g3 plugin. Worked great before with Alexa.


    Sent from my iPad using Tapatalk

    Leave a comment:


  • srodgers
    replied
    Just tried mine and it reported -17.8 degree.


    Sent from my iPad using Tapatalk
    Attached Files

    Leave a comment:


  • charlesmbell
    replied
    I think AWS changed an API and HS needs to update their v3 connector to accommodate the change. Please take this with a grain of salt I could be completely off base, but that is my professional opinion.

    Leave a comment:


  • Rotech
    replied
    You think it's a HS issue?

    Leave a comment:


  • charlesmbell
    replied
    Originally posted by charlesmbell View Post

    I just noticed the same thing. Looks like an aws update 2 days ago. Not recognizng my tstat via homeseer. If you look at devices on alexa.amazon.com, does your tstat show offline? Mine did. So I forgot it and cannot reccan and add it back. I think its an api issue. anyone else?
    So I was able to add the tstat back. it is a zwave, needed to click the "is light" under the root device in HS. But the temp in the root device is still showing celsius. It is not the alexa device setting they are all F.

    The tstat is zwave in HS, alexa uses the HS skill and reads my.hs, the tstat is added. But recently the temp reads back C not F and there is no way to change it. It was working for a long time.

    also if I try to change the temp via voice it works. if you try to change temp via alexa app it fails with this log entry "JSON controldevicebyvalue caused an error: Input string was not in a correct format."

    The cool and heat temps are backwards, but that has always been like that.

    I am pretty sure something changed. Last time something like this happened it took over a month before it got fixed. AWS changed an api last time.

    not sure where to begin.
    Attached Files

    Leave a comment:


  • Rotech
    replied
    When I try to log on the Amozon site it directs me to downloaded the app which I already have.

    Leave a comment:


  • charlesmbell
    replied
    Originally posted by Rotech View Post
    Anyone is having this issue? When I ask Alexa what's the the thermolstat temp, she responses back 22 degree when it's actually 72 degrees Fahrenheit... Anybody seen this with your Alexa?
    I just noticed the same thing. Looks like an aws update 2 days ago. Not recognizng my tstat via homeseer. If you look at devices on alexa.amazon.com, does your tstat show offline? Mine did. So I forgot it and cannot reccan and add it back. I think its an api issue. anyone else?

    Leave a comment:


  • Rotech
    replied
    I may have to check directly on amazon site,sinceI checked the setting on my iPad...

    Leave a comment:


  • joZ666
    replied
    I'm sorry for repeating what everyone already had said. I hadn't updated the browser since the night before when I started to read the thread.
    I hope you find the cause.

    Good luck.

    /joz

    Leave a comment:


  • langenet
    replied
    I've flip flopped between the two without any problem. Being in Canada we're metric but my wife being from the U.K. likes imperial which is fine with me for internal temps. But I configure alexa metric so I can get outdoor temps in metric since all weather reporting is metric. Saying that if I want alexa to change the thermostat, I either tell her directly to set the stat to 22 or I use John's helper and tell homeseet to set it to 71 or 72. ☺

    Leave a comment:


  • joZ666
    replied
    22 degrees celcius is aprox. 72 dedees fahrenheit. Could that be the problem?

    /joZ

    Leave a comment:


  • Rotech
    replied
    Originally posted by loliver View Post
    Sounds like you Alexa is set to Celsius units rather than Fahrenheit, but temperature is correct, just units are wrong. Change your units to Fahrenheit and you'll be happy.
    I checked that before posting this issue. The setting are set to Fahrenheit .

    Leave a comment:


  • randy
    replied
    Just to clarify, the settings are in your Echo account. Use the app or alexa.amazon.com and go to settings, then device settings. Pick your Echo device and change the units of measure.

    https://alexafaq.com/guide-how-to-ch...it-or-celsius/

    Leave a comment:

Working...
X