No announcement yet.

Migrating from Windows 10 to Linux

  • Filter
  • Time
  • Show
Clear All
new posts

    Migrating from Windows 10 to Linux

    I have to data read about any success stories for people migrating from Windows to Linux but nevertheless I will still try.

    I have made a few tries now doing manual copying and overwriting a stock linux installation but not there yet.​​​​​​ I have discovered some inconsistencies in Homeseer backup and restore. So I want to document this.

    What I have tried so far
    • Install Linux and copy whole Homeseer folder overwriting everything. This messes something up and will not start.
    • Install Linux and copy only certain folders like Data and Config, still not worked properly. Issues with config
    • Install Linux and doing a Homeseer restore (System - Backup/restore), issues with config
    Both the two last tries gave me a working Homeseer but no working Z-Wave yet.

    What I have discovered is that Config/Z-Wave.ini has an absolute path to the z-wave database:
    But in the backup ZIP-file there is a file with relative path.

    Starting Homeseer gives me this. Since it can not find the database a new one is created.
    11:52:02:6581:[Z-Wave Warning]->Z-Wave database file does not exist, so a new database is being created in /HomeSeer/Data/Z-Wave/C:/HS3/Data/Z-Wave/Z-Wave2.db
    11:52:03:3625:[Z-Wave]->Created new database /HomeSeer/Data/Z-Wave/C:/HS3/Data/Z-Wave/Z-Wave2.db
    Trying again:
    1. Delete Data and Config folder
    2. Copy fresh copies from my own windows backup of Data and Config
    3. Verify the Z-wave device (UZB1 in my case): /dev/ttyACM0
    4. Verify the location of Z-wave database: Data/Z-Wave/Z-Wave2.db
    5. Edit Config/Z-Wave.ini
      1. Change to gConfigFilename2=Z-Wave2.db as it seems to append the whole path relatively.
      2. Change all references to COM3 to /dev/ttyACM0
    Holy c.... I get Z-Wave traffic in my log


    Had to remove gServerAddressBind= from Config/settings.ini as I'm not on the same address anymore.

    • Z-Wave seems to work properly
    • Events seem to be working as well
    • Installing JowiHue plugin my deconz devices works as well