Announcement

Collapse
No announcement yet.

Alexa & Turn On Light to Last Dimming Level

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Alexa & Turn On Light to Last Dimming Level

    I have cooper wiring dimmers. Let's assume I have a living room light that is currently off and the dimming level is set to 30%. When I physically turn on the switch the light turns on and goes to the current dimming level, i.e. 30%.
    However, when I tell Alexa to turn on that light switch it goes to 100% even if the current status is set to 30%. How can I make it go to 30% when I say "Alexa, turn on living room light"?

  • #2
    I have WD100's which if I want on at a certain level, I would tell Alexa to turn on device at 30%. On the other hand, I have an X-10 dimmer (can't remember the model) which if it was turned off while at 30%, when I turn it on with Alexa, it turns on at 30%. I find this a pain because I then need to tell Alexa to turn it on at 100% if I want it fully on.

    Robert
    HS3PRO 3.0.0.500 as a Fire Daemon service, Windows 2016 Server Std Intel Core i5 PC HTPC Slim SFF 4GB, 120GB SSD drive, WLG800, RFXCom, TI103,NetCam, UltraNetcam3, BLBackup, CurrentCost 3P Rain8Net, MCsSprinker, HSTouch, Ademco Security plugin/AD2USB, JowiHue, various Oregon Scientific temp/humidity sensors, Z-Net, Zsmoke, Aeron Labs micro switches, Amazon Echo Dots, WS+, WD+ ... on and on.

    Comment


    • #3
      Well, if I manually toggle a light switch from off to on I expect it to go to the preset dimming level. Consider the case where you set your light switch to 30% because that is what you prefer. Then each time you hit the light switch it goes to 100% and you have to dim it down to 30%. That's pretty annoying. You expect the light switch to go to the 30% you set before and not reset it to 100%.

      Controlling a light switch with Alexa should be exactly the same as manually operating the light switch. If it was set to 30% and you flip the switch to on you expect it to go to 30%. So when I tell Alexa to turn on a light I want it to go to that last dimming level. If you want to adjust the dimming level on the light switch you hit the appropriate buttons on the light switch. Same thing with Alexa. If I want to adjust the dimming level I will tell Alexa and that includes setting it to 100%.

      So my question remains. How can I achieve to set a light switch to "last setting" when I tell Alexa to turn a light on?




      Comment


      • #4
        Check out my post here - https://forums.homeseer.com/forum/ho...-to-last-level

        Comment


        • #5
          will.i.am, thanks a lot for your post. I didn't do the same you did but it gave me another idea. I prefer to leave things as close to the original setting as possible. In the original setting value 99 had control use "On" and 255 had control use "On Alternate". When I tell Alexa it actually doesn't set the light to 100% but to the 99% which I verified. So then I simply switched the control use. The status 255 seems to be interpreted as "Last". But by now setting the control use to "On" it actually sets the switch to last. I could have deleted status 99 but because I prefer to leave things as untouched as possible I simply set it's control use to "On Alternate". It all works now as I expect it to work.


          Click image for larger version

Name:	OriginalControlUse.png
Views:	59
Size:	19.6 KB
ID:	1305121
          Click image for larger version

Name:	ControlUseSwitched.png
Views:	54
Size:	19.8 KB
ID:	1305122

          Comment


          • #6
            I tried set up the same as you suggest but every time I ask Alexa to turn the lights on they go on 100% not as you described to the last setting. I don’t understand why the 255 works for you and not for me.?

            Comment


            • #7
              Do you have a light switch that you didn't try to modify yet? If so can you provide a screenshot. Also what brand is it? Maybe somebody who uses the same as you can help.

              Comment


              • #8
                Yes I have many HLC dimmers and their set up in the Graphics tab are all like this.. Click image for larger version

Name:	Screen Shot 2019-05-17 at 11.43.07 PM.jpg
Views:	39
Size:	82.7 KB
ID:	1305630
                And in Alexa they look like this.... Click image for larger version

Name:	Screen Shot 2019-05-17 at 11.47.12 PM.jpg
Views:	37
Size:	19.4 KB
ID:	1305631

                Comment


                • #9
                  Your states don't show a "Last" and that is probably where the problem is. In the case of Cooper Wiring switches (the ones I have) there seems to be a z-wave state 255 which turns on the switch to the last dimming level. Maybe your switch (a Leviton?) doesn't have that state 255 or maybe it has no z-wave state at all that sets it to "Last". So the first thing to figure out is if your switch has a z-wave state "Last" and if so what that value is (has to be something between 101 and 255 because 0-100 are already taken). I did a quick google search but couldn't find anything. Did you try to create a state 255 and set the control use to on and for state 100 change the control use to alternate on? Based on your comments you did but I just wanted to double check.

                  Comment


                  • #10
                    The Leviton Z-Wave dimmers I have show a state of 255 as well for On Last Level.
                    HS 3.0.0.532: 1963 Devices 1141 Events
                    Z-Wave 3.0.1.261: 122 Nodes on one Z-Net

                    Comment


                    • #11
                      Thank you gentlemen for trying to help me. My dimmers are HAI/HCL, non-Z wave.
                      Mulu I set up one of my switches identical to your graphic page and still the dimmer would go to 100% when requesting “turn on“.
                      With the set up I show I can request the lights go to X percent and they do. However going to the last set level is not an option. Because my house is programmed and the motion detectors do all of the Dimmer requests I seldom ask a light to turn on but when I do going to the last setting would be ideal.

                      I noticed that most of my switches/Dimmers manually remember the last setting when quick tapping on. However a couple went to a specific percentage of dimming instead of the last setting. I guess I need to go into the UPB program to figure that one out.

                      Comment


                      • #12
                        My only wireless devices are z-wave devices so I am not going to be much help with your switches. My guess is that they don't have a "last" setting for whatever protocol (a non z-wave protocol) they are using. I did some more googling and it seems z-wave might use 255 as "last". See this quote from the link listed: "Oddly enough, the DIM levels for Z-Wave are 1-99 where 99 is "full on". There is no 100 - sending 100 is an error. You can also send a "255" which means "last Value""

                        https://forums.homeseer.com/forum/li...-or-100-for-on

                        That is exactly how my switch is set up. I find it strange that dimming only goes to 98 and 99 is on (there is no 100) but that is exactly how my switch is set up by default. Of course it could be that he has the same switch and this has nothing to do with the standard z-wave protocol for switches but only how Cooper Wiring did implement it (they probably just integrated a z-wave IC from another vendor).

                        Comment

                        Working...
                        X