Announcement

Collapse
No announcement yet.

Port issues

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Port issues

    When I open HS3 on my late father's desktop, I get the message that "~!~Warning~!~Error starting web server, port in use? Are you running a web server on the designated port? Edit settings.ini in the Config folder and change gWebSvrPort=## to a different port #. The requested address is not valid in its context" message. Now, before you tell me to change the port in the settings file, I've tried. I've changed it to all kinds of different numbers. HS3 has been slowly forgetting to turn things on and off for my mother and its to the point I came over the other night and she had one light on in the whole house. My father had all kinds of events and things that are totally over my head on his system. I have a super basic knowledge of how this all works (I have a HomeSeer system at home with basic turn the lights on and off with the sunset/sunrise). I would appreciate any help in figuring out how to get into the web interface so I can get things working again for her.

    HS3 Professional Version 3.0.0.548

  • #2
    So, you go to the HS3 config directory and change the line in settings.ini to gWebSvrPort=81 (while HS3 is not running) and it still doesn't work?
    Windows 10 likes to run some sort of web server on port 80. A windows update may have turned that back on.

    Comment


    • #3
      That is correct. I found another thread in here and was able to change the port to multiple other numbers, still nothing.

      Comment


      • #4
        That's odd. Did you check to make sure there was only one gWebSvrPort entry in the ini file. Are there more than one HS3 installs/directories on the PC? Maybe look up how to disable the built-in Windows 10 server...

        Comment


        • #5
          It looks like in the program files (x86) folder there are multiples. A HomeSeer HS3, a HomeSeer HS3 - 449, a HomeSeer HS3 - 454, and a HomeSeer HS3 - 460, I have no idea what those other ones are. I have been using a shortcut link and changing the HomeSeer file without a number behind it.

          Comment


          • #6
            This was set to----gServerAddressBind=192.168.1.106, I made it gServerAddressBind=192.168.1.101 and I'm in!!!! Thanks for your help!

            Comment

            Working...
            X