Announcement

Collapse
No announcement yet.

BMW Connected integration

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    #31
    Ha, I did the same thing!!

    Comment


      #32
      Originally posted by jlikonen View Post
      OK, now I know what was the problem, I had wrong field names like Range Number. It should be just Range. I removed "number" in all the field names which had this word. The access database is now populated. Now I need to add new BMW devices on HS3. Many thanks.
      I guess that the api returns different data for each model - I thought that would be the case.
      I’m glad you're both making progress.

      Comment


        #33
        I'm wondering one thing. I am right now charging up my car and My BMW app shows that the battery is being charged up. When I run the BMW Python script the Access database doesn't seem to be updated and last token is from yesterday evening. The token seems to be valid for 2hours and the old token has already expired. My BMW app does get the status from my car but the Python script doesn't. Any ideas?

        Comment


          #34
          Originally posted by jlikonen View Post
          I'm wondering one thing. I am right now charging up my car and My BMW app shows that the battery is being charged up. When I run the BMW Python script the Access database doesn't seem to be updated and last token is from yesterday evening. The token seems to be valid for 2hours and the old token has already expired. My BMW app does get the status from my car but the Python script doesn't. Any ideas?
          In my experience the token is only valid for 2 hours. The python script should request a new token if it has expired but I guess thats not happened for you. I've not experienced this before.
          Are you able to capture what it says when you run the script?

          Comment


            #35
            For some reason I get now some errors which I didn't see few days ago. Token is renewed but database not updated because of the errors.
            Attached Files

            Comment


              #36
              Run it again - it works the second time

              Comment


                #37
                Originally posted by ScottRennie View Post
                Run it again - it works the second time
                OK, thanks. Yes, that seemed to work. I'll have to look at the Python code and try to understand what those error messages above mean.

                Comment

                Working...
                X