Announcement

Collapse
No announcement yet.

trying to get setup on ubuntu. Unable to connect - Solved!

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    trying to get setup on ubuntu. Unable to connect - Solved!

    Hello,

    I wanted to give HomeSeer a try. I've followed this post on how to install HomeSeer on a Ubuntu VM. When I try and go to the VM's Ip in my browser, I get the error "This site can't be reached". How can I get this up and running on my VM?

    Any assistance would be greatly appreciated.

    Loren

    #2
    I think I've mad a couple of steps in the right direction. Here is the log from HomeSeer starting:


    Code:
    12:47:33:1632:[Database]->Opening (Mode=Read Only) up HomeSeer LOG database /home/loren/HomeSeer/Logs/HomeSeerLog.hsd
    12:47:33:2641:[Startup]->Loading Settings
    12:47:33:3282:[Startup]->Settings Loaded.
    12:47:33:8294:[Startup]->
    12:47:33:8297:[Startup]->********************************************************************************
    12:47:33:8306:[Startup]->            HomeSeer version 3.0.0.435 Edition: HS3 Pro Starting Now
    12:47:33:8310:[Startup]->********************************************************************************
    12:47:33:8314:[Startup]->
    12:47:33:8444:[Startup]->Creating Class Objects...
    12:47:33:8463:[Startup]->COM port classes started.
    12:47:33:8494:[Startup]->Application interface class started.
    12:47:33:8812:[Startup]->Web server class started.
    12:47:33:8823:[Startup]->E-Mail SEND class started.
    12:47:33:8828:[Startup]->E-Mail RECEIVE class started.
    12:47:33:8859:[Startup]->Plug-In Interface class started.
    12:47:33:8873:[Startup]->Local voice recognition class started.
    12:47:33:8896:[Startup]->Database SAVE process started.
    12:47:33:8899:[Startup]->Loading configuration file ...
    12:47:33:9028:[Database]->Opening (Mode=Read Only) up HomeSeer database /home/loren/HomeSeer/Data/HomeSeerData.hsd
    12:47:33:9096:[Warning]->Configuration database has no devices in it: /home/loren/HomeSeer/Data/HomeSeerData.hsd
    12:47:33:9104:[Database]->Loading Devices...
    12:47:33:9107:[Load Config]->0 total devices loaded.
    12:47:33:9136:[Load Config]->Loading Event Groups...
    12:47:33:9185:[Load Config]->Loading Events...
    12:47:33:9213:[Load Config]->0 total events loaded.
    12:47:33:9215:[Load Config]->Loading COUNTERS...
    12:47:33:9266:[Load Config]->Loading TIMERS...
    12:47:33:9368:[Startup]->HomeSeer version is: 3.0.0.435
    12:47:33:9374:[Startup]->Creating Speaker Client Interface Object...
    12:47:33:9404:[Warning]->This version of HomeSeer is not registered and is currently disabled
    12:47:34:0148:[Error]->Unable to start plug-in API: Address already in use
    12:47:34:0153:[Startup]->Checking for available plug-ins
    12:47:34:0257:[Startup]->Initializing Plug-Ins
    12:47:34:0504:[HSTouch Server]->Server started on port 10200
    12:47:34:0533:[Startup]->HStouch server started, waiting for clients to connect.
    12:47:34:0724:[Web Server]->Local IP address is: 192.168.17.59
    12:47:34:0775:[Web Server]->Web Server started on port 8085
    12:47:34:0981:[Startup]->Start automation engine...
    12:47:34:1004:[Startup]->Initializing Speaker Client Interface
    12:47:34:1059:[Error]->Unable to start remote speech API: Address already in use
    12:47:34:1062:[Speech]->Listening for remote speaker connections on port 10401
    12:47:34:1141:[Database]->Opening (Mode=Read/Write) up HomeSeer Energy database /home/loren/HomeSeer/Data/Energy/Energy.hsd
    12:47:34:1223:[Startup]->Updater services starting...
    12:47:34:1237:[Startup]->Starting Find service...
    12:47:34:1291:[Startup]->Starting Event Scheduler...
    12:47:34:1360:[Startup]->HSSentry is disabled in Setup, sentry will not be started.
    12:47:34:1377:[Startup]->Start up complete.
    Type 'shutdown' to shutdown HomeSeer
    
    > 12:47:34:2012:[Info]->System connected to MyHS Service, waiting for acknowledge...
    I've tried going to 192.168.17.59:8085 but the browser just sits and tries to access the webpage without any connection.

    Anyone have any thoughts?

    Comment


      #3
      You modified settings.ini in Config directory to have the web server listen on port 8085 or something? The default port is 80, then you should be able to change it in Tools>Setup>Network - I'm just guessing since it seems you have a clean setup and haven't accessed the GUI in your browser yet.

      Also, from the looks of your IP address, you are using a NAT or Host config on your VM. Try changing it to a Bridged network so you can assign your VM a unique IP address. Generate a MAC address for the virtual Ethernet card under the VM's settings and then assign that MAC a static IP in your router. Reboot the VM and try the static IP in your browser. If you need to use another port to access the server you can assign it one then.

      Comment


        #4
        I also have this problem. After Ubuntu installation and changing the port, I get the following. Ctrl-C gets it to stop. Any help would be appreciated.

        10/3/2020 4:39:43 PM HomeSeer~!~Database~!~Opening (Mode=Read Only) up HomeSeer LOG database /usr/local/HomeSeer/Logs/HomeSeerLog.hsd
        10/3/2020 4:39:43 PM HomeSeer~!~Startup~!~Loading Settings
        10/3/2020 4:39:43 PM HomeSeer~!~Startup~!~Settings Loaded.
        10/3/2020 4:39:43 PM HomeSeer~!~Startup~!~
        10/3/2020 4:39:43 PM HomeSeer~!~Startup~!~*************************************** *****************************************
        10/3/2020 4:39:43 PM HomeSeer~!~Startup~!~ HomeSeer version 4.1.6.0 Edition: HS4 Pro Starting Now
        10/3/2020 4:39:43 PM HomeSeer~!~Startup~!~*************************************** *****************************************
        10/3/2020 4:39:43 PM HomeSeer~!~Startup~!~
        10/3/2020 4:39:43 PM HomeSeer~!~Startup~!~Creating Class Objects...
        10/3/2020 4:39:43 PM HomeSeer~!~Startup~!~COM port classes started.
        10/3/2020 4:39:43 PM HomeSeer~!~Startup~!~Application interface class started.
        10/3/2020 4:39:43 PM HomeSeer~!~Startup~!~Web server class started.
        10/3/2020 4:39:43 PM HomeSeer~!~Startup~!~E-Mail SEND class started.
        10/3/2020 4:39:43 PM HomeSeer~!~Startup~!~E-Mail RECEIVE class started.
        10/3/2020 4:39:43 PM HomeSeer~!~Startup~!~Plug-In Interface class started.
        10/3/2020 4:39:43 PM HomeSeer~!~Startup~!~Local voice recognition class started.
        10/3/2020 4:39:43 PM HomeSeer~!~Startup~!~Loading configuration file ...
        10/3/2020 4:39:43 PM HomeSeer~!~Warning~!~Unable to load devices config file, trying backup
        10/3/2020 4:39:43 PM HomeSeer~!~Warning~!~Unable to load event groups config file, trying backup
        10/3/2020 4:39:43 PM HomeSeer~!~Warning~!~Unable to load events config file, trying backup
        10/3/2020 4:39:43 PM HomeSeer~!~Startup~!~HomeSeer version is: 4.1.6.0
        10/3/2020 4:39:43 PM HomeSeer~!~Startup~!~Creating Speaker Client Interface Object...
        10/3/2020 4:39:43 PM HomeSeer~!~Warning~!~This version of HomeSeer is not registered and is currently disabled
        10/3/2020 4:39:43 PM HomeSeer~!~Web Server~!~Local IP address is: 192.168.11.3
        10/3/2020 4:39:43 PM HomeSeer~!~Web Server~!~Web Server started on port 89
        10/3/2020 4:39:43 PM HomeSeer~!~Startup~!~Start automation engine...
        10/3/2020 4:39:43 PM HomeSeer~!~Startup~!~Initializing Speaker Client Interface
        10/3/2020 4:39:43 PM HomeSeer~!~Error~!~Unable to start remote speech API: Address already in use
        10/3/2020 4:39:43 PM HomeSeer~!~Speech~!~Listening for remote speaker connections on port 10401
        10/3/2020 4:39:43 PM HomeSeer~!~Database~!~Opening (Mode=Read/Write) up HomeSeer Energy database /usr/local/HomeSeer/Data/Energy/Energy.hsd
        10/3/2020 4:39:43 PM HomeSeer~!~Startup~!~Updater services starting...
        10/3/2020 4:39:43 PM HomeSeer~!~Startup~!~Starting Find service...
        10/3/2020 4:39:43 PM HomeSeer~!~Error~!~Unable to start plug-in API: Address already in use
        10/3/2020 4:39:43 PM HomeSeer~!~Startup~!~Checking for available plug-ins
        10/3/2020 4:39:43 PM HomeSeer~!~Startup~!~Initializing Plug-Ins
        10/3/2020 4:39:43 PM HomeSeer~!~HSTouch Server Error~!~Exception in client listener: Address already in use restarting...
        10/3/2020 4:39:43 PM HomeSeer~!~HSTouch Server Error~!~Exception in client listener: Address already in use restarting...
        10/3/2020 4:39:43 PM HomeSeer~!~HSTouch Server Error~!~Exception in client listener: Address already in use restarting...
        10/3/2020 4:39:43 PM HomeSeer~!~HSTouch Server Error~!~Exception in client listener: Address already in use restarting...
        10/3/2020 4:39:43 PM HomeSeer~!~HSTouch Server Error~!~Exception in client listener: Address already in use restarting...
        10/3/2020 4:39:43 PM HomeSeer~!~HSTouch Server Error~!~Exception in client listener: Address already in use restarting...
        10/3/2020 4:39:43 PM HomeSeer~!~HSTouch Server Error~!~Exception in client listener: Address already in use restarting...
        10/3/2020 4:39:43 PM HomeSeer~!~HSTouch Server Error~!~Exception in client listener: Address already in use restarting...
        10/3/2020 4:39:43 PM HomeSeer~!~HSTouch Server Error~!~Exception in client listener: Address already in use restarting...
        10/3/2020 4:39:43 PM HomeSeer~!~HSTouch Server Error~!~Exception in client listener: Address already in use restarting...
        10/3/2020 4:39:43 PM HomeSeer~!~HSTouch Server Error~!~Exception in client listener: Address already in use restarting...
        10/3/2020 4:39:43 PM HomeSeer~!~HSTouch Server Error~!~Exception in client listener: Address already in use restarting...
        10/3/2020 4:39:43 PM HomeSeer~!~HSTouch Server Error~!~Exception in client listener: Address already in use restarting...
        10/3/2020 4:39:43 PM HomeSeer~!~HSTouch Server Error~!~Exception in client listener: Address already in use restarting...
        10/3/2020 4:39:43 PM HomeSeer~!~HSTouch Server Error~!~Exception in client listener: Address already in use restarting...

        Comment


          #5
          Disable the auto start of Homeseer. Restart the box and using terminal or SSH start HS manually. It almost looks like HS is starting twice. Note this is just a guesstimate.
          - Pete

          Auto mator
          Homeseer 3 Pro - 3.0.0.548 (Linux) - Ubuntu 18.04/W7e 64 bit Intel Haswell CPU 16Gb- Mono 6.12.X - HSTouch on Intel tabletop tablets
          Homeseer Zee2 (Lite) - 3.0.0.548 (Linux) - Ubuntu 18.04/W7e - CherryTrail x5-Z8350 BeeLink 4Gb BT3 Pro - Mono 6.12.X
          HS4 Pro - V4.1.11.0 - Ubuntu 20.01/VB W7e 64 bit Intel Kaby Lake CPU - 32Gb - Mono
          6.10.0.104
          HS4 Lite -

          X10, UPB, Zigbee, ZWave and Wifi MQTT automation-Tasmota-Espurna. OmniPro 2, Russound zoned audio, Smartthings hub, Hubitat Hub, and Home Assistant

          Comment


            #6
            Homeseer does not appear to be auto starting. /etc/systemd/system/homeseer.service does not exist, and there is no Homeseer service running.

            After waiting several days and another reboot, it looks like the above resolved itself.

            I now get a message stating (I wish I'd saved the redirect message) when browsing to http://<IP_Address>:<port>.

            In short, the fix for this is browsing to http://<IP_Address>:<port>/register.html, and filling in the form.

            Comment

            Working...
            X