Announcement

Collapse
No announcement yet.

Mono installation freezes at an annoying 99%

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • concordseer
    replied
    You’re recompiling a very extensive code base so depending on your connection speed you could end up sitting and watching it for hours.

    On a 500mb/s connection it takes me approximately 15 minutes for that task to complete.

    At least you now have the latest version of Mono from the Mono Project instead of an outdated version from the repos.

    If you’ve ever built and compiled code from a GitHub they always advise heading off for a coffee during the process.

    Leave a comment:


  • Pete
    replied
    Mono today is owned by Microsoft. They are sinking their teeth in to it. ^;;^

    From the Wiki...

    Mono's current version is 6.0.0 (as of August 2019). This version provides the core API of the .NET Framework and support for Visual Basic.NET and C# 7.0. LINQ to Objects, XML, and SQL are part of the distribution. Windows Forms 2.0 is also supported, but not actively developed, and as such its support on Mono is incomplete. Version 4.0 was the first version that incorporates Microsoft original source code that was released by Microsoft as part of the .NET Core project.

    Leave a comment:


  • pc__hs
    replied
    Smart. For me all of this is new territory so I watch every move in fear of any mishaps. Getting there though.

    Leave a comment:


  • Pete
    replied
    Good news. I just walk away and not watch the Mono updates any more as they are very time consuming. Faster for me on Intel CPUs and slower on Arm CPUs.

    Leave a comment:


  • pc__hs
    replied
    ... and after two hours sitting there, and just minutes after I posted.. guess what : it completed successfully. Classic.

    Case closed.

    Leave a comment:


  • pc__hs
    started a topic Mono installation freezes at an annoying 99%

    Mono installation freezes at an annoying 99%

    Hi,

    I use a hometroller SEL with Lubuntu 18.04 64bit.

    I've had to rebuild the machine from scratch. Fresh new install of Lubuntu.

    Now installing Mono-complete and it hangs at 99% on this process:

    Mono precompiling /usr/lib/mono/4.5/Microsoft.CodeAnalysis.VisualBasic.dll for amd64 (trying with LLVM, this might take a few minutes)...

    Can someone help me get out of this successfully?

    I'm not a linux user (or developer or computer scientist) so will need help with commands. Sorry for the annoyance.

    Thanks,

    Pete
Working...
X