Announcement

Collapse
No announcement yet.

Aeotec Heavy Duty Switch - Not Autoreporting Changes

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Aeotec Heavy Duty Switch - Not Autoreporting Changes

    I just installed an Aeotec Heavy Duty Switch and can't get it to auto-report changes in Watts (or % changes). I have an Aeotec Smart Switch 6 the auto-reports Wattage chagnes just fine.

    Devices created when added to network:
    --Root Node
    --Switch control
    --Amperes
    --kW Hours
    --Volts
    --Watts

    Here's what I've tried:
    1) Added to Z-wave network. The first time I got the security warning/error. Removed and re-added--worked fine the second time.
    2) It is reporting kWh, W, and A on the time-bases that specified in the Root Device's Z-Wave settings.
    3) See screen-shot of the Z-Wave settings page (attached). The 65460 setting for "how often the data is automatically sent" is copied from my Smart Switch 6 settings. I only want it to report when the Watts changes. If I change that value to 30, it does report every 30 seconds.
    4) Manually set the configuration parameters (in the following order), using the "Set Configuration Parameters" in the Settings section.
    -Set Parameter 101 to 12 [4-bytes] (kWh & Watt)
    -Set Parameter 91 to 10 [2-bytes] (Watts)
    -Set Parameter 92 to 5 [1-bytes] (Percent)
    -Set Parameter 90 to 1 [1-bytes] (Enable change reporting)
    5) Disconnected power, waited 15 seconds, reconnected power to the device. Is still reports at set interval, but still doesn't report on Wattage changes.

    Any ideas anyone??


    Thanks,
    --Doug

    #2
    Click image for larger version

Name:	Skärmbild från 2019-11-14 19-36-44.png
Views:	250
Size:	29.6 KB
ID:	1340056 Try to associate group 2 to HomeSeer

    Comment


      #3
      Thanks for the suggestion, but unfortunately associating Group 2 to Homeseer didn't fix it.

      Comment


        #4
        This is what I did to get mine working.

        1. Set Parameter 13 = 0
        2. Delete Associations
        3. Re-set Group #1 association to Node ID 1 NO ENDPOINT!!

        Comment


          #5
          I also added the kWh, W, and A as data values to be sent to group 2. Still doesn't report on a Wattage change.

          Comment


            #6
            Thanks Bill1219,

            I followed the 3 steps, but that didn't do it either. Couple questions...
            1. Is parameter 13 a 1-byte parameter? I assumed it was when I set it to 0. I also assumed it was decimal 13 and not hexidecimal 0x13.
            2. What is parameter 13 for? I don't see it mentioned in the Aeotec documentation.
            3. I didn't see any option on endpoints for the HD Switch Root device. Where would that option be?
            Thanks!

            Comment


              #7
              Saw title and immediately thought "they forgot to adjust hidden Z-Wave parameters" to force Aeotec devices to auto-report as I've had to do on most-if-not-all AeonLabs/Aeotec switches and dimmers.

              What is your 0x50 (80 decimal) parameter set to? Hail CC (1) might be needed, and if yours is currently set to 0, then that would explain your situation.

              Comment


                #8
                Sorry about that. Those notes I was looking at were for the Aeotec HEM not the Heavy duty switch.
                I hope it did not mess anything up! Not sure what was going on in my head, brain fog or something.

                Comment


                  #9
                  Bill1219,

                  Apparently no harm done. I don't see any operational difference after setting parameter 13 to 0.

                  Comment


                    #10
                    RoChess,

                    Thanks! That got me 90% of the way there. It sounded like Parameter 80 might be related to my issue, but I wasn't sure enough to mess with it.

                    Setting Parameter 80 to 1 (Hail CC) has it reporting changes in Wattage, but only in the intervals set by parameter 111. So... If I have the time interval set to 5 seconds, it will only report changes every 5 seconds (curiously to the same second for every report--even if reports are not sent for several 5-second intervals). If I have 111 set to 60, no matter how many changes take place, it will only report once every minute.

                    Example:
                    5-Second interval only reports on "3" and "8" second marks
                    Nov-14 16:50:28 Z-Wave Device: Energy Basement Dryer Watts Set to 0 (0 Watts)
                    Nov-14 16:50:23 Z-Wave Device: Energy Basement Dryer Watts Set to 1754.75 (1754.75 Watts)
                    Nov-14 16:50:08 Z-Wave Device: Energy Basement Dryer Watts Set to 0 (0 Watts)
                    Nov-14 16:50:18 Z-Wave Device: Energy Basement Dryer Watts Set to 5422.281 (5422.281 Watts)
                    Nov-14 16:49:48 Z-Wave Device: Energy Basement Dryer Watts Set to 0 (0 Watts)
                    Nov-14 16:50:03 Z-Wave Device: Energy Basement Dryer Watts Set to 5496.018 (5496.018 Watts)
                    This is different from my Smart Switch 6 which reports at any time a Wattage changes.


                    =============================================
                    90% Solved: Only reports changes at the specified interval
                    =============================================
                    1. Set up Root device as shown in attached picture.
                    2. Set the Watt change and % Watt change through parameters 91 & 92
                    3. Make sure Parameter 90 is enabled
                    4. Set Parameter 80 to 1 (1-byte). This will report once every time period if a Wattage change occurs. Report rate set by "Automatic Report Rate" (Parameter decimal 111).


                    Comment


                      #11
                      Maybe you need to try setting param 80 to 2 then to send basic report, but I could swear that Hail-CC kicks in the auto notification and then you can adjust all the other relative params to configure the threshold, such as for example only report if power usage goes up/down 50Watt as to not cram Z-Wave network full with useless updates.

                      Would have to dig up Aeotec manual to verify, as I don't own the heavy duty node, but remembered the 80-param from having helped somebody else.

                      Otherwise settle for 90% and revisit it another day

                      Once HS4 is launched and HomeSeer development team has time available again, I plan to work with them to get all the AeonLabs/Aeotec parameters exposed properly as we should not have to manually configure those. Seems HomeSeer will only whitelist parameters if they have physical access to the device, so I plan to cross-ship them a wide variety, but have no usage for heavy duty node, so hopefully it will still end up getting more expanded support indirectly.

                      Comment


                        #12
                        Originally posted by dwoolridge View Post
                        RoChess,

                        Thanks! That got me 90% of the way there. It sounded like Parameter 80 might be related to my issue, but I wasn't sure enough to mess with it.

                        Setting Parameter 80 to 1 (Hail CC) has it reporting changes in Wattage, but only in the intervals set by parameter 111. So... If I have the time interval set to 5 seconds, it will only report changes every 5 seconds (curiously to the same second for every report--even if reports are not sent for several 5-second intervals). If I have 111 set to 60, no matter how many changes take place, it will only report once every minute.

                        Example:
                        5-Second interval only reports on "3" and "8" second marks
                        Nov-14 16:50:28 Z-Wave Device: Energy Basement Dryer Watts Set to 0 (0 Watts)
                        Nov-14 16:50:23 Z-Wave Device: Energy Basement Dryer Watts Set to 1754.75 (1754.75 Watts)
                        Nov-14 16:50:08 Z-Wave Device: Energy Basement Dryer Watts Set to 0 (0 Watts)
                        Nov-14 16:50:18 Z-Wave Device: Energy Basement Dryer Watts Set to 5422.281 (5422.281 Watts)
                        Nov-14 16:49:48 Z-Wave Device: Energy Basement Dryer Watts Set to 0 (0 Watts)
                        Nov-14 16:50:03 Z-Wave Device: Energy Basement Dryer Watts Set to 5496.018 (5496.018 Watts)
                        This is different from my Smart Switch 6 which reports at any time a Wattage changes.


                        =============================================
                        90% Solved: Only reports changes at the specified interval
                        =============================================
                        1. Set up Root device as shown in attached picture.
                        2. Set the Watt change and % Watt change through parameters 91 & 92
                        3. Make sure Parameter 90 is enabled
                        4. Set Parameter 80 to 1 (1-byte). This will report once every time period if a Wattage change occurs. Report rate set by "Automatic Report Rate" (Parameter decimal 111).

                        I have picked up the heavy duty switch for the clothes dryer as well. I am seeing the same behavior as the OP. Specifically that it only reports on a fixed internal not after a change in percentage or a certain number of watts. For my use case, this is fine. What I noticed in OP's quoted post is that his dryer also bounces between 0 watts and ~5000 watts. Mine does this as well and it causes trouble when trying to determine when a load is finished drying. I have an aging ticket open with Aeotec support that isn't going anywhere. Does anyone know if this is expected behavior?

                        Thanks.

                        Comment


                          #13
                          Don't configure it to poll on X-seconds, but configure the Aeotec to push changes when delta exceeds threshold value. This is either defined in a fixed value, say +/- 25W, or +/- 5%, and then you adjust it per the main appliance power-usage characteristics, which are going to be different for a 5kW dryer than for a 15Watt floodlight.

                          It can be tricky to configure as HomeSeer lacks native parameter support for these devices (and still does not offer a user managed system like SmarterThings and other systems offer), but Aeotec makes good manuals and it is all in there, and in HomeSeer you have full control to read each setting and then reconfigure it to the way you want it.

                          By default usage reporting tends to be disabled, because it adds a lot of extra traffic on your network depending on the power-usage of the appliance, so you often have to specifically turn it on to the way you want it.

                          For me every individual light (or group of LEDs), appliance, and panel/sub-panel reports their power usage, but not many have a wild power-usage pattern. Especially the lights, once I turn them on, then they go from 0Watt to say 5.8Watt and will stay there until I turn them off (or adjust dim-level), which means only one Z-Wave push package gets send and network remains nice and clean.

                          Even at 40Kbps there is plenty of room for a lot of packages without causing a "delay" when you want something to happen, but of course if you start heading towards 100+ nodes then things can get very crowded, so take things slowly and monitor the logs to verify the impact.

                          Comment


                            #14
                            Assuming we are all referring to the ZW078-A, parameter 80 is only for reporting a change of load state (on/off). 90, 91 and 92 have to do with wattage reporting. 90 enables reporting, 91 sets the change in wattage to trigger a report and 92 is to configure a percentage change to trigger.


                            Click image for larger version

Name:	80C4227C-B88B-49C4-B501-24521C02FEF8.jpeg
Views:	141
Size:	107.3 KB
ID:	1367799

                            Comment


                              #15
                              @AZweimille how is the Aeotec working for you? I'm close to recommending it to a customer who just needs the energy monitoring function for a heavy load. This is the only device I've found that will handle 20A and do the reporting.

                              Comment

                              Working...
                              X